CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM

Foam-extend -3.0 installation problem

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   January 6, 2015, 06:43
Default Foam-extend -3.0 installation problem
  #1
New Member
 
serkan
Join Date: Dec 2014
Posts: 7
Rep Power: 3
Sermengi is on a distinguished road
Hi everyone,

I am trying to install foam-extend-3.0 following the steps in this web page: http://openfoamwiki.net/index.php/In...oam-extend-3.0. I am using Linux system Ubuntu version 12.04. Also my OpenFoam version is 2.1.1. I have trouble compiling the foam-extend. I set the enviromnet variable and write the f30 command on terminal i get this message:

sermengi@sermengi-VirtualBox:~/foam/foam-extend-3.0$ fe30
bash: /opt/foam-extend-3.0/bin/foamGetSystemInfo: No such file or directory
bash: /opt/foam-extend-3.0/bin/foamCleanPath: No such file or directory
bash: /opt/foam-extend-3.0/bin/foamCleanPath: No such file or directory
bash: /opt/foam-extend-3.0/bin/foamCleanPath: No such file or directory
bash: /opt/foam-extend-3.0/etc/settings.sh: No such file or directory
bash: /opt/foam-extend-3.0/etc/aliases.sh: No such file or directory
bash: /opt/foam-extend-3.0/bin/foamCleanPath: No such file or directory
bash: /opt/foam-extend-3.0/bin/foamCleanPath: No such file or directory
bash: /opt/foam-extend-3.0/bin/foamCleanPath: No such file or directory

The problem that is mentioned above is about setting the enviroment variable. But i couldn't solve this problem. I search this issue, try to install again but these didn't work for me. Also when i write the ./Allwmake.firstInstall command on terminal i get error message again,

sermengi@sermengi-VirtualBox:~/foam/foam-extend-3.0$ ./Allwmake.firstInstall

Error: Current directory is not $WM_PROJECT_DIR
The environment variables are not consistent with the installation.
Please source configuration files.

Examples:
bash: . etc/bashrc
tcsh: source etc/cshrc

If you sourced the configuration files, please check the 'foamInstall' entry.

I did exactly same thing in steps. I did not change anything when installing foam-extend. I stuck this problem more than 4 days and i couldn't solve this. I hope, i can explain myself very clear. Please help me.

Best regards,
Sermengi.
Sermengi is offline   Reply With Quote

Reply

Tags
compile error, openfaom

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Take derivative of mean velocity in paraFoam hiuluom OpenFOAM Paraview & paraFoam 13 April 26, 2016 06:44
problem with RBF in tho Foam 3.0 extend Vesek OpenFOAM Programming & Development 4 June 16, 2014 04:22
Negative Cell Volume with moveDyMEngineMesh with Foam Extend 3.0 RJ87 OpenFOAM 2 May 8, 2014 12:13
Basic Error when installing swak4foam with foam extend 3.0 mnobrega OpenFOAM Installation 6 April 1, 2014 01:47
Import gmsh msh to Foam adorean Open Source Meshers: Gmsh, Netgen, CGNS, ... 24 April 27, 2005 08:19


All times are GMT -4. The time now is 08:03.