CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > OpenFOAM

viewFactor radiation model stuck

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   September 16, 2019, 19:14
Default viewFactor radiation model stuck
  #1
New Member
 
shach
Join Date: Apr 2019
Posts: 26
Rep Power: 5
shach934 is on a distinguished road
Hi,
I am using chtMultiRegionSimpleFoam to solve a multiregion heat transfer problem. The surface2surface/viewFactor radiation model is employed. I tried without the radiation on, it works fine. When the radiation is turned on, faceAgglomerate and viewFactors are generated. About 30000 agglomerated surface is generated. However, when I started the simulation in parallel the model is stucked at loading viewFactor stage, like the following:

Selecting boundary radiation Model: opaqueDiffusive
Selecting boundary radiation Model: opaqueDiffusive
Selecting boundary radiation Model: opaqueDiffusive
Selecting boundary radiation Model: opaqueDiffusive
Selecting boundary radiation Model: opaqueDiffusive
Selecting boundary radiation Model: opaqueDiffusive
Selecting boundary radiation Model: opaqueDiffusive
Selecting boundary radiation Model: opaqueDiffusive
Selecting boundary radiation Model: opaqueDiffusive
Selecting boundary radiation Model: lookup
Selecting boundary radiation Model: lookup


I tried with much less agglomerated surface ~5000 and single core. It works. The model is using several techniques, MRF, anisotropic material properties in cylinder coordinate system, volume heat source. Is 30000 faces a high number or I set something wrong? Any suggestion is high appreciated!
Thanks.
shach934 is offline   Reply With Quote

Old   May 25, 2021, 12:01
Default
  #2
New Member
 
Jonas
Join Date: Dec 2020
Posts: 5
Rep Power: 4
JonL is on a distinguished road
Quote:
Originally Posted by shach934 View Post
Hi,
I am using chtMultiRegionSimpleFoam to solve a multiregion heat transfer problem. The surface2surface/viewFactor radiation model is employed. I tried without the radiation on, it works fine. When the radiation is turned on, faceAgglomerate and viewFactors are generated. About 30000 agglomerated surface is generated. However, when I started the simulation in parallel the model is stucked at loading viewFactor stage, like the following:

Selecting boundary radiation Model: opaqueDiffusive
Selecting boundary radiation Model: opaqueDiffusive
Selecting boundary radiation Model: opaqueDiffusive
Selecting boundary radiation Model: opaqueDiffusive
Selecting boundary radiation Model: opaqueDiffusive
Selecting boundary radiation Model: opaqueDiffusive
Selecting boundary radiation Model: opaqueDiffusive
Selecting boundary radiation Model: opaqueDiffusive
Selecting boundary radiation Model: opaqueDiffusive
Selecting boundary radiation Model: lookup
Selecting boundary radiation Model: lookup


I tried with much less agglomerated surface ~5000 and single core. It works. The model is using several techniques, MRF, anisotropic material properties in cylinder coordinate system, volume heat source. Is 30000 faces a high number or I set something wrong? Any suggestion is high appreciated!
Thanks.
Hey shach,


so I realize I'm rather late to the party, but did you by any chance find a way to solve your issue? I am currently in a similar situation in which the simulation crashes after selecting each boundary radiation model and then simply crashes with a rather cryptic error regarding viewFactor and radiationModel, which I am uncertain on how to deal with.


Greetings,


Jonas
JonL is offline   Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
stuck in simple evaporation model mossaied Main CFD Forum 0 November 21, 2018 15:21
simplifiedSiwek - error in calculating the position of a coal error guitar_love_15 OpenFOAM Running, Solving & CFD 0 November 4, 2018 05:06
manualInjection model in sprayFoam Mentalo OpenFOAM Running, Solving & CFD 1 April 2, 2014 10:29
Discrete Phase Model (bubbles stuck in an eddy) sahraaan FLUENT 0 September 8, 2011 01:32
Problems bout CFD model of biomass gasification, Downdraft gasifier wanglong FLUENT 2 November 26, 2009 00:27


All times are GMT -4. The time now is 08:29.