CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > OpenFOAM

FOAM FATAL IO ERROR: Bad token - could not get scalar value file: 0/alpha.water

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   April 3, 2023, 14:42
Default FOAM FATAL IO ERROR: Bad token - could not get scalar value file: 0/alpha.water
  #1
New Member
 
Shuvashish Roy
Join Date: Mar 2023
Posts: 6
Rep Power: 3
sroy is on a distinguished road
Hi,
I am an absolute begineer in OF. I am trying to run a simulation of simple intake struture with culvert. However, when I run the following command:
Code:
mpiexec -n 20 setFields |tee setfields.out
OF gives me followig errors:

Code:
......
--> FOAM FATAL IO ERROR: (openfoam-
--> FOAM FATAL IO ERROR:
2206
--> FOAM FATAL IO ERROR:
(openfoam-
--> FOAM FATAL IO ERROR:
)
(openfoam-
2206
(openfoam-

2206
)
2206
Bad token - could not get scalar value
)

file:
file:
0/alpha.water
0/alpha.water
 at line
 at line
1616910
1675675
.
.




    From
    From
Foam::Istream& Foam::operator>>(Foam::Istream&, Foam::doubleScalar&)
Foam::Istream& Foam::operator>>(Foam::Istream&, Foam::doubleScalar&)
.....
Though it writes a alpha.water file and runs
Code:
mpiexec -n 20 interFoam -parallel |tee interfoam.out
I am not sure what is causing the error in setFields and alpha.water. Please let me know if I should upload the case files. Thanks.

Last edited by sroy; April 4, 2023 at 16:15.
sroy is offline   Reply With Quote

Old   April 5, 2023, 12:47
Default SetFields is serial only
  #2
New Member
 
Join Date: Jun 2019
Location: United States
Posts: 15
Rep Power: 6
ryanc6 is on a distinguished road
Roy,

The setFields utility cannot be run on multiple processors. If you run on a single processor this should work fine.
ryanc6 is offline   Reply With Quote

Old   April 5, 2023, 12:56
Default
  #3
New Member
 
Shuvashish Roy
Join Date: Mar 2023
Posts: 6
Rep Power: 3
sroy is on a distinguished road
Ryan, I can't thank you enough for your help with my openFOAM problems.
sroy is offline   Reply With Quote

Reply

Tags
alpha.water, fatal io error, setfields

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
[openSmoke] LaminarSMOKE compilation error mdhfiz OpenFOAM Community Contributions 7 October 4, 2022 13:57
[foam-extend.org] Problems installing foam-extend-4.0 on openSUSE 42.2 and Ubuntu 16.04 ordinary OpenFOAM Installation 19 September 3, 2019 18:13
[swak4Foam] build problem swak4Foam OF 2.2.0 mcathela OpenFOAM Community Contributions 14 April 23, 2013 13:59
Version 15 on Mac OS X gschaider OpenFOAM Installation 113 December 2, 2009 10:23
error while compiling the USER Sub routine CFD user CFX 3 November 25, 2002 15:16


All times are GMT -4. The time now is 05:06.