CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Visualization & Post-Processing Software > ParaView

[General] Trouble installing ParaView from source

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   June 15, 2016, 09:32
Unhappy Trouble installing ParaView from source
  #1
Member
 
Jack_Landis's Avatar
 
Join Date: Feb 2016
Posts: 32
Rep Power: 10
Jack_Landis is on a distinguished road
Dear all,

I'm fighting with ParaView wiki in order to install it from source... I have Ubuntu 15.10 and want to install ParaView 3.12, so I need to compile it from source...

This is the wiki I'm following:

http://www.paraview.org/Wiki/index.p...ll&oldid=46445

I can arrive without problems to "configure ParaView with cmake" but then it make no sense anymore for me...It is told this:

"Use ccmake (Curses CMake GUI) from the CMake installed location. CCMake is a Curses based GUI for CMake. To run it go to the build directory and specify as an argument the src directory."

What does this mean? There is some command after this few lines but they call a folder I haven't created...

I really don't know what to do...Can please someone help me?
__________________
Omnia per ipsum facta sunt,
et sine ipso factum est nihil,
quod factum est


Jack_Landis is offline   Reply With Quote

Old   June 15, 2016, 10:06
Default
  #2
Member
 
Jack_Landis's Avatar
 
Join Date: Feb 2016
Posts: 32
Rep Power: 10
Jack_Landis is on a distinguished road
I succeeded in starting ccmake...Now it gives me these errors:

CMake Error at
/usr/share/cmake-3.2/Modules/FindPackageHandleStandardArgs.cmake:138
(message):
Could NOT find MPI_C (missing: MPI_C_LIBRARIES MPI_C_INCLUDE_PATH)
Call Stack (most recent call first):
/usr/share/cmake-3.2/Modules/FindPackageHandleStandardArgs.cmake:374
(_FPHSA_FAILURE_MESSAGE)
/usr/share/cmake-3.2/Modules/FindMPI.cmake:616
(find_package_handle_standard_args)
VTK/CMakeLists.txt:896 (FIND_PACKAGE)

What shall I do?
__________________
Omnia per ipsum facta sunt,
et sine ipso factum est nihil,
quod factum est


Jack_Landis is offline   Reply With Quote

Old   June 20, 2016, 05:47
Default
  #3
New Member
 
Luke
Join Date: May 2016
Posts: 3
Rep Power: 10
Luke9571 is on a distinguished road
Quote:
Originally Posted by Jack_Landis View Post
I succeeded in starting ccmake...Now it gives me these errors:

CMake Error at
/usr/share/cmake-3.2/Modules/FindPackageHandleStandardArgs.cmake:138
(message):
Could NOT find MPI_C (missing: MPI_C_LIBRARIES MPI_C_INCLUDE_PATH)
Call Stack (most recent call first):
/usr/share/cmake-3.2/Modules/FindPackageHandleStandardArgs.cmake:374
(_FPHSA_FAILURE_MESSAGE)
/usr/share/cmake-3.2/Modules/FindMPI.cmake:616
(find_package_handle_standard_args)
VTK/CMakeLists.txt:896 (FIND_PACKAGE)

What shall I do?
You have to install the library and add te path to the cmake configure
Luke9571 is offline   Reply With Quote

Old   June 20, 2016, 11:18
Default
  #4
Member
 
Jack_Landis's Avatar
 
Join Date: Feb 2016
Posts: 32
Rep Power: 10
Jack_Landis is on a distinguished road
Thank you Luke! I abandoned the idea of compiling Paraview from source and tried instead using an executable version...This is not as good but for the moment it works.
__________________
Omnia per ipsum facta sunt,
et sine ipso factum est nihil,
quod factum est


Jack_Landis is offline   Reply With Quote

Reply

Tags
build, paraview 3.12, source

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
[swak4Foam] Installation Problem with OF 6 version Aurel OpenFOAM Community Contributions 14 November 18, 2020 16:18
Problem compiling a custom Lagrangian library brbbhatti OpenFOAM Programming & Development 2 July 7, 2014 11:32
[swak4Foam] Swak4FOAM 0.2.3 / OF2.2.x installation error FerdiFuchs OpenFOAM Community Contributions 27 April 16, 2014 15:14
[swak4Foam] problem on installing swak4Foam navid2 OpenFOAM Community Contributions 2 May 30, 2012 04:32
DecomposePar links against liblamso0 with OpenMPI jens_klostermann OpenFOAM Bugs 11 June 28, 2007 17:51


All times are GMT -4. The time now is 23:34.