CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Visualization & Post-Processing Software > ParaView

[OpenFOAM] Problem with xy plot

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   April 8, 2008, 05:55
Default Problem with xy plot
  #1
Member
 
Vivien
Join Date: Mar 2009
Posts: 52
Rep Power: 17
sunnysun is on a distinguished road
Hi, everyone

I have a problem with x-y plot in paraview. I tired with several tutorials but seems i could not get the velocity profile accross a single line.

For example after i run with icofoam and start the paraview,the steps are:

1)select a time instance
2)filter-> append dataset
3)filter->probe

Then I select 'line' as a probe object and specify two points.
However, only pressure(or maybe only scalar) can be plotted, Ux, Uy, Uz are not appeared in the'point scalars'.

Any one has some idears? Thanks in advance!
sunnysun is offline   Reply With Quote

Old   April 8, 2008, 07:48
Default Hi Qii, Maybe, you can have
  #2
Senior Member
 
Cedric DUPRAT
Join Date: Mar 2009
Location: Nantes, France
Posts: 195
Rep Power: 17
cedric_duprat is on a distinguished road
Hi Qii,

Maybe, you can have a look in the user guide chapter 7.5: Sampling data for plotting graphs. It is about the sample utility.
I think It will be usefull :o)

regards,

Cedric
cedric_duprat is offline   Reply With Quote

Old   April 9, 2008, 03:14
Default Hi, Cedric, Thanks for your
  #3
Member
 
Vivien
Join Date: Mar 2009
Posts: 52
Rep Power: 17
sunnysun is on a distinguished road
Hi, Cedric,

Thanks for your idea. But does it mean that I did not follow the right steps?


Qi
sunnysun is offline   Reply With Quote

Old   January 13, 2009, 09:51
Default Hi, I have the same problem, c
  #4
New Member
 
Ali Mansouri
Join Date: Mar 2009
Posts: 15
Rep Power: 17
alimansouri is on a distinguished road
Hi, I have the same problem, can anybody help ?

only pressure can be plotted in Paraview 2.4, Ux, Uy, Uz are not appeared.
alimansouri is offline   Reply With Quote

Old   April 23, 2009, 06:42
Default
  #5
Super Moderator
 
bigphil's Avatar
 
Philip Cardiff
Join Date: Mar 2009
Location: Dublin, Ireland
Posts: 1,089
Rep Power: 34
bigphil will become famous soon enoughbigphil will become famous soon enough
Hi,

Did you first use 'Ucomponents' to break the velocity into its repective components or use 'magU' to get the magnitude of the velocity? Then Ux, Uy and Uz or magU should appear as they are scalars.


Hopefully this helps,
Philip C
bigphil is offline   Reply With Quote

Old   April 23, 2009, 06:52
Default
  #6
Super Moderator
 
bigphil's Avatar
 
Philip Cardiff
Join Date: Mar 2009
Location: Dublin, Ireland
Posts: 1,089
Rep Power: 34
bigphil will become famous soon enoughbigphil will become famous soon enough
I am using OpenFOAM v1.4.1

Possibly the commands in OpenFOAM v1.5 are:

"foamCalc components U"

or

"foamCalc mag U"
bigphil is offline   Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem diverges when exhaust valve opens swerner0711 AVL FIRE 0 September 21, 2018 07:14
A problem on the Energy spectrum plot by using FFT Martin duan OpenFOAM Post-Processing 5 February 22, 2016 10:12
Problem with Residual plot raising up to hige numbers na do not converge fardinkhalili STAR-CCM+ 4 March 25, 2014 09:35
X-Y plot problem, please help tobytoby FLUENT 8 March 20, 2013 20:57
CFD post vector plot problem bharath CFX 3 February 8, 2011 17:16


All times are GMT -4. The time now is 04:03.