CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > General Forums > Structural Mechanics

Abaqus Explicit SYSTEM TIME too high

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   November 1, 2022, 03:29
Question Abaqus Explicit SYSTEM TIME too high
  #1
New Member
 
Johann
Join Date: Oct 2022
Posts: 13
Rep Power: 3
hurd is on a distinguished road
Dear forum Abaqus experts,

I have a strange problem and the support has no clue what's wrong either. I "just" wanted to borrow a colleague's ryzen 5600X machine for Abaqus/Explicit runs because our dedicated abaqus Xeon machine has become a bit dated (we are currently purchasing a new machine, see this thread in the hardware forum)

Normally these days I squeeze my jobs in on another colleague's ryzen 5950X workstation and I get speedups that are pretty sweet.

Now I thought with just 6 cores on my abaqus license the 5600X shouldn't be much slower, BUT it's severely underperforming. It needs massive amounts of SYSTEM TIME, which according to the manual is defined as follows:
* USER TIME refers to the CPU time spent executing Abaqus.
* SYSTEM TIME refers to the amount of OS kernel CPU time spent by the operating system doing work on behalf of the Abaqus process.

So in my quest to find the cause together with our support, I created a super small (10MB problem size) benchmark job and ran it with all three machines, and while I probably shouldn't even be bothering it's driving me nuts .

HTML Code:
CPU            Xeon E5    Ryzen 9    Ryzen 5    Ryzen 5    Ryzen 5    Ryzen 5
                 2650 v2    5950X    5600X    5600X      5600X     5600X
OS             WIN10      WIN11    WIN10    WIN10     WIN10     WIN10
#cpus        cpus=6    cpus=6    cpus=6    cpus=4    cpus=2    cpus=1
USER TIME      944        389        484        537        876        1512
SYSTEM TIME  7            1          533        406        346        345
WALLCLOCK TIME 950     391      1017       944        1222      1858
Things I checked so far:
  • Hyperthreading is OFF - 6 cores / 6 threads on the 5600X machine
  • RAM is available / problem size is super small
  • disk is a SATA SSD, but output is only written at four points in the benchmark run
So finally I decided to post this here in case anybody has seen anything like it or has any hints to share.
hurd is offline   Reply With Quote

Old   November 1, 2022, 07:40
Default
  #2
New Member
 
Johann
Join Date: Oct 2022
Posts: 13
Rep Power: 3
hurd is on a distinguished road
Ok, I found the solution myself. The WIN10 Ryzen 5 5600X "workstation" had an active "balanced" power plan

After switching to "high performance" the machine finally runs as expected - thank goodness!

I hope this will save someone in the future from the madness I went through .
hurd is offline   Reply With Quote

Reply

Tags
abaqus, explicit solver

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
LES, Courant Number, Crash, Sudden Alhasan OpenFOAM Running, Solving & CFD 5 November 22, 2019 02:05
laplacianFoam with source term Herwig OpenFOAM Running, Solving & CFD 17 November 19, 2019 13:47
Inconsistencies in reading .dat file during run time in new injection model Scram_1 OpenFOAM 0 March 23, 2018 22:29
Stuck in a Rut- interDyMFoam! xoitx OpenFOAM Running, Solving & CFD 14 March 25, 2016 07:09
Upgraded from Karmic Koala 9.10 to Lucid Lynx10.04.3 bookie56 OpenFOAM Installation 8 August 13, 2011 04:03


All times are GMT -4. The time now is 09:23.