CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > SU2 > SU2 Installation

SU2 example job on multiple nodes creates incorrect result

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   December 14, 2018, 08:58
Default SU2 example job on multiple nodes creates incorrect result
  #1
New Member
 
merijn
Join Date: Dec 2018
Posts: 2
Rep Power: 0
merijn is on a distinguished road
Hi,
I'm an HPC admin, trying to get SU2 to run in slurm on an opa fabric,
which seems to work succesfully, but produces no valid results.

so to test this I started the https://su2code.github.io/tutorials/Inviscid_ONERAM6/
example.

if I run it manually on one node like so:
SU2_CFD inv_ONERAM6.cfg
it produces a 29M restart_flow.dat and I can view the resulting surface_flow.vtk file in paraview for a visualization.

if I run the same simulation in parallel on two nodes x24 cores using
parallel_computation.py -n $SLURM_NTASKS -f inv_ONERAM6.cfg
it produces a clean log output, stating success, but the restart_flow is smaller, 15M restart_flow.dat (half the size of a manual 1 node run) and the .vtk file has no points to show.

on 8 nodes the filesize of restart_flow.dat becomes 3.6 MB
on 16 nodes the filesize of restart_flow.dat becomes 1.8MB

I do see the processes running on the allocated nodes.

im deducing, it breaks up the problem to multiple compute-nodes, and the restart_flow.dat will also contain only the partial solution of one compute-node. and the solition vtk file will be invalid. speculating, perhaps it just overwrites restart_flow.dat on each node.

I compiled SU2 with ./configure --prefix=/shared/Modules/SU2/6.1.0 --enable-mpi CFLAGS=-g -O3
with openmpi 4.0.0

how to debug this, how to solve this test job with multiple nodes?

merijn
merijn is offline   Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Issue with OpenMPI-1.5.3 while running parallel jobs on multiple nodes LargeEddy OpenFOAM 1 March 7, 2012 17:05
Running in parallel on multiple nodes kalyangoparaju OpenFOAM 5 January 18, 2012 11:36
Issue with running in parallel on multiple nodes daveatstyacht OpenFOAM 7 August 31, 2010 17:16
Multiple hanging nodes in GAMBIT Partha Main CFD Forum 0 March 12, 2008 00:16
CFX4.3 -build analysis form Chie Min CFX 5 July 12, 2001 23:19


All times are GMT -4. The time now is 02:58.