CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > SU2

nspan Turbomachinery MPI issues

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   April 25, 2022, 08:17
Default nspan Turbomachinery MPI issues
  #1
New Member
 
Madrid
Join Date: Mar 2022
Posts: 2
Rep Power: 0
AmarotoS7 is on a distinguished road
Hello everyone,

I am a Master Student using SU2 for my msc thesis. I am trying as a first step to run a steady state simulation of a one row rotor stage using the turbomachinery tool. I am having an issue with the nspan of the outlet and looking for the fault on the forums I found that is maybe related to a partitioning error of the mpi capability, but when I tried running the simulation with one core, the fault remains happening. I also saw that the nspan can be manually specified somewhere but I dont know where. I attach a screenshot of the fault. Thank you in advance
Attached Images
File Type: png Captura.PNG (15.8 KB, 17 views)
AmarotoS7 is offline   Reply With Quote

Old   May 27, 2022, 09:57
Default
  #2
New Member
 
Join Date: Nov 2012
Posts: 18
Rep Power: 13
koray is on a distinguished road
Hey there, probably there's something wrong with your mesh. Have you tried solving one of the test cases, a 3D centrifugal compressor case ? Probably that case will run at least without mpi.
koray is offline   Reply With Quote

Old   May 28, 2022, 06:27
Default
  #3
New Member
 
Madrid
Join Date: Mar 2022
Posts: 2
Rep Power: 0
AmarotoS7 is on a distinguished road
Hi koray,

Thank you for your reply. Definitely it was a mesh issue, but I have not found where the mistake comes from yet. I have 3 volumes, all created with TurboGrid at the same time, and the first two volumes work fine but when I include the third one it crushes
AmarotoS7 is offline   Reply With Quote

Old   May 29, 2022, 04:25
Default
  #4
New Member
 
Join Date: Nov 2012
Posts: 18
Rep Power: 13
koray is on a distinguished road
Can you share the image of the domains?
koray is offline   Reply With Quote

Reply

Tags
mpi error, nspan, turbomachinery cfd

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Issues on the simulation of high-speed compressible flow within turbomachinery dowlee OpenFOAM Running, Solving & CFD 11 August 6, 2021 06:40
MPI issues with my own solver davide_c OpenFOAM Running, Solving & CFD 1 March 23, 2012 08:57
Sgimpi pere OpenFOAM 27 September 24, 2011 07:57
Error using LaunderGibsonRSTM on SGI ALTIX 4700 jaswi OpenFOAM 2 April 29, 2008 10:54
Is Testsuite on the way or not lakeat OpenFOAM Installation 6 April 28, 2008 11:12


All times are GMT -4. The time now is 21:07.