CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > FLUENT

Bugg in Remeshing in 3D - Any Fluent Wizards ??

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   October 16, 2007, 07:35
Default Bugg in Remeshing in 3D - Any Fluent Wizards ??
  #1
Amr
Guest
 
Posts: n/a
Hi all,

I am simulating an oscillating cylinder in cross flow and wish to accomplish this in 3D. There is a linear simple prescribed motion in order to test the model; the motion is currently only in the horizontal direction. By using a simple compiled UDF, enabling smooting and remeshing, everything goes fine in a 2D simulation.

However, when I switch to 3D, the body moves and the cells adjacent to the body keep on getting stretched (smoothed) without remeshing at all. Even after checking and verifying face remeshing and size function, the remeshing doesn't happen for some unknown reason. It appears to me that either I need to add something or modify the settings I used in 2D or that there might be a bug in the 6.3 fluent version. Surprisingly, the 3D cylinder-piston tutorial has its remeshing working fine, but I have also checked this against my case and I couldn't figure out why I have this remeshing inoperable.

Wonder if somebody out there has had a similar obstacle!!!

Awaiting to hear from anybody.

Amr
  Reply With Quote

Old   November 1, 2011, 05:04
Default
  #2
Member
 
stb
Join Date: Sep 2009
Posts: 35
Rep Power: 7
snailstb is on a distinguished road
Quote:
Originally Posted by Amr
;146244
Hi all,

I am simulating an oscillating cylinder in cross flow and wish to accomplish this in 3D. There is a linear simple prescribed motion in order to test the model; the motion is currently only in the horizontal direction. By using a simple compiled UDF, enabling smooting and remeshing, everything goes fine in a 2D simulation.

However, when I switch to 3D, the body moves and the cells adjacent to the body keep on getting stretched (smoothed) without remeshing at all. Even after checking and verifying face remeshing and size function, the remeshing doesn't happen for some unknown reason. It appears to me that either I need to add something or modify the settings I used in 2D or that there might be a bug in the 6.3 fluent version. Surprisingly, the 3D cylinder-piston tutorial has its remeshing working fine, but I have also checked this against my case and I couldn't figure out why I have this remeshing inoperable.

Wonder if somebody out there has had a similar obstacle!!!

Awaiting to hear from anybody.

Amr
have you solved this problem? I also face this problem for 3D model. LINUX VERSION of FLUENT6.3 is used. 2D is ok for remeshing. Can you give me some advise, thank you very much.
snailstb is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Two questions on Fluent UDF Steven Fluent UDF and Scheme Programming 4 September 20, 2013 16:30
fluent parallel problem in win7 x64 system dunga82 FLUENT 8 April 19, 2012 20:23
What the differences flow equation of Fluent 6.3 and Fluent 12.1 opehterinar81 FLUENT 0 August 19, 2011 11:55
Master node in parallel computing only distirubtion syadgar FLUENT 1 September 8, 2009 16:41
Hey Fluent WIZARDS !! Need help here Amr FLUENT 0 October 16, 2006 05:21


All times are GMT -4. The time now is 19:54.