CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > OpenFOAM > OpenFOAM Bugs

bug : topoSet STOP RESPONDING while trying to make cellzones near to a surface.

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   March 1, 2021, 11:49
Red face bug : topoSet STOP RESPONDING while trying to make cellzones near to a surface.
  #1
New Member
 
Sarath
Join Date: Mar 2017
Location: Spain
Posts: 21
Rep Power: 6
sk11 is on a distinguished road
Hello FOAMers,

I have a strange problem trying to make cellZone with cells near to a surface using topoSet. The topoSet stop responding after the stage "adding cells in relation to the surface". This Happens only when the surface STL is at some particular random angles of attack ( for example, no problems at 25 and 35 but get stuck when the surface is at 30)

I have a frame and a net in my domain. And I need to add the cells near to the net to a cellZone using topoSet.



Here is the image of the net and frame

netandframe.jpg


Here is the log file of topoSet :

log.topoSet.txt


This is a sample case where I get the error.

topoSet_error.zip


I tried running topoSet in both parallel and single core still the problem persists. a slight change in the orientation of the surface and topoSet works like charm. But my problem needs a consistent working of topoSet. It also works without any errors when I don't mesh the frame which is close to the surface

Does anyone faced similar issues or knows what I might be doing wrong here?
Thank you so much for your time
sk11 is offline   Reply With Quote

Reply

Tags
openfoam8, preprocessing, toposet

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
[snappyHexMesh] snappyHexMesh generates not planar surface krzychu111 OpenFOAM Meshing & Mesh Conversion 2 April 23, 2020 16:38
[snappyHexMesh] Surface triangulation using snappyHexMesh shaileshbg OpenFOAM Meshing & Mesh Conversion 4 October 17, 2019 04:42
[snappyHexMesh] SHM doesn't create cellZones for one region Eko OpenFOAM Meshing & Mesh Conversion 10 January 24, 2018 02:03
OpenFOAM with IBM AIX matthias OpenFOAM Installation 20 March 25, 2008 02:36
To make sure nodes on surface Twiti CFX 0 December 23, 2004 20:06


All times are GMT -4. The time now is 04:12.