CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > OpenFOAM > OpenFOAM Community Contributions

[swak4Foam] swak4foam for OpenFOAM 4.0

Register Blogs Members List Search Today's Posts Mark Forums Read

Like Tree27Likes

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   October 2, 2016, 16:40
Default
  #21
Assistant Moderator
 
Bernhard Gschaider
Join Date: Mar 2009
Posts: 4,140
Rep Power: 46
gschaider will become famous soon enoughgschaider will become famous soon enough
Quote:
Originally Posted by smodh View Post
hi....i am new in openfoam. is there anybody know how to install swak4Foam in openfoam4.0.


g++ -std=c++0x -m64 -Dlinux64 -DWM_ARCH_OPTION=64 -DWM_DP -DWM_LABEL_SIZE=32 -Wall -Wextra -Wold-style-cast -Wnon-virtual-dtor -Wno-unused-parameter -Wno-invalid-offsetof -O3 -DNoRepository -ftemplate-depth-100 -IMake/linux64GccDPInt32Opt -I/opt/openfoam4/src/finiteVolume/lnInclude -I/opt/openfoam4/src/sampling/lnInclude -I/opt/openfoam4/src/fileFormats/lnInclude -I/opt/openfoam4/src/triSurface/lnInclude -I/opt/openfoam4/src/dynamicMesh/lnInclude -I/opt/openfoam4/src/surfMesh/lnInclude -I/opt/openfoam4/src/lagrangian/basic/lnInclude -I/opt/openfoam4/src/meshTools/lnInclude -IlnInclude -I. -I/opt/openfoam4/src/OpenFOAM/lnInclude -I/opt/openfoam4/src/OSspecific/POSIX/lnInclude -fPIC -c repositories/RepositoryBase.C -o Make/linux64GccDPInt32Opt/repositories/RepositoryBase.o
g++ -std=c++0x -m64 -Dlinux64 -DWM_ARCH_OPTION=64 -DWM_DP -DWM_LABEL_SIZE=32 -Wall -Wextra -Wold-style-cast -Wnon-virtual-dtor -Wno-unused-parameter -Wno-invalid-offsetof -O3 -DNoRepository -ftemplate-depth-100 -IMake/linux64GccDPInt32Opt -I/opt/openfoam4/src/finiteVolume/lnInclude -I/opt/openfoam4/src/sampling/lnInclude -I/opt/openfoam4/src/fileFormats/lnInclude -I/opt/openfoam4/src/triSurface/lnInclude -I/opt/openfoam4/src/dynamicMesh/lnInclude -I/opt/openfoam4/src/surfMesh/lnInclude -I/opt/openfoam4/src/lagrangian/basic/lnInclude -I/opt/openfoam4/src/meshTools/lnInclude -IlnInclude -I. -I/opt/openfoam4/src/OpenFOAM/lnInclude -I/opt/openfoam4/src/OSspecific/POSIX/lnInclude -fPIC -c repositories/SurfacesRepository.C -o Make/linux64GccDPInt32Opt/repositories/SurfacesRepository.o
g++ -std=c++0x -m64 -Dlinux64 -DWM_ARCH_OPTION=64 -DWM_DP -DWM_LABEL_SIZE=32 -Wall -Wextra -Wold-style-cast -Wnon-virtual-dtor -Wno-unused-parameter -Wno-invalid-offsetof -O3 -DNoRepository -ftemplate-depth-100 -IMake/linux64GccDPInt32Opt -I/opt/openfoam4/src/finiteVolume/lnInclude -I/opt/openfoam4/src/sampling/lnInclude -I/opt/openfoam4/src/fileFormats/lnInclude -I/opt/openfoam4/src/triSurface/lnInclude -I/opt/openfoam4/src/dynamicMesh/lnInclude -I/opt/openfoam4/src/surfMesh/lnInclude -I/opt/openfoam4/src/lagrangian/basic/lnInclude -I/opt/openfoam4/src/meshTools/lnInclude -IlnInclude -I. -I/opt/openfoam4/src/OpenFOAM/lnInclude -I/opt/openfoam4/src/OSspecific/POSIX/lnInclude -fPIC -c repositories/MeshesRepository.C -o Make/linux64GccDPInt32Opt/repositories/MeshesRepository.o
/opt/openfoam4/wmake/rules/General/transform:8: recipe for target 'Make/linux64GccDPInt32Opt/helpers/exprString.o' failed
make: *** [Make/linux64GccDPInt32Opt/helpers/exprString.o] Error 1
make: *** Waiting for unfinished jobs....
Parser library did not compile OK. No sense continuing as everything else depends on it

Requirements for Library not satisfied. I see no sense in going on
Check the README before you go on to ask. And search: Most likely your problem occured to 5 other people before and has been solved on the MessageBoard
That is strange:
- Which version of OF 4.0 are you using? Released or git?
- You're using the latest version of swak4Foam
- Is the file ./Libraries/swak4FoamParsers/helpers/exprString.C in your -swak-sources
- Did you previously attempt to compile this swak-installation? (Try ./Allwclean to make sure that no problems from earlier compilations exist. Then retry ./Allwmake)
__________________
Note: I don't use "Friend"-feature on this forum out of principle. Ah. And by the way: I'm not on Facebook either. So don't be offended if I don't accept your invitation/friend request
gschaider is offline   Reply With Quote

Old   October 3, 2016, 04:50
Default
  #22
New Member
 
Sachin
Join Date: Sep 2016
Location: Poitiers,France
Posts: 17
Rep Power: 5
smodh is on a distinguished road
thnx gschaider for replying,

1) I am using released version of OF 4.0 ; downloaded from openfoam.org website.

2)I am using latest version of swak4Foam, downloaded from ( "git clone https://github.com/Unofficial-Extend...k4Foam-dev.git swak4Foam" )

3)yes....I checked swak4Foam folder.

4) Today I again uninstall and try to install swak4Foam again but I have still same problem.

Hope you know some solution.
Thx.
smodh is offline   Reply With Quote

Old   October 3, 2016, 05:55
Default
  #23
Assistant Moderator
 
Bernhard Gschaider
Join Date: Mar 2009
Posts: 4,140
Rep Power: 46
gschaider will become famous soon enoughgschaider will become famous soon enough
Quote:
Originally Posted by smodh View Post
thnx gschaider for replying,

1) I am using released version of OF 4.0 ; downloaded from openfoam.org website.

2)I am using latest version of swak4Foam, downloaded from ( "git clone https://github.com/Unofficial-Extend...k4Foam-dev.git swak4Foam" )

3)yes....I checked swak4Foam folder.

4) Today I again uninstall and try to install swak4Foam again but I have still same problem.

Hope you know some solution.
Thx.
Don't know if the git you're using is up to date. The "Un" before the "official" should be a hint that this is not the repository I vouch for
Code:
hg clone http://hg.code.sf.net/p/openfoam-extend/swak4Foam
cd swak4Foam
hp update develop
will get you the latest version. Be sure to apply the patches found in the distroPatches-directory as the release of OF 4.0 is broken in two places (this will be fixed in the next release I hear)
__________________
Note: I don't use "Friend"-feature on this forum out of principle. Ah. And by the way: I'm not on Facebook either. So don't be offended if I don't accept your invitation/friend request
gschaider is offline   Reply With Quote

Old   October 4, 2016, 07:07
Default
  #24
New Member
 
Panchatcharam Mariappan
Join Date: Apr 2014
Posts: 16
Rep Power: 8
mpanch13114 is on a distinguished road
When I try to install swak4Foam (develop) version, after following the instructions in this post.
Code:
hg clone http://hg.code.sf.net/p/openfoam-extend/swak4Foam
cd swak4Foam 
hg update develop
I get the following error.

Code:
../FieldValueExpressionParser.yy:2517:21:   required from here
/opt/OpenFOAM/OpenFOAM-4.0/src/finiteVolume/lnInclude/fvcD2dt2.C:53:20:  error: passing ‘const Foam::fv::d2dt2Scheme<double>’ as ‘this’  argument discards qualifiers [-fpermissive]
     )().fvcD2dt2(vf);
                    ^
In file included from /opt/OpenFOAM/OpenFOAM-4.0/src/finiteVolume/lnInclude/fvcD2dt2.C:28:0,
                 from /opt/OpenFOAM/OpenFOAM-4.0/src/finiteVolume/lnInclude/fvcD2dt2.H:74,
                 from ../FieldValueExpressionParser.yy:60:
/opt/OpenFOAM/OpenFOAM-4.0/src/finiteVolume/lnInclude/d2dt2Scheme.H:141:66:  note:   in call to ‘Foam::tmp<Foam::GeometricField<Type,  Foam::fvPatchField, Foam::volMesh> >  Foam::fv::d2dt2Scheme<Type>::fvcD2dt2(const  Foam::GeometricField<Type, Foam::fvPatchField,  Foam::volMesh>&) [with Type = double]’
         virtual tmp<GeometricField<Type, fvPatchField, volMesh>> fvcD2dt2
                                                                  ^
In file included from /opt/OpenFOAM/OpenFOAM-4.0/src/finiteVolume/lnInclude/fvcD2dt2.H:74:0,
                 from ../FieldValueExpressionParser.yy:60:
/opt/OpenFOAM/OpenFOAM-4.0/src/finiteVolume/lnInclude/fvcD2dt2.C:  In instantiation of ‘Foam::tmp<Foam::GeometricField<Type,  Foam::fvPatchField, Foam::volMesh> > Foam::fvc::d2dt2(const  Foam::GeometricField<Type, Foam::fvPatchField,  Foam::volMesh>&) [with Type = Foam::Tensor<double>]’:
../FieldValueExpressionParser.yy:3103:13:   required from here
/opt/OpenFOAM/OpenFOAM-4.0/src/finiteVolume/lnInclude/fvcD2dt2.C:53:20:  error: passing ‘const  Foam::fv::d2dt2Scheme<Foam::Tensor<double> >’ as ‘this’  argument discards qualifiers [-fpermissive]
     )().fvcD2dt2(vf);
                    ^
In file included from /opt/OpenFOAM/OpenFOAM-4.0/src/finiteVolume/lnInclude/fvcD2dt2.C:28:0,
                 from /opt/OpenFOAM/OpenFOAM-4.0/src/finiteVolume/lnInclude/fvcD2dt2.H:74,
                 from ../FieldValueExpressionParser.yy:60:
/opt/OpenFOAM/OpenFOAM-4.0/src/finiteVolume/lnInclude/d2dt2Scheme.H:141:66:  note:   in call to ‘Foam::tmp<Foam::GeometricField<Type,  Foam::fvPatchField, Foam::volMesh> >  Foam::fv::d2dt2Scheme<Type>::fvcD2dt2(const  Foam::GeometricField<Type, Foam::fvPatchField,  Foam::volMesh>&) [with Type = Foam::Tensor<double>]’
         virtual tmp<GeometricField<Type, fvPatchField, volMesh>> fvcD2dt2
                                                                  ^
In file included from /opt/OpenFOAM/OpenFOAM-4.0/src/finiteVolume/lnInclude/fvcD2dt2.H:74:0,
                 from ../FieldValueExpressionParser.yy:60:
/opt/OpenFOAM/OpenFOAM-4.0/src/finiteVolume/lnInclude/fvcD2dt2.C:  In instantiation of ‘Foam::tmp<Foam::GeometricField<Type,  Foam::fvPatchField, Foam::volMesh> > Foam::fvc::d2dt2(const  Foam::GeometricField<Type, Foam::fvPatchField,  Foam::volMesh>&) [with Type = Foam::SymmTensor<double>]’:
../FieldValueExpressionParser.yy:3416:13:   required from here
/opt/OpenFOAM/OpenFOAM-4.0/src/finiteVolume/lnInclude/fvcD2dt2.C:53:20:  error: passing ‘const  Foam::fv::d2dt2Scheme<Foam::SymmTensor<double> >’ as ‘this’  argument discards qualifiers [-fpermissive]
     )().fvcD2dt2(vf);
                    ^
In file included from /opt/OpenFOAM/OpenFOAM-4.0/src/finiteVolume/lnInclude/fvcD2dt2.C:28:0,
                 from /opt/OpenFOAM/OpenFOAM-4.0/src/finiteVolume/lnInclude/fvcD2dt2.H:74,
                 from ../FieldValueExpressionParser.yy:60:
/opt/OpenFOAM/OpenFOAM-4.0/src/finiteVolume/lnInclude/d2dt2Scheme.H:141:66:  note:   in call to ‘Foam::tmp<Foam::GeometricField<Type,  Foam::fvPatchField, Foam::volMesh> >  Foam::fv::d2dt2Scheme<Type>::fvcD2dt2(const  Foam::GeometricField<Type, Foam::fvPatchField,  Foam::volMesh>&) [with Type = Foam::SymmTensor<double>]’
         virtual tmp<GeometricField<Type, fvPatchField, volMesh>> fvcD2dt2
                                                                  ^
In file included from /opt/OpenFOAM/OpenFOAM-4.0/src/finiteVolume/lnInclude/fvcD2dt2.H:74:0,
                 from ../FieldValueExpressionParser.yy:60:
/opt/OpenFOAM/OpenFOAM-4.0/src/finiteVolume/lnInclude/fvcD2dt2.C:  In instantiation of ‘Foam::tmp<Foam::GeometricField<Type,  Foam::fvPatchField, Foam::volMesh> > Foam::fvc::d2dt2(const  Foam::GeometricField<Type, Foam::fvPatchField,  Foam::volMesh>&) [with Type =  Foam::SphericalTensor<double>]’:
../FieldValueExpressionParser.yy:3697:13:   required from here
/opt/OpenFOAM/OpenFOAM-4.0/src/finiteVolume/lnInclude/fvcD2dt2.C:53:20:  error: passing ‘const  Foam::fv::d2dt2Scheme<Foam::SphericalTensor<double> >’ as  ‘this’ argument discards qualifiers [-fpermissive]
     )().fvcD2dt2(vf);
                    ^
In file included from /opt/OpenFOAM/OpenFOAM-4.0/src/finiteVolume/lnInclude/fvcD2dt2.C:28:0,
                 from /opt/OpenFOAM/OpenFOAM-4.0/src/finiteVolume/lnInclude/fvcD2dt2.H:74,
                 from ../FieldValueExpressionParser.yy:60:
/opt/OpenFOAM/OpenFOAM-4.0/src/finiteVolume/lnInclude/d2dt2Scheme.H:141:66:  note:   in call to ‘Foam::tmp<Foam::GeometricField<Type,  Foam::fvPatchField, Foam::volMesh> >  Foam::fv::d2dt2Scheme<Type>::fvcD2dt2(const  Foam::GeometricField<Type, Foam::fvPatchField,  Foam::volMesh>&) [with Type =  Foam::SphericalTensor<double>]’
         virtual tmp<GeometricField<Type, fvPatchField, volMesh>> fvcD2dt2
                                                                  ^
Let me know if any patches available to fix it.

Make/linux64GccDPInt32Opt/../mybisonNew:20: recipe for target 'Make/linux64GccDPInt32Opt/FieldValueExpressionParser.o' failed
make: *** [Make/linux64GccDPInt32Opt/FieldValueExpressionParser.o] Error 1
Parser library did not compile OK. No sense continuing as everything else depends on it

Requirements for Library not satisfied. I see no sense in going on
Check the README before you go on to ask. And search: Most likely your problem occured to 5 other people before and has been solved on the MessageBoard

If I run the swak4foam using git repo from ( "git clone https://github.com/Unofficial-Extend...k4Foam-dev.git swak4Foam" ), I get the same error as reported by Sachin.
mpanch13114 is offline   Reply With Quote

Old   October 4, 2016, 08:26
Default
  #25
Assistant Moderator
 
Bernhard Gschaider
Join Date: Mar 2009
Posts: 4,140
Rep Power: 46
gschaider will become famous soon enoughgschaider will become famous soon enough
Quote:
Originally Posted by mpanch13114 View Post
When I try to install swak4Foam (develop) version, after following the instructions in this post.
Code:
hg clone http://hg.code.sf.net/p/openfoam-extend/swak4Foam
cd swak4Foam 
hg update develop
I get the following error.

Code:
../FieldValueExpressionParser.yy:2517:21:   required from here
<snip>
instantiation of ‘Foam::tmp<Foam::GeometricField<Type,  Foam::fvPatchField, Foam::volMesh> > Foam::fvc::d2dt2(const  Foam::GeometricField<Type, Foam::fvPatchField,  Foam::volMesh>&) [with Type =  Foam::SphericalTensor<double>]’:
../FieldValueExpressionParser.yy:3697:13:   required from here
/opt/OpenFOAM/OpenFOAM-4.0/src/finiteVolume/lnInclude/fvcD2dt2.C:53:20:  error: passing ‘const  Foam::fv::d2dt2Scheme<Foam::SphericalTensor<double> >’ as  ‘this’ argument discards qualifiers [-fpermissive]
     )().fvcD2dt2(vf);
                    ^
In file included from /opt/OpenFOAM/OpenFOAM-4.0/src/finiteVolume/lnInclude/fvcD2dt2.C:28:0,
                 from /opt/OpenFOAM/OpenFOAM-4.0/src/finiteVolume/lnInclude/fvcD2dt2.H:74,
                 from ../FieldValueExpressionParser.yy:60:
/opt/OpenFOAM/OpenFOAM-4.0/src/finiteVolume/lnInclude/d2dt2Scheme.H:141:66:  note:   in call to ‘Foam::tmp<Foam::GeometricField<Type,  Foam::fvPatchField, Foam::volMesh> >  Foam::fv::d2dt2Scheme<Type>::fvcD2dt2(const  Foam::GeometricField<Type, Foam::fvPatchField,  Foam::volMesh>&) [with Type =  Foam::SphericalTensor<double>]’
         virtual tmp<GeometricField<Type, fvPatchField, volMesh>> fvcD2dt2
                                                                  ^
Let me know if any patches available to fix it.

Make/linux64GccDPInt32Opt/../mybisonNew:20: recipe for target 'Make/linux64GccDPInt32Opt/FieldValueExpressionParser.o' failed
make: *** [Make/linux64GccDPInt32Opt/FieldValueExpressionParser.o] Error 1
Parser library did not compile OK. No sense continuing as everything else depends on it

Requirements for Library not satisfied. I see no sense in going on
Check the README before you go on to ask. And search: Most likely your problem occured to 5 other people before and has been solved on the MessageBoard

If I run the swak4foam using git repo from ( "git clone https://github.com/Unofficial-Extend...k4Foam-dev.git swak4Foam" ), I get the same error as reported by Sachin.
I quote from the README:
Code:
** Next release - version number : 0.4.1
*** New supported versions
**** Support for OpenFOAM 4.0
     This version is supported in this version of OpenFOAM. There is
     one problem: the released version has two problems that mean that
     =swak4foam= will *never* compile on the released version.

     Patches fixing these issues are found in the directory
     =distroPatches/OpenFOAM-4.0=
Where else should I put that kind of information?
__________________
Note: I don't use "Friend"-feature on this forum out of principle. Ah. And by the way: I'm not on Facebook either. So don't be offended if I don't accept your invitation/friend request
gschaider is offline   Reply With Quote

Old   October 4, 2016, 09:18
Default
  #26
New Member
 
Panchatcharam Mariappan
Join Date: Apr 2014
Posts: 16
Rep Power: 8
mpanch13114 is on a distinguished road
Quote:
Originally Posted by gschaider View Post
I quote from the README:
Code:
** Next release - version number : 0.4.1
*** New supported versions
**** Support for OpenFOAM 4.0
     This version is supported in this version of OpenFOAM. There is
     one problem: the released version has two problems that mean that
     =swak4foam= will *never* compile on the released version.

     Patches fixing these issues are found in the directory
     =distroPatches/OpenFOAM-4.0=
Where else should I put that kind of information?

Thank you Bernhard. I have compiled it successfully. It was my bad. I have messed up both git and hg readme files. Thanks again.
mpanch13114 is offline   Reply With Quote

Old   October 6, 2016, 07:35
Default
  #27
Member
 
Bijan Darbari
Join Date: Nov 2015
Posts: 47
Rep Power: 6
bijan darbari is on a distinguished road
I want to compile swak4Foam on openfoam 4.0 dev.

but it get the below error:

Code:
In file included from EliminateBySwakExpressionInstances.C:40:0:
EliminateBySwakExpression.H:55:40: fatal error: CloudValueExpressionDriver.H: No such file or directory
compilation terminated.
/home/bijan/OpenFOAM/OpenFOAM-dev/wmake/rules/General/transform:8: recipe for target 'Make/linux64GccDPInt32Opt/EliminateBySwakExpressionInstances.o' failed
make: *** [Make/linux64GccDPInt32Opt/EliminateBySwakExpressionInstances.o] Error 1

Requirements for Library not satisfied. I see no sense in going on
Check the README before you go on to ask. And search: Most likely your problem occured to 5 other people before and has been solved on the MessageBoard


-How can I solve this error??
-How can I apply "distropatches" ??
bijan darbari is offline   Reply With Quote

Old   October 6, 2016, 11:38
Default
  #28
Assistant Moderator
 
Bernhard Gschaider
Join Date: Mar 2009
Posts: 4,140
Rep Power: 46
gschaider will become famous soon enoughgschaider will become famous soon enough
Quote:
Originally Posted by bijan darbari View Post
I want to compile swak4Foam on openfoam 4.0 dev.

but it get the below error:

Code:
In file included from EliminateBySwakExpressionInstances.C:40:0:
EliminateBySwakExpression.H:55:40: fatal error: CloudValueExpressionDriver.H: No such file or directory
compilation terminated.
/home/bijan/OpenFOAM/OpenFOAM-dev/wmake/rules/General/transform:8: recipe for target 'Make/linux64GccDPInt32Opt/EliminateBySwakExpressionInstances.o' failed
make: *** [Make/linux64GccDPInt32Opt/EliminateBySwakExpressionInstances.o] Error 1

Requirements for Library not satisfied. I see no sense in going on
Check the README before you go on to ask. And search: Most likely your problem occured to 5 other people before and has been solved on the MessageBoard
-How can I solve this error??
-How can I apply "distropatches" ??
At first: are you using the correct version of swak4foam? Please report the output of "hg id"

Applying patch files is described for instance in http://www.cyberciti.biz/faq/appy-pa...patch-command/

"cd $WM_PROJECT_DIR" and apply the patch files that come with the swak sources with the option -p1
__________________
Note: I don't use "Friend"-feature on this forum out of principle. Ah. And by the way: I'm not on Facebook either. So don't be offended if I don't accept your invitation/friend request
gschaider is offline   Reply With Quote

Old   October 6, 2016, 16:52
Default
  #29
Member
 
Bijan Darbari
Join Date: Nov 2015
Posts: 47
Rep Power: 6
bijan darbari is on a distinguished road
Quote:
At first: are you using the correct version of swak4foam? Please report the output of "hg id"

Applying patch files is described for instance in http://www.cyberciti.biz/faq/appy-pa...patch-command/

"cd $WM_PROJECT_DIR" and apply the patch files that come with the swak sources with the option -p1
Dear Bernhard
Thanks for your reply.

The problem solved. It will compile without any error If I use "hg" command for downloading swak4Foam.


If I download swak4Foam manually as 2-2-1 in:
http://www.cfd-online.com/Forums/ope...tml#post619345

I will get mentioned error when trying to compile it.

But If download swak4Foam by "hg" command like this:
Quote:
hg clone http://hg.code.sf.net/p/openfoam-extend/swak4Foam swak4Foam cd swak4Foam && hg update develop
It will compile successfully with out any error.
bijan darbari is offline   Reply With Quote

Old   October 19, 2016, 01:42
Default
  #30
Member
 
Join Date: May 2015
Posts: 34
Rep Power: 7
mnikku is on a distinguished road
Seems that there were some issues(?) with the release 4.0 and there is a highly recommended patch version 4.1 out. I tried to install the current development version of swak4foam, but encountered the following error:
Code:
make: *** No rule to make target `/shared/apps/openfoam/openmpi-1.10.4-gcc-local/gcc-4.9.2/4.1/src/OpenFOAM/lnInclude/uLabelSpecific.H', needed by `Make/linux64GccDPOpt/../filesThatAreOnlyInSomeDistributions/OutputFilerDropin/outputFilterOutputControl.C.dep'.  Stop.
Parser library did not compile OK. No sense continuing as everything else depends on it
So two questions:
1) does 4.1 also need some distro patching?
2) has anyone managed to compile swak4foam for 4.1 or is new development version needed for this?

EDIT: So I actually managed to compile the latest development version of swak4foam for 4.1 on one cluster. So it seems to work out of the box, though I have no idea why it didn't compile on the other clusters...

Last edited by mnikku; October 19, 2016 at 08:42. Reason: New info.
mnikku is offline   Reply With Quote

Old   October 19, 2016, 13:39
Default
  #31
Assistant Moderator
 
Bernhard Gschaider
Join Date: Mar 2009
Posts: 4,140
Rep Power: 46
gschaider will become famous soon enoughgschaider will become famous soon enough
Quote:
Originally Posted by mnikku View Post
Seems that there were some issues(?) with the release 4.0 and there is a highly recommended patch version 4.1 out. I tried to install the current development version of swak4foam, but encountered the following error:
Code:
make: *** No rule to make target `/shared/apps/openfoam/openmpi-1.10.4-gcc-local/gcc-4.9.2/4.1/src/OpenFOAM/lnInclude/uLabelSpecific.H', needed by `Make/linux64GccDPOpt/../filesThatAreOnlyInSomeDistributions/OutputFilerDropin/outputFilterOutputControl.C.dep'.  Stop.
Parser library did not compile OK. No sense continuing as everything else depends on it
So two questions:
1) does 4.1 also need some distro patching?
2) has anyone managed to compile swak4foam for 4.1 or is new development version needed for this?

EDIT: So I actually managed to compile the latest development version of swak4foam for 4.1 on one cluster. So it seems to work out of the box, though I have no idea why it didn't compile on the other clusters...
Good to know. There are still some fixes to make swak4Foam work better on 4.0 (some function objects compiled but were not really working correctly. But those mostly used - swakExpression etc - already work on the version that is in the public repository) that I've got to push.
wyldckat likes this.
__________________
Note: I don't use "Friend"-feature on this forum out of principle. Ah. And by the way: I'm not on Facebook either. So don't be offended if I don't accept your invitation/friend request
gschaider is offline   Reply With Quote

Old   October 22, 2016, 04:23
Default
  #32
Senior Member
 
Mark Olesen
Join Date: Mar 2009
Location: http://olesenm.github.io/
Posts: 928
Rep Power: 26
olesen will become famous soon enougholesen will become famous soon enough
This is due to removal of the uLabelSpecific.H file (was a zero-size file). Your depends, however, still have the old dependency noted. You either need to remove the offending .dep files (this will not be trivial since lots of places use ulabel), or a wclean and rebuild.
olesen is offline   Reply With Quote

Old   October 25, 2016, 14:16
Smile installing swak4Foam on OF4 + Ubuntu 16.06
  #33
New Member
 
vsammartano's Avatar
 
Vincenzo
Join Date: Oct 2012
Location: Varese (IT)
Posts: 15
Rep Power: 9
vsammartano is on a distinguished road
Send a message via Skype™ to vsammartano
Dear Bruno,
I have installed OF4.x, I followed your instructions and everything goes perfect!
....but after installation I have realized that an error occurred during installation (agrr!! )
I found this error inside the log.make file:
"
Previously compiled for OpenFOAM 4.x
No file 'swakConfiguration'. Python etc won't work. See README for details
Try 'ln -s swakConfiguration.automatic swakConfiguration' for automatic configuration. BEWARE: this does not work on some systems
Checking swak4Foam-version and generating file
Swak version is 0.4.1
Bison is version 3.0.4
swak4Foam only confirmed to work with Bison 2.x
Consider running ./maintainanceScripts/compileRequirements.sh for a local bison-installation
Set the environment variable DEVELOPE_FOR_NEW_BISON if you want to continue anyway.

Requirements for Library not satisfied. I see no sense in going on
Check the README before you go on to ask. And search: Most likely your problem occured to 5 other people before and has been solved on the MessageBoard
"


I do not understand what do next?!?!?
Thank you so much for your help!!!
Regards, Vincenzo


Quote:
Originally Posted by wyldckat View Post
Quick news update: Bernhard has managed to finish adapting swak4Foam to build with OpenFOAM 4.0 and OpenFOAM+ v1606+: https://twitter.com/swakPyFoam/statu...93042482642948

I won't be able to update and test the wiki right now, but here is what I expect that will work as intended, for the steps on how to download swak4Foam from the Mercurial repository:
  1. First, go into a good working folder. Run the following commands in a terminal to get to a good folder:
    Code:
    mkdir -p $FOAM_RUN
    cd "$FOAM_RUN/../"
  2. The use either the first or the second option below:
    1. From the main Mercurial development repository, using the hg command, download from the repository and checkout the right branch:
      Code:
      hg clone http://hg.code.sf.net/p/openfoam-extend/swak4Foam swak4Foam
      cd swak4Foam && hg update develop
    2. Or manually download a snapshot from the Mercurial interface at Sourceforge.net:
      1. Go to this page: Mercurial repository for swak4Foam - branch "develop"
      2. Request a snapshot on that page; in other words click on the link Download Snapshot.
      3. Unpack the downloaded file and move the unpacked folder, into the folder indicated by this command: pwd
      4. Rename the folder to "swak4Foam".
These steps above will replace the step #3 on this list: http://openfoamwiki.net/index.php/In...tall_swak4Foam

Last edited by vsammartano; October 26, 2016 at 05:55.
vsammartano is offline   Reply With Quote

Old   October 26, 2016, 10:33
Default
  #34
Senior Member
 
FlyBob91's Avatar
 
Join Date: Mar 2016
Location: Bergamo
Posts: 150
Rep Power: 6
FlyBob91 is on a distinguished road
Hello to all

Same problem of vsammartano and i don't completely understand the solution other users adopted.
zhaoshiyu likes this.
FlyBob91 is offline   Reply With Quote

Old   October 26, 2016, 11:29
Default solved for openFoam4.x + Ubuntu 16.04
  #35
New Member
 
vsammartano's Avatar
 
Vincenzo
Join Date: Oct 2012
Location: Varese (IT)
Posts: 15
Rep Power: 9
vsammartano is on a distinguished road
Send a message via Skype™ to vsammartano
Quote:
Originally Posted by FlyBob91 View Post
Hello to all

Same problem of vsammartano and i don't completely understand the solution other users adopted.

Dear FlyBob91,
today I've solved the installation problem just using the last procedure suggested by the good wyldckat. I installed the develop version of swak4Foam because, so far, is the only version correctly working with OF4.x.
Here the step I followed:
1.Imanually downloaded a snapshot from the Mercurial interface at Sourceforge.net:

https://sourceforge.net/p/openfoam-e.../develop/tree/

... to download you have to click on "Download Snapshot".

2. Once you have got the tar file, unpack the file on your working folder, and rename the unpacked folder to "swak4Foam".

...as stated in the wyldckat post, if you do not have a working folder create one ...

mkdir -p $FOAM_RUN
cd "$FOAM_RUN/../"

3. Go into the "swak4Foam" folder: cd swak4Foam 4. Build the dependencies that are needed,
because Ubuntu usually has an updated bison ver. (>3.*),
and swak4foam works fine only with older version of bison (2.*).
So, you need to build a custom version, type:

./maintainanceScripts/compileRequirements.sh

5. At the end of the process you can build swak4Foam:
./Allwmake > log.make 2>&1
6. To take a look to the installation summary open the log file.

7. if you want to check the version go into a case folder and type

funkySetFields
this will return an error, but under the openFOAM banner you find
swak4foam version.

Before you use this tool do not forget to paste in the controlDict
file of your case study the following lines:

libs (
"libOpenFOAM.so"
"libsimpleSwakFunctionObjects.so"
"libswakFunctionObjects.so"
"libgroovyBC.so"
);

That is all. I hope I was clear and helpful.
Regards,
Vincenzo
Luttappy and FlyBob91 like this.
vsammartano is offline   Reply With Quote

Old   October 26, 2016, 11:32
Default
  #36
Senior Member
 
FlyBob91's Avatar
 
Join Date: Mar 2016
Location: Bergamo
Posts: 150
Rep Power: 6
FlyBob91 is on a distinguished road
Quote:
Originally Posted by vsammartano View Post
Dear Bruno,
I have installed OF4.x, I followed your instructions and everything goes perfect!
....but after installation I have realized that an error occurred during installation (agrr!! )
I found this error inside the log.make file:
"
Previously compiled for OpenFOAM 4.x
No file 'swakConfiguration'. Python etc won't work. See README for details
Try 'ln -s swakConfiguration.automatic swakConfiguration' for automatic configuration. BEWARE: this does not work on some systems
Checking swak4Foam-version and generating file
Swak version is 0.4.1
Bison is version 3.0.4
swak4Foam only confirmed to work with Bison 2.x
Consider running ./maintainanceScripts/compileRequirements.sh for a local bison-installation
Set the environment variable DEVELOPE_FOR_NEW_BISON if you want to continue anyway.

Requirements for Library not satisfied. I see no sense in going on
Check the README before you go on to ask. And search: Most likely your problem occured to 5 other people before and has been solved on the MessageBoard
"

ok maybe you have only to compile

Code:
./maintainanceScripts/compileRequirements.sh
and then

Code:
./Allwmake
Best Regards,
Roberto
vsammartano likes this.
FlyBob91 is offline   Reply With Quote

Old   October 27, 2016, 01:26
Default
  #37
Member
 
Join Date: May 2015
Posts: 34
Rep Power: 7
mnikku is on a distinguished road
Code:
Requirements for Library not satisfied. I see no sense in going on
Typically you find some kind of error message(s) before this line.
In my case, it gave an error on missing files uLabelSpecific.H and also staticAssert.H in file Make/linux64GccDPOpt/../filesThatAreOnlyInSomeDistributions/OutputFilerDropin/outputFilterOutputControl.C.dep. I simply removed references to those files and the compilation was ok.
There might be other methods and I'm not at all sure you should do it like I did...
rdbisme likes this.
mnikku is offline   Reply With Quote

Old   October 27, 2016, 02:27
Default
  #38
New Member
 
vsammartano's Avatar
 
Vincenzo
Join Date: Oct 2012
Location: Varese (IT)
Posts: 15
Rep Power: 9
vsammartano is on a distinguished road
Send a message via Skype™ to vsammartano
Dear Roberto,
thank you for your reply.
However as you read my post #35, I solved the installation issue.
Thank you again.
Regards
vsammartano is offline   Reply With Quote

Old   October 27, 2016, 05:02
Default
  #39
Senior Member
 
FlyBob91's Avatar
 
Join Date: Mar 2016
Location: Bergamo
Posts: 150
Rep Power: 6
FlyBob91 is on a distinguished road
Quote:
Originally Posted by vsammartano View Post
Dear Roberto,
thank you for your reply.
However as you read my post #35, I solved the installation issue.
Thank you again.
Regards
Yes, we were writing at the same time.

Regards,
Roberto
vsammartano likes this.
FlyBob91 is offline   Reply With Quote

Old   October 30, 2016, 10:36
Default
  #40
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 10,956
Blog Entries: 43
Rep Power: 122
wyldckat is a name known to allwyldckat is a name known to allwyldckat is a name known to allwyldckat is a name known to allwyldckat is a name known to allwyldckat is a name known to all
Greetings to all!

I'm glad things are sorted out for everyone, or at least for the most part. I'm here to give a report on what happened for the various posts after post #13 - and sorry for the delay on this, but hopefully the following will help in diagnosing future situations.

Chronological report:
  1. Post #13 was made a few hours after Bernhard tweeted that the development branch of swak4Foam was ready to be used for compiling with OpenFOAM 4.0 and OpenFOAM+ v1606+. I tried to write the critical steps on that post #13 that were needed to get the correct source code snapshot.
    • It was late that night and I didn't manage to test the instructions nor revise the wiki pages.
  2. First report of a failed build with the swak4Foam develop branch came in post #14.
    • The problem was that I didn't check the README file, so I was not aware that it was necessary to patch certain files in OpenFOAM 4.0 and v1606+, as addressed in the posts up (down) to and including #19.
  3. Post #22: The unofficial mirror had been used. For whatever reason the forum member didn't see the instructions given in post #13 and probably used the instructions given on the wiki.
    • The problem was likely because the instructions on the wiki - https://openfoamwiki.net/index.php/I...am/Downloading - were outdated when referring on how to download from the mirror, because those instructions back then were using the "master" branch on the mirror repository instead of the "branches/develop" branch. This is now already fixed on the wiki.
    • There is always a possibility that the mirrors are outdated. This has been added to that wiki page as well.
  4. Post #29: Apparently downloading the tarball directly from the Sourceforge.net source code browser gave the incorrect source code snapshot.
    • I can only guess that either the incorrect page was used on the SF.net website (Allura) or that the tarball snapshot was somehow stale and giving for the incorrect commit.


Beyond the report, on the 15th of October I managed to make a considerable update to the installation pages for swak4Foam here: https://openfoamwiki.net/index.php/I...tion/swak4Foam
The instructions have been all been revised, although I didn't manage to finish the instructions given here: https://openfoamwiki.net/index.php/I...gy_source_code - I simply copy-pasted from the README file the references to the fixes necessary. This was why I didn't report it here sooner.

If anyone can step in and complement with details how to perform the patching, the wiki is open and editable to anyone who wants to contribute!

Best regards,
Bruno
vsammartano likes this.
wyldckat is offline   Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
[swak4Foam] swak4Foam installation on OpenFOAM 4.0 blttkgl OpenFOAM Community Contributions 1 March 14, 2017 11:06
[swak4Foam] and twoPhaseEulerFoam mnikku OpenFOAM Community Contributions 1 February 19, 2016 05:21
source term in near wall cell rajcfd OpenFOAM Pre-Processing 5 February 1, 2016 10:31
[swak4Foam] Install swak4Foam on OpenFOAM1.7.1 on Ubuntu 13.04 kobayashi OpenFOAM Community Contributions 2 January 5, 2014 17:33
[swak4Foam] fails in parallel with -otherTime? Phicau OpenFOAM Community Contributions 3 June 26, 2013 13:00


All times are GMT -4. The time now is 01:54.