CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > OpenFOAM > OpenFOAM Community Contributions

[waves2Foam] OF 2.2, problems using waveFoam, command not found

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   December 9, 2015, 12:49
Default OF 2.2, problems using waveFoam, command not found
  #1
New Member
 
Niels D
Join Date: Nov 2015
Posts: 4
Rep Power: 10
Slein is on a distinguished road
Hi,

For the moment i am running OpenFoam-2.2.2 and tried to use waves2Foam today. When compiling the source code for waves2Foam no problems occur.

When i am trying to run the tutorial waveFlume, the pre-processing commands like blockMesh, ... do work. But the command waveFoam does not work. The error i am getting when using ./Allrun is:

niels@niels-HP-Pavilion-17-Notebook-PC:~/OpenFOAM/niels-2.2.2/applications/utilities/waves2Foam/tutorials/waveFoam/waveFlume$ ./Allrun
Running blockMesh on /home/niels/OpenFOAM/niels-2.2.2/applications/utilities/waves2Foam/tutorials/waveFoam/waveFlume
Running waveGaugesNProbes on /home/niels/OpenFOAM/niels-2.2.2/applications/utilities/waves2Foam/tutorials/waveFoam/waveFlume
Running setWaveParameters on /home/niels/OpenFOAM/niels-2.2.2/applications/utilities/waves2Foam/tutorials/waveFoam/waveFlume
Running setWaveField on /home/niels/OpenFOAM/niels-2.2.2/applications/utilities/waves2Foam/tutorials/waveFoam/waveFlume
Running waveFoam on /home/niels/OpenFOAM/niels-2.2.2/applications/utilities/waves2Foam/tutorials/waveFoam/waveFlume
Running postProcessWaves2Foam on /home/niels/OpenFOAM/niels-2.2.2/applications/utilities/waves2Foam/tutorials/waveFoam/waveFlume
/home/niels/OpenFOAM/OpenFOAM-2.2.2/bin/tools/RunFunctions: line 42: 22079 Segmentation fault (core dumped) $APP_RUN "$@" > log.$APP_NAME 2>&1

When only using the command waveFoam, the error is that the command can not be found. The other pre-processing commands work just fine.

Thanks in advance
Slein is offline   Reply With Quote

Old   December 10, 2015, 11:18
Default
  #2
ngj
Senior Member
 
Niels Gjoel Jacobsen
Join Date: Mar 2009
Location: Copenhagen, Denmark
Posts: 1,901
Rep Power: 37
ngj will become famous soon enoughngj will become famous soon enough
Good afternoon,

@Slein: If waveFoam does not exist, it means that not everything went as smoothly in the compilation process as you think.

Kind regards,

Niels
__________________
Please note that I do not use the Friend-feature, so do not be offended, if I do not accept a request.

Last edited by wyldckat; August 25, 2018 at 12:09. Reason: removed answers to other posts that were on the main thread
ngj is offline   Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
[Gmsh] Insatlling gmsh from the source code-issue? CFD-Lover OpenFOAM Meshing & Mesh Conversion 20 June 12, 2018 06:39
[Other] Mesh Importing Problem cuteapathy ANSYS Meshing & Geometry 2 June 24, 2017 05:29
dsmcInitialise - dsmcFoam archymedes OpenFOAM Pre-Processing 94 July 15, 2016 16:14
OpenFOAM15 installables are incomplete problem with paraFoam tryingof OpenFOAM Bugs 17 December 7, 2008 04:41
Problem with rhoSimpleFoam matteo_gautero OpenFOAM Running, Solving & CFD 0 February 28, 2008 06:51


All times are GMT -4. The time now is 23:16.