CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > OpenFOAM > OpenFOAM Installation

paraview not working after installing OpenFOAM in Ubuntu 12.04

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   October 7, 2014, 06:02
Default paraview not working after installing OpenFOAM in Ubuntu 12.04
  #1
Member
 
chen long
Join Date: Dec 2012
Posts: 32
Rep Power: 10
Jackie Chen is on a distinguished road
Hello all.

I just installed OF-2.3.0 on Ubuntu 12.04 following these instructions: http://www.openfoam.org/download/ubuntu.php

The paraView cannot run properly
When I try to run it the following error arises:
Anyone knows the problem?Thanks in advance
Code:
FATAL ERROR: ParaView reader module libraries do not exist Please build the reader module before continuing: cd $FOAM_UTILITIES/postProcessing/graphics/PV3Readers ./Allwclean ./Allwmake
Jackie Chen is offline   Reply With Quote

Old   October 7, 2014, 09:57
Default
  #2
Member
 
Join Date: Jun 2011
Posts: 53
Rep Power: 12
blacksquirrel is on a distinguished road
Hi Jackie,

Try this instructions:
http://openfoamwiki.net/index.php/In...M-2.3.0/Ubuntu
The paraview for OF2.3.0 needs a newer cmake and you need to custom build your paraview.
blacksquirrel is offline   Reply With Quote

Old   October 8, 2014, 01:56
Default
  #3
Member
 
chen long
Join Date: Dec 2012
Posts: 32
Rep Power: 10
Jackie Chen is on a distinguished road
Hi

Thanks for your reply. However, when i reach step 5. it shows failed to create symbolic link. and no such file or directory.

Do you know what is the problem?
Thanks
Jackie Chen is offline   Reply With Quote

Old   October 8, 2014, 03:12
Default
  #4
Member
 
chen long
Join Date: Dec 2012
Posts: 32
Rep Power: 10
Jackie Chen is on a distinguished road
BTW, can i uninstall the latest version of OF and use the previous version?Thanks
Jackie Chen is offline   Reply With Quote

Old   October 8, 2014, 05:26
Default
  #5
Member
 
Join Date: Jun 2011
Posts: 53
Rep Power: 12
blacksquirrel is on a distinguished road
Hi Jackie,

Yes, you can uninstall the new version of OF and use an older one.

In the step by step instruction in the CFD wiki: step5 is an optional step and not related to your paraview problem. Important steps are 8-10.

And if that not works, have a look at this thread:
http://www.cfd-online.com/Forums/ope...not-exist.html
This is a similar problem, the other way round. (new system, old OF)
blacksquirrel is offline   Reply With Quote

Old   October 9, 2014, 06:28
Default
  #6
Member
 
chen long
Join Date: Dec 2012
Posts: 32
Rep Power: 10
Jackie Chen is on a distinguished road
Thanks, it works now!
Jackie Chen is offline   Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Installing OpenFOAM 2.2.0 on Ubuntu 12.10 i686 AHutchison OpenFOAM Installation 6 June 4, 2013 12:11
Installing OpenFOAM 1.6-ext on Ubuntu 11.10 immortality OpenFOAM Installation 17 May 6, 2013 17:43
Whats the video card recommended for Paraview 3120 in Ubuntu 12.04? chujeh2020 Hardware 1 July 14, 2012 12:03
New OpenFOAM Forum Structure jola OpenFOAM 2 October 19, 2011 06:55
Installing OpenFOAM 1.7.0 on Ubuntu Hardy 64bit nuovodna OpenFOAM 2 July 1, 2010 09:24


All times are GMT -4. The time now is 12:48.