CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > OpenFOAM > OpenFOAM Installation

[OpenFOAM.org] OpenFOAM 2.4 on Ubuntu 14.04 - gcc not found?

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   July 9, 2015, 15:52
Default OpenFOAM 2.4 on Ubuntu 14.04 - gcc not found?
  #1
Member
 
Jam Racing 2015's Avatar
 
john mcgeorge
Join Date: Jul 2015
Location: South Africa Pinetown
Posts: 36
Rep Power: 10
Jam Racing 2015 is on a distinguished road
Hi.I am new to OpenFOAM.HavE installed Ubuntu 14.04 LTS and OpenFOAM2.4.0 and cannot get working.It says I need gcc version.What is that.Is it an Ubuntu or OpenFOAM problem.Please someone get me going in the right direction.Thanks.I am in South Africa so not much help here.
Jam Racing 2015 is offline   Reply With Quote

Old   July 9, 2015, 16:20
Default
  #2
Member
 
Refik
Join Date: Dec 2014
Location: Turkey
Posts: 56
Rep Power: 11
rewol is on a distinguished road
I recently installed ubuntu 14.04 and openFOAM 2.4 and they work just fine.But i myself encountered some issues to properly get it to work, and had some issues with paraview too.Turned out that there were some files missing that was needed to open paraview.

Try to go through the forums, i am sure you will find what you are looking for.
rewol is offline   Reply With Quote

Old   July 9, 2015, 16:25
Default OpenFOAM
  #3
Member
 
Jam Racing 2015's Avatar
 
john mcgeorge
Join Date: Jul 2015
Location: South Africa Pinetown
Posts: 36
Rep Power: 10
Jam Racing 2015 is on a distinguished road
ThAnks for quick reply.I have been through forums and other sites.Just cannot work out problem.I have OpenFOAM 15.06 on Windows 7 and it works.All I want to do is test bodywork of my Formula Vee racing car to see how it compares to results I got in my small wind tunnel using a model.
Jam Racing 2015 is offline   Reply With Quote

Old   July 9, 2015, 16:28
Default
  #4
Member
 
Refik
Join Date: Dec 2014
Location: Turkey
Posts: 56
Rep Power: 11
rewol is on a distinguished road
What exactly is the error when you try to run a simulation ? Did you menage to compile openfoam or is there a problem with the solvers etc ?
rewol is offline   Reply With Quote

Old   July 9, 2015, 16:39
Thumbs down OpenFOAM
  #5
Member
 
Jam Racing 2015's Avatar
 
john mcgeorge
Join Date: Jul 2015
Location: South Africa Pinetown
Posts: 36
Rep Power: 10
Jam Racing 2015 is on a distinguished road
It says I need version gcc=4.5.0 and uname.Warning Conflicting installations.OpenFOAM environment not configured.Need valid host name.These errors get when foamInstallationTest is run.
Jam Racing 2015 is offline   Reply With Quote

Old   July 9, 2015, 16:46
Default
  #6
Member
 
Refik
Join Date: Dec 2014
Location: Turkey
Posts: 56
Rep Power: 11
rewol is on a distinguished road
I think you should update the proper gcc version as root.
rewol is offline   Reply With Quote

Old   July 9, 2015, 16:56
Default OpenFOAM
  #7
Member
 
Jam Racing 2015's Avatar
 
john mcgeorge
Join Date: Jul 2015
Location: South Africa Pinetown
Posts: 36
Rep Power: 10
Jam Racing 2015 is on a distinguished road
I did look today but was not sure where to find it.Is it missing frm OpenFOAM or Ubuntu.Do I download frm internet?Sorry but I am dumb when it comes to this.
Jam Racing 2015 is offline   Reply With Quote

Old   July 10, 2015, 05:21
Default
  #8
Senior Member
 
Saideep
Join Date: Apr 2015
Location: INDIA
Posts: 203
Rep Power: 12
Saideep is on a distinguished road
Hi,

Welcome to OpenFOAM.

GCC is the C++ compiler and as far as I remember i installed ubuntu initially(14.04 LTS) and later openfoam and i had no problems with gcc compilers. So, by default openfoam uses gcc compiler.

Well I guess it is not complicated and i suggest you to remove the previously installed version of openfoam and start once again.
Remove the main folder within your opts or user directory. Take care while changing your .bashrc file. If you have multiple versions it gets complicated and you will need to use alias for specific versions.

Actually you can follow the step wise process here:
http://www.openfoam.org/download/ubuntu.php

and related information about the version{this is always a pain working and switching between versions}:
http://www.openfoam.org/download/source.php

From your message i read there is some sort of older version installed and from openfoam 2.2 gcc versions >4.5 are only allowed for usage.

Hope this helps;
Saideep
Saideep is offline   Reply With Quote

Old   July 10, 2015, 05:41
Default OpenFOAM
  #9
Member
 
Jam Racing 2015's Avatar
 
john mcgeorge
Join Date: Jul 2015
Location: South Africa Pinetown
Posts: 36
Rep Power: 10
Jam Racing 2015 is on a distinguished road
Thanks for ur answer.Now I wud like to remove all Ubuntu and OF and then reload everything correctly.I know how to do that with Windows but how does one do that with Linux...thanks
Jam Racing 2015 is offline   Reply With Quote

Old   July 10, 2015, 06:10
Default
  #10
Senior Member
 
Saideep
Join Date: Apr 2015
Location: INDIA
Posts: 203
Rep Power: 12
Saideep is on a distinguished road
Hi,

I guess there is no problem with Ubuntu. May be you can just remove openfoam and later check from your terminal if any sort of gcc version exists.

Use gcc --version to know about it.
Saideep is offline   Reply With Quote

Old   July 10, 2015, 06:14
Default OpenFOAM
  #11
Member
 
Jam Racing 2015's Avatar
 
john mcgeorge
Join Date: Jul 2015
Location: South Africa Pinetown
Posts: 36
Rep Power: 10
Jam Racing 2015 is on a distinguished road
Did check it is version 4.8.2-19ubuntu.Is that ok for OF 2.4.0 ???
Jam Racing 2015 is offline   Reply With Quote

Old   July 10, 2015, 06:18
Default
  #12
Senior Member
 
Saideep
Join Date: Apr 2015
Location: INDIA
Posts: 203
Rep Power: 12
Saideep is on a distinguished road
yes thats fine now you can install step wise and it should work fine.

All the best!!
Saideep is offline   Reply With Quote

Old   July 10, 2015, 07:23
Default OpenFOAM
  #13
Member
 
Jam Racing 2015's Avatar
 
john mcgeorge
Join Date: Jul 2015
Location: South Africa Pinetown
Posts: 36
Rep Power: 10
Jam Racing 2015 is on a distinguished road
What is step wise.When OpenFOAM is installed correctly where is it viewed.In its own window??
Jam Racing 2015 is offline   Reply With Quote

Old   July 10, 2015, 09:34
Default
  #14
Senior Member
 
Saideep
Join Date: Apr 2015
Location: INDIA
Posts: 203
Rep Power: 12
Saideep is on a distinguished road
Hi,

I just meant follow the steps as they are specified in the webpage for installation for the ubuntu 14.04lts version.

After installation, openfoam would be present in the users directory. After installation just follow the steps mentioned in Chapter 2 of the openfoam user guide, to copy the tutorial folder to your home directory.

Saideep
Saideep is offline   Reply With Quote

Old   July 10, 2015, 09:40
Default OpenFOAM
  #15
Member
 
Jam Racing 2015's Avatar
 
john mcgeorge
Join Date: Jul 2015
Location: South Africa Pinetown
Posts: 36
Rep Power: 10
Jam Racing 2015 is on a distinguished road
I did run through installation and still get errors.I am sure problem is with Ubuntu.How can I delete all Ubuntu off my pc and start over.I have been at this for abt 2 weeks.Also found out u load frm command line which I found.Thanks for ur help.U make things clearer.
Jam Racing 2015 is offline   Reply With Quote

Old   July 10, 2015, 12:08
Default
  #16
Member
 
Refik
Join Date: Dec 2014
Location: Turkey
Posts: 56
Rep Power: 11
rewol is on a distinguished road
You can use OS-Uninstaller to remove Ubuntu, though i suggest you try to fix the error. Removal of operating systems are always complicated for my case and i believe openFoam works much more efficient on ubuntu than it does on Windows.
rewol is offline   Reply With Quote

Old   July 10, 2015, 12:17
Default OpenFOAM
  #17
Member
 
Jam Racing 2015's Avatar
 
john mcgeorge
Join Date: Jul 2015
Location: South Africa Pinetown
Posts: 36
Rep Power: 10
Jam Racing 2015 is on a distinguished road
I get error $1 9 not installed and still version is incorrect but it is 4.8.I have now loaded 2.2.2 but same errors
Jam Racing 2015 is offline   Reply With Quote

Old   July 11, 2015, 08:17
Default OpenFOAM
  #18
Member
 
Jam Racing 2015's Avatar
 
john mcgeorge
Join Date: Jul 2015
Location: South Africa Pinetown
Posts: 36
Rep Power: 10
Jam Racing 2015 is on a distinguished road
The Ubuntu 14.04 LTS has files missing where can I download an error free copy from? Thanks
Jam Racing 2015 is offline   Reply With Quote

Reply

Tags
openfoam 2.4.0 help

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
[Gmsh] Insatlling gmsh from the source code-issue? CFD-Lover OpenFOAM Meshing & Mesh Conversion 20 June 12, 2018 06:39
OpenFoam 2.3.0 on Ubuntu 14.04 CHagen OpenFOAM Installation 4 October 6, 2014 09:53
Problems with OpenFOAM 2.3.0 on Ubuntu 14.04 smallzilla OpenFOAM Installation 15 September 14, 2014 12:11
OpenFOAM 1.6 ext fportela OpenFOAM Installation 11 December 26, 2013 18:55
critical error during installation of openfoam Fabio88 OpenFOAM Installation 21 June 2, 2010 03:01


All times are GMT -4. The time now is 21:26.