CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > OpenFOAM > OpenFOAM Installation

[OpenFOAM.org] Problems with Paraview (OpenFOAM 2.4.0 from source code in Ubuntu 14.04)

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   July 26, 2015, 08:24
Default Problems with Paraview (OpenFOAM 2.4.0 from source code in Ubuntu 14.04)
  #1
Member
 
Join Date: Jul 2015
Location: Aalborg
Posts: 83
Rep Power: 6
Gerrit is on a distinguished road
Hi,

I am new to OpenFoam CFD and hope to not ask a stupid question or repeat an answered question.
I have Ubuntu 14.04 LTS on my computer and followed the guide from this page:http://www.openfoam.org/download/source.php

After finishing the installation I followed the steps on that page of "Getting Started".
Code:
cd $FOAM_RUN/tutorials/incompressible/icoFoam/cavity
blockMesh 
icoFoam
this part ran without trouble. In the folder I have now new folders of the calculation steps from 0 to 0.5.

When using the command
Code:
paraFoam
, I receive an error massage:
Code:
FATAL ERROR: ParaView reader module libraries do not exist

Please build the reader module before continuing:
cd $FOAM_UTILITIES/postProcessing/graphics/PV4Readers
./Allwclean
./Allwmake
Following that instructions I receive a new error massage at
Code:
 ./Allwmake
Code:
ERROR: ParaView not found in /home/gerrit/OpenFOAM/ThirdParty-2.4.0/platforms/linux64Gcc/ParaView-4.1.0
I checked the folder linux64Gcc and there is no Paraview folder.

What would be the next step? Download Paraview somewhere and simply copy it in that folder?

Thanky you very much.

Best regards
Gerrit
Gerrit is offline   Reply With Quote

Old   July 26, 2015, 10:38
Default
  #2
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 10,956
Blog Entries: 43
Rep Power: 121
wyldckat is a name known to allwyldckat is a name known to allwyldckat is a name known to allwyldckat is a name known to allwyldckat is a name known to allwyldckat is a name known to all
Greetings Gerrit and welcome to the forum!

According to your description, it seems that perhaps you didn't follow the steps from the section "Compiling Paraview and the Paraview Reader Module" on that page, where it instructs how to build ParaView 4.1.0 from source code: http://www.openfoam.org/download/source.php
The source code itself is already provided in the folder "ThirdParty-2.4.0", therefore you don't need to download ParaView's source code.

If you have trouble following the instructions provided on that page, you might want to try these instructions: http://openfoamwiki.net/index.php/In...u#Ubuntu_14.04

Best regards,
Bruno
__________________
wyldckat is offline   Reply With Quote

Old   July 26, 2015, 14:00
Default
  #3
Member
 
Join Date: Jul 2015
Location: Aalborg
Posts: 83
Rep Power: 6
Gerrit is on a distinguished road
Hi Bruno,

thank you for your answer, I will try it again!

Best regards
Gerrit
Gerrit is offline   Reply With Quote

Old   August 5, 2015, 17:14
Default
  #4
Member
 
Join Date: Jul 2015
Location: Aalborg
Posts: 83
Rep Power: 6
Gerrit is on a distinguished road
Hi,

I could get it to run by following the Ubuntu Deb Pack Installation.

http://www.openfoam.org/download/ubuntu.php

Thank you anyway!
BR
Gerrit
Gerrit is offline   Reply With Quote

Old   August 15, 2015, 12:05
Default
  #5
Member
 
Davi Barreira
Join Date: Apr 2014
Location: Fortaleza
Posts: 76
Rep Power: 7
davibarreira is on a distinguished road
Gerrit,

I recently faced the same problem with OF 2.4.x. I solved using the solution provided here http://www.openfoam.org/mantisbt/view.php?id=1734.

Basically, go into the folder OpenFOAM/ThirdParty-2.4.x/ParaView-4.1.0/VTK/Rendering/OpenGL , and alter the vtkXOpenGLRenderWindow.cxx file, by uncommenting #define GLX_GLXEXT_LEGACY
davibarreira is offline   Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
polynomial BC srv537 OpenFOAM Pre-Processing 4 December 3, 2016 10:07
OpenFOAM without MPI kokizzu OpenFOAM Installation 4 May 26, 2014 10:17
[swak4Foam] Error bulding swak4Foam sfigato OpenFOAM Community Contributions 18 August 22, 2013 13:41
[swak4Foam] build problem swak4Foam OF 2.2.0 mcathela OpenFOAM Community Contributions 14 April 23, 2013 14:59
Adventure of fisrst openfoam installation on Ubuntu 710 jussi OpenFOAM Installation 0 April 24, 2008 15:25


All times are GMT -4. The time now is 19:03.