CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > OpenFOAM > OpenFOAM Installation

[OpenFOAM.org] Install OpenFOAM 2.3.x on Mac OS

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   September 17, 2019, 12:08
Exclamation Install OpenFOAM 2.3.x on Mac OS
  #1
New Member
 
Guido
Join Date: Sep 2019
Posts: 3
Rep Power: 2
gxuk is on a distinguished road
Dear Forum,

I will start using OpenFOAM for my master thesis project regarding simulation of wind turbine.
I am having some difficulties in finding an optimal solution for installing OpenFOAM 2.3.x on Mac OS Mojave 10.14.6.
  1. Do you suggest me to switch absolutely to Linux or is it ok to work on Mac OS?
  2. Even if suggested, is there a way to avoid using docker and compile directly on Mac OS OpenFOAM 2.3.x ?

Thanks
Best Regards,

Guido
gxuk is offline   Reply With Quote

Old   September 22, 2019, 08:23
Default
  #2
HPE
New Member
 
Herpes Free Engineer
Join Date: Sep 2019
Posts: 25
Rep Power: 2
HPE is on a distinguished road
I kindly suggest you to forget about OF 2.3.x, which is not being maintained anymore since the new versions are available.

Either OpenFOAM 1906 or OpenFOAM v7 should be used.

The full maintenance support is for Linux, I would always use Linux instead of Unix or Windows. But the new versions afaik are compatible with Mac and Windows.
__________________
Kind regards,
HPE
HPE is offline   Reply With Quote

Old   September 22, 2019, 11:11
Default
  #3
New Member
 
Guido
Join Date: Sep 2019
Posts: 3
Rep Power: 2
gxuk is on a distinguished road
Quote:
Originally Posted by HPE View Post
I kindly suggest you to forget about OF 2.3.x, which is not being maintained anymore since the new versions are available.

Either OpenFOAM 1906 or OpenFOAM v7 should be used.
Thanks for your reply HPE. As you can imagine I am very beginner.
At the moment I should work on a previous code written in OpenFOAM 2.3.x and I have been told that the next versions cannot compile the very same code.

Question 1 : do you suggest a beginner to migrate to the last version or do you think is better to just compile OpenFOAM 2.3.x ?
Question 2 : is there a docker container of OpenFOAM 2.3.x ?
gxuk is offline   Reply With Quote

Old   September 22, 2019, 13:25
Default
  #4
HPE
New Member
 
Herpes Free Engineer
Join Date: Sep 2019
Posts: 25
Rep Power: 2
HPE is on a distinguished road
Quote:
Originally Posted by gxuk View Post
Thanks for your reply HPE. As you can imagine I am very beginner.
At the moment I should work on a previous code written in OpenFOAM 2.3.x and I have been told that the next versions cannot compile the very same code.

Question 1 : do you suggest a beginner to migrate to the last version or do you think is better to just compile OpenFOAM 2.3.x ?
Question 2 : is there a docker container of OpenFOAM 2.3.x ?
"the next versions cannot compile the very same code."

I rephrase their remark as that they are not able to refactor their code, so that it can be compiled with the new version, because they have no clue in coding simple tweaks (since OpenFOAM always take care of backward compatibility for years but not a decade), but they cannot admit it.

"Question 1 : do you suggest a beginner to migrate to the last version or do you think is better to just compile OpenFOAM 2.3.x ?"

IMHO, you must forget OF 2.3 for your long-term good. Attending a programming course, or a self thought course will enable you to perform the code tweaks you need for the code compilation.

"Question 2 : is there a docker container of OpenFOAM 2.3.x ?"

I don't know I am afraid.
__________________
Kind regards,
HPE
HPE is offline   Reply With Quote

Old   September 26, 2019, 05:44
Default
  #5
Member
 
Glenn Carlson
Join Date: Oct 2012
Location: US
Posts: 37
Rep Power: 8
gcengineer is on a distinguished road
Especially for a beginner, I suggest using the latest version of OF -- OF7 or OFv1906 -- in Ubuntu 18.04. OF in Ubuntu is well tested. Is there a utility or feature for OF 2.3 that you need but doesn't exist for OF7 or OFv1906? If not, use the latest version.


I run OF7 and OFv1906 with Paraview 5.6 in Ubuntu 18.04. A Qt version mismatch error that I and others have seen when building Paraview 5.6 is solved: Qt5, OpenFOAM-7 and -v1906, and Ubuntu 18.04


Good luck.
gcengineer is offline   Reply With Quote

Reply

Tags
docker, mac os, openfoam 2.3.x

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
[OpenFOAM.org] Install OpenFOAM without admin right OpenFoamlove OpenFOAM Installation 1 December 31, 2017 11:45
OpenFOAM v3.0+ ?? SBusch OpenFOAM 22 December 26, 2016 14:24
[OpenFOAM.org] OpenFOAM 2.3.x for Mac at GitHub ajmas OpenFOAM Installation 2 April 20, 2015 16:23
Any Parallel install procedure on Mac OS JinZhiyi SU2 Installation 2 March 11, 2014 01:12
New OpenFOAM Forum Structure jola OpenFOAM 2 October 19, 2011 06:55


All times are GMT -4. The time now is 09:57.