CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > OpenFOAM > OpenFOAM Pre-Processing

totalPressure Error

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   August 10, 2022, 07:30
Default totalPressure Error
  #1
New Member
 
Matthew
Join Date: May 2021
Posts: 10
Rep Power: 3
Tegdlemat is on a distinguished road
Hi everyone,

I am currently attempting to simulate a shock train phenomenon as shown in the first picture with rhoCentralFoam. In my case, I require a inlet pressure at 47000pa and outlet pressure at 104000pa, with inlet Mach number at 1.61 and temperature at 197K. I am using the boundary conditions below for the simulation, and the pressure at the inlet matches the target pressure magnitude, but not at the outlet. I wonder if I implied the totalpressure wrongly that causes the pressure there basically equals to the total pressure I defined. I have included the pressure contour as the second picture. I would be very grateful if anyone could lend my a helping hand.


0/p
Code:
dimensions      [1 -1 -2 0 0 0 0];

internalField     uniform 47984;

boundaryField
{
    Inlet
    {   
        type           totalPressure;
        p0              uniform 207000;
        gamma      1.4;
        psi              thermo:psi;
        value          uniform 47984;
    } 

    Outlet
    {
        type           totalPressure;
        p0              uniform 451260;
        gamma      1.4;
        psi              thermo:psi;
        value          uniform 104859;
    }

    Wall
    {
        type            zeroGradient;
    }

    Sides
    {
        type            empty;
    }
0/T
Code:
dimensions      [0 0 0 1 0 0 0];

internalField   uniform 197.6;

boundaryField
{
    Inlet
    {
       type            fixedValue;
       value          uniform 197.6;
    }

    Outlet
    {
        type            zeroGradient;
    }

    Wall
    {
        type            zeroGradient;
    }

    Sides
    {
        type            empty;
    }
0/U
Code:
dimensions      [0 1 -1 0 0 0 0];

internalField   uniform (453.65 0 0);

boundaryField
{
    Inlet
    {
        type            pressureInletOutletVelocity;
        value           $internalField;
    }

    Outlet
    {
        type            pressureInletOutletVelocity;
        value           $internalField;
    }

    Wall
    {
         type            noSlip;
    }

    Sides
    {
        type            empty;
    }
Attached Images
File Type: png image_2022-08-10_182923367.png (89.9 KB, 6 views)
File Type: png image_2022-08-10_182946608.png (22.0 KB, 8 views)
Tegdlemat is offline   Reply With Quote

Old   October 29, 2022, 09:04
Default
  #2
Member
 
Sakun
Join Date: Nov 2019
Location: United Kingdom
Posts: 68
Rep Power: 5
Sakun is on a distinguished road
Hi,


Did you manage to sort this out ?
Sakun is offline   Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
DPM udf error haghshenasfard FLUENT 0 April 13, 2016 07:35
[swak4Foam] GroovyBC the dynamic cousin of funkySetFields that lives on the suburb of the mesh gschaider OpenFOAM Community Contributions 300 October 29, 2014 19:00
OpenFOAM without MPI kokizzu OpenFOAM Installation 4 May 26, 2014 10:17
Problem with compile the setParabolicInlet ivanyao OpenFOAM Running, Solving & CFD 6 September 5, 2008 21:50
DecomposePar links against liblamso0 with OpenMPI jens_klostermann OpenFOAM Bugs 11 June 28, 2007 18:51


All times are GMT -4. The time now is 18:07.