CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > OpenFOAM > OpenFOAM Programming & Development

Problems installing waves2Foam extension

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   October 28, 2022, 12:18
Default Problems installing waves2Foam extension
  #1
New Member
 
Jaime Martins-Barata
Join Date: Oct 2022
Posts: 1
Rep Power: 0
JaimeMB is on a distinguished road
Dear all,

I have been trying for the past week to install waves2Foam to perform NWT simulations for my final year university project, however, all attempts have been unsuccessful. I am using a Mac (macOS Big Sur v11.4 silicon chip), I have installed all the required third party dependencies (git (v2.33.0), gfortran, GNU science library and svn (installed using brew)), I am running OpenFoam 10 (on which I have already run and post-processed a couple of tutorial simulations). Whenever I attempt to run the command ./Allwmake I get the following error message:

=====================================
COMPILE OCEANWAVE3D
=====================================

Pull changes from the OceanWave3D git repository ...
Saved working directory and index state WIP on master: bb7d99e bug fix for calling OceanWave3D
Already up to date.
On branch master
Your branch is up to date with 'origin/master'.

Changes not staged for commit:
(use "git add <file>..." to update what will be committed)
(use "git restore <file>..." to discard changes in working directory)
modified: common.mk
modified: makefile

no changes added to commit (use "git add" and/or "git commit -a")
Dropped refs/stash@{0} (0d899fd10c35773ec3c6cd8f6693e2a11fcc2411)

Set the environmental variables for waves2Foam
Exiting compilation process


Problems with the compilation of the third party dependencies
Exiting

Before attempting to use waves2Foam, I tried using OlaFlow but also found myself having problems with compilation (this time compiling the solvers). If you have any idea on how to solve this problem, or any alternative 2D & 3D NWT simulators please do not hesitate to contact me.

Thank you, Jaime MB
JaimeMB is offline   Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
[foam-extend.org] Problems on installing Foam-extend 4.0/ swak4Foam on ubuntu18.0.4 XJ_Wang OpenFOAM Installation 22 December 19, 2021 07:55
[foam-extend.org] Problems installing the FSI-toolkit on foam-extend-4.0 Elstro OpenFOAM Installation 0 June 20, 2021 17:50
[waves2Foam] installing waves2foam into OpenFoam 6 madgeogr OpenFOAM Community Contributions 1 June 15, 2021 11:17
[OpenFOAM.com] v3.0+ Problems installing on Ubuntu 16.04 Evander OpenFOAM Installation 3 March 26, 2017 14:47
Problems installing OpenFOAM 2.3.0, 1.6-ext and foam-extend 3.0 sam.ho OpenFOAM Installation 35 April 5, 2014 15:31


All times are GMT -4. The time now is 06:23.