CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Running, Solving & CFD

Problems running OF on cluster

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   January 13, 2016, 21:48
Default Problems running OF on cluster
  #1
New Member
 
Kate Fang
Join Date: Jun 2014
Posts: 2
Rep Power: 0
kate.F is on a distinguished road
Dear FOAMers,

I have encountered a problem while running a case on cluster and got the error(part of it):

Quote:
WARNING: Error in initializing MVAPICH2 ptmalloc library.Continuing without InfiniBand registration cache support.
[7] [4] [3] [6] [10] [9] [15] [5]



[4] [7] [3]


[4] [7] [3] [6] --> FOAM FATAL IO ERROR: --> FOAM FATAL IO ERROR: --> FOAM FATAL IO ERROR:


[6]
--> FOAM FATAL IO ERROR: [4] [7] [3]
wrong token type - expected Scalar, found on line 0 the word 'nan'wrong token type - expected Scalar, found on line 0 the word 'nan'

wrong token type - expected Scalar, found on line 0 the word 'nan'

[5]
[4]

[10] [9] [15] [5]


[14] [9] --> FOAM FATAL IO ERROR: [4] --> FOAM FATAL IO ERROR:
[15] file:
[11] /scratch/03857/tg831567/SC5/processor4/system/data.solverPerformance.p[5] [9] [12] at line [8]
[11] [0] 0
.
[4] [11]
The log file:
Quote:
Time = 20.558

Courant Number mean: 0.028402 max: 0.11946
smoothSolver: Solving for Ux, Initial residual = 0.758777, Final residual = 9.92998e-09, No Iterations 4
smoothSolver: Solving for Uy, Initial residual = 0.399664, Final residual = 2.49574e-08, No Iterations 4
smoothSolver: Solving for Uz, Initial residual = 0.0129346, Final residual = 3.99374e-08, No Iterations 3
GAMG: Solving for p, Initial residual = 0.00802443, Final residual = 0.000744506, No Iterations 21
GAMG: Solving for p, Initial residual = 0.00167003, Final residual = 0.000155684, No Iterations 24
time step continuity errors : sum local = 4.97087e-08, global = 8.01521e-09, cumulative = -5.85061e-07
GAMG: Solving for p, Initial residual = 0.032428, Final residual = 0.00219924, No Iterations 2
GAMG: Solving for p, Initial residual = 0.00244059, Final residual = 9.45781e-07, No Iterations 64
time step continuity errors : sum local = 2.71954e-10, global = 4.74174e-11, cumulative = -5.85013e-07
ExecutionTime = 27940.8 s ClockTime = 28738 s

Time = 20.56

Courant Number mean: 0.0282469 max: 0.118619
smoothSolver: Solving for Ux, Initial residual = 0.327472, Final residual = 4.42746e-09, No Iterations 4
smoothSolver: Solving for Uy, Initial residual = 0.180964, Final residual = 1.13125e-08, No Iterations 4
smoothSolver: Solving for Uz, Initial residual = 0.0103192, Final residual = 3.28473e-08, No Iterations 3
GAMG: Solving for p, Initial residual = 0.00895919, Final residual = 0.000816276, No Iterations 20
GAMG: Solving for p, Initial residual = 0.00165398, Final residual = 0.000153604, No Iterations 24
time step continuity errors : sum local = 2.04548e-08, global = 3.5577e-09, cumulative = -5.81455e-07
GAMG: Solving for p, Initial residual = 1, Final residual = nan, No Iterations 1000
GAMG: Solving for p, Initial residual = nan, Final residual = nan, No Iterations 1000
And I have run the identical case on the clusters of another institution, as well as on my local machine, it worked well.

It is LES case, cell number 3.75 million. subdomain: simple, (12,4,1). The OpenFOAM versions on the two clusters and my workstation are all 2.3.0. Does any one have any idea about the problem?
kate.F is offline   Reply With Quote

Old   January 14, 2016, 06:20
Default
  #2
Senior Member
 
Alexey Matveichev
Join Date: Aug 2011
Location: Nancy, France
Posts: 1,438
Rep Power: 25
alexeym will become famous soon enoughalexeym will become famous soon enough
Hi,

You problem is divergence

Code:
Time = 20.56

Courant Number mean: 0.0282469 max: 0.118619
...
GAMG: Solving for p, Initial residual = 1, Final residual = nan, No Iterations 1000
GAMG: Solving for p, Initial residual = nan, Final residual = nan, No Iterations 1000
Why GAMG is diverging? It depends on GAMG settings (and maybe IC/BC). Could you reproduce the error with PCG?
alexeym is offline   Reply With Quote

Old   January 14, 2016, 13:33
Default
  #3
New Member
 
Kate Fang
Join Date: Jun 2014
Posts: 2
Rep Power: 0
kate.F is on a distinguished road
Hi Alexey,
Thank you very much for you reply. I have run the identical case elsewhere( my workstation, and cluster of another institution) and it worked well, no divergence. And that is why I'm confused and don't know what is the problem.
I'll try PCG and will post the result here.

Thank you again!
kate.F is offline   Reply With Quote

Reply

Tags
cluster computing, divergence

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
High system load running OF-2.2 on cluster, but not OF-2.1 sylvester OpenFOAM Running, Solving & CFD 3 January 22, 2014 07:54
Problems running in parallel - Pstream not available dark lancer OpenFOAM Installation 14 October 13, 2013 14:13
Problem running OF on cluster Rebecca513 OpenFOAM Running, Solving & CFD 14 August 26, 2012 17:09
Weird problems running unsteady braennstroem OpenFOAM Running, Solving & CFD 5 June 8, 2011 20:38
Problems in a Background running of Intel Fortran Minsuk Choi Main CFD Forum 2 February 11, 2005 05:55


All times are GMT -4. The time now is 10:12.