CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > OpenFOAM > OpenFOAM Running, Solving & CFD

problems when using interFoam

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   December 15, 2019, 22:33
Default problems when using interFoam
  #1
New Member
 
Peida Han
Join Date: Nov 2019
Location: Beijing, China
Posts: 6
Rep Power: 4
Peida is on a distinguished road
Hello everyone,

I am new beginner, and I’m using interFoam in a simple case. I have a big pool filled with water. The top of the pool is open to atmosphere. The maxY of the pool has an outlet -- I use shallowWaterAbsorbtion. The other boundarys are set as walls.

It‘s a really simple case but the result diverges in several seconds. I find some large velocities near maxY and the deltaT becomes smaller and smaller. You can see planform belows. And I upload my code here.
Attached Images
File Type: png simplepool.png (16.7 KB, 7 views)
Attached Files
File Type: zip simplepool.zip (16.2 KB, 0 views)
Peida is offline   Reply With Quote

Old   December 15, 2019, 22:36
Default
  #2
New Member
 
Peida Han
Join Date: Nov 2019
Location: Beijing, China
Posts: 6
Rep Power: 4
Peida is on a distinguished road
Sorry, the problem was solved.

One thing shoud be noticed:

the Y direction but not Z direction in wave module refers to vertical direction.

Last edited by Peida; December 16, 2019 at 03:27.
Peida is offline   Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Benchmarking interFOAM -- problems... einatlev OpenFOAM Running, Solving & CFD 6 March 19, 2015 11:16
interFoam simulation yields inconsistent results for alpha1 surface Ralinus OpenFOAM Running, Solving & CFD 8 January 13, 2014 09:54
Pressure convergence problems with sloped bottom in interFoam gradylemoine OpenFOAM Running, Solving & CFD 0 November 18, 2013 19:33
Problems with interFoam usage vrecha OpenFOAM Running, Solving & CFD 4 January 5, 2008 04:34
Problems starting new case interFoam billy OpenFOAM Running, Solving & CFD 3 June 21, 2006 11:18


All times are GMT -4. The time now is 09:50.