CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > OpenFOAM > OpenFOAM Running, Solving & CFD

Very Low deltaT after just few iterations

Register Blogs Members List Search Today's Posts Mark Forums Read

Like Tree1Likes
  • 1 Post By rapoutin

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   June 19, 2020, 09:41
Default Very Low deltaT after just few iterations
  #1
New Member
 
fpp prr
Join Date: Jun 2020
Posts: 3
Rep Power: 5
filippo222 is on a distinguished road
Hi everybody,
I'm running a simulation with pimpleDyMFoam and turbulence model kEpsilon, after just a few iterations deltaT drops to very low values (order of e-20) and a very high y+ value (order of e18). I cannot understand if the problem are the mesh and BC or the set up of schemes, solution and controlDict. Here attached fvSchemes, fvSolution and controlDict.
Thanks in advance.
Attached Files
File Type: txt controlDict.txt (2.0 KB, 2 views)
File Type: txt fvSchemes.txt (1.5 KB, 1 views)
File Type: txt fvSolution.txt (1.8 KB, 1 views)
filippo222 is offline   Reply With Quote

Old   June 23, 2020, 00:23
Default
  #2
New Member
 
raphael
Join Date: Dec 2015
Posts: 5
Rep Power: 10
rapoutin is on a distinguished road
In your controlDict you have adjustTimeStep yes;
And maxCo 1;
So deltaT will drop until it reaches the constraint maxCo < 1

At the moment you could change adjustTimeStep to no.

We don't have enough info to help you more. You could run some iteration and have a check on paraview to see where the problem is located. You are looking for high-velocity cells.
filippo222 likes this.
rapoutin is offline   Reply With Quote

Old   June 23, 2020, 12:39
Default
  #3
New Member
 
fpp prr
Join Date: Jun 2020
Posts: 3
Rep Power: 5
filippo222 is on a distinguished road
Problem solved, the main issue was inconsistency between mesh and turbulence model adopted, thank you anyway
filippo222 is offline   Reply With Quote

Old   December 28, 2023, 04:09
Unhappy
  #4
New Member
 
Chandra Napitupulu
Join Date: Nov 2023
Posts: 6
Rep Power: 2
chandrana70 is on a distinguished road
Quote:
Originally Posted by filippo222 View Post
Problem solved, the main issue was inconsistency between mesh and turbulence model adopted, thank you anyway

How do you know that the problem was inconsistency between mesh and turbulence? I have same the problem when I use pimpleFoam as solver for simulation of underwater vessel
chandrana70 is offline   Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with chtMultiregionFoam radiation boundary condition baran_foam OpenFOAM Running, Solving & CFD 10 December 17, 2019 17:36
chtMultiRegionSimpleFoam turbulent case Aditya Patil OpenFOAM Running, Solving & CFD 6 April 24, 2017 22:13
Floating point exception error lpz_michele OpenFOAM Running, Solving & CFD 53 October 19, 2015 02:50
Compressor Simulation using rhoPimpleDyMFoam Jetfire OpenFOAM Running, Solving & CFD 107 December 9, 2014 13:38
Upgraded from Karmic Koala 9.10 to Lucid Lynx10.04.3 bookie56 OpenFOAM Installation 8 August 13, 2011 04:03


All times are GMT -4. The time now is 21:01.