CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Visualization & Post-Processing Software > ParaView

[OpenFOAM] Xlib: extension "GLX" missing on display

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   March 19, 2013, 12:40
Default Xlib: extension "GLX" missing on display
  #1
New Member
 
Join Date: Mar 2013
Posts: 13
Rep Power: 13
goldbeard is on a distinguished road
Hello.

When I try to run paraview it only flickers open for a moment and then disappears.
Here is the message I get in the terminal.



Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
ERROR: In /home/opencfd/OpenFOAM/ThirdParty-2.1.x/ParaView-3.12.0/VTK/Rendering/vtkXOpenGLRenderWindow.cxx, line 404
vtkXOpenGLRenderWindow (0x2288500): Could not find a decent visual



Xlib: extension "GLX" missing on display ":0.0".
ERROR: In /home/opencfd/OpenFOAM/ThirdParty-2.1.x/ParaView-3.12.0/VTK/Rendering/vtkXOpenGLRenderWindow.cxx, line 609
vtkXOpenGLRenderWindow (0x2288500): GLX not found. Aborting.


Aborted (core dumped)




Does anyone know what I need to do. I am not a linux expert. I am running Ubuntu 12.04 LTS.

If you need more info please let me know.

Thank you.
goldbeard is offline   Reply With Quote

Old   March 20, 2013, 14:36
Default Fixed it.
  #2
New Member
 
Join Date: Mar 2013
Posts: 13
Rep Power: 13
goldbeard is on a distinguished road
Fixed it. How do I delete this post? I don't want it to waste people time in the future.
goldbeard is offline   Reply With Quote

Old   March 20, 2013, 14:53
Default
  #3
Senior Member
 
Join Date: Dec 2011
Posts: 111
Rep Power: 19
haakon will become famous soon enough
Perhaps you can share the solution with the rest of the forum? In that way, other people with similar problems can find the solution themself, without asking/posting the same question again. That is a much better solution than deleting the post.
haakon is offline   Reply With Quote

Old   March 20, 2013, 16:07
Default
  #4
New Member
 
Join Date: Mar 2013
Posts: 13
Rep Power: 13
goldbeard is on a distinguished road
Of course! My solution was to reformat my hard drive, and reinstall the latest and greatest versions of all software, Ubuntu 12.10 and openFOAM 2.2.0, and then download the current version of Paraview from the software center of Ubuntu.

If that helps people, then let the post stand, if not........
goldbeard is offline   Reply With Quote

Old   March 24, 2013, 00:05
Default
  #5
New Member
 
Join Date: Mar 2013
Posts: 13
Rep Power: 13
goldbeard is on a distinguished road
so how can I delete this worthless thread?
goldbeard is offline   Reply With Quote

Old   March 24, 2013, 13:12
Default
  #6
Retired Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 10,975
Blog Entries: 45
Rep Power: 128
wyldckat is a name known to allwyldckat is a name known to allwyldckat is a name known to allwyldckat is a name known to allwyldckat is a name known to allwyldckat is a name known to all
Greetings goldbeard,

Quote:
Originally Posted by goldbeard View Post
so how can I delete this worthless thread?
I'll answer with another quote:
Quote:
Originally Posted by pete View Post
Users can't delete threads. If you for some reason want to delete a thread please contact an admin directly.
I didn't manage to find the time to answer the original post sooner, but using Google should have helped you find the following blog post of mine: Related issues to ParaView with OpenFOAM - Fixes and solutions

But in essence, the error was probably because the drivers for graphics card were not properly instaled.

Best regards,
Bruno
__________________
wyldckat is offline   Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
[Other] paraFoam error scybchenjun OpenFOAM Meshing & Mesh Conversion 0 May 11, 2016 23:25
errors when installing openfoam2.1 on ubuntu12.o4 hewei OpenFOAM Installation 5 May 29, 2012 07:43
[OpenFOAM] Saving ParaFoam views and case sail ParaView 9 November 25, 2011 15:46
Problem with paraFoam ata OpenFOAM 14 November 30, 2009 04:23
Xlib: extension "GLX" missing on display ":0.0". tipakorn Siemens 1 August 16, 2006 06:07


All times are GMT -4. The time now is 13:42.