CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > REEF3D

After using the B270 function, the force has a null value.

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   January 14, 2022, 03:04
Default After using the B270 function, the force has a null value.
  #1
Super Moderator
 
Arun Kamath
Join Date: Nov 2014
Location: Trondheim, Norway
Posts: 175
Rep Power: 10
kamath is on a distinguished road
@haho hao: I repost your question on a fresh thread to address it properly

Hi Arun
I don't know why my account can't post at present, so I can only ask questions in this way. At present, my problem is that when I use the B270 function, my simulationis calculated in a strange way, and there is an error as shown in the following images, and the calculated force is null. But when I do not use the B270 function, the calculation can be carried out normally, there is no error, and the force is normal. I would like to ask how this problem can be solved. All simulation tests are carried out by REEF3D 21.09.
kamath is offline   Reply With Quote

Old   January 14, 2022, 03:08
Default
  #2
Super Moderator
 
Arun Kamath
Join Date: Nov 2014
Location: Trondheim, Norway
Posts: 175
Rep Power: 10
kamath is on a distinguished road
Hi Hao,

I see that your simulation is crashing. It is possibly crashing at the first time step and therefore you have 0 values for forces throughout.

Are you sure you are using the latest version? In the latest version, the simulation terminates when there is a crash from Hypre to avoid this output (which is just a waste of resources). So, please check that first.

With the information you provide, I don't really follow your simulation/ problem.
What are you trying to simulate?

Do you have a porous object in the domain?

Are you trying to calculate the force on this porous object?

What is your domain size and grid size?
__________________
Arun
Team REEF3D
www.reef3d.com
kamath is offline   Reply With Quote

Old   January 14, 2022, 09:42
Default
  #3
New Member
 
Hao hao
Join Date: Aug 2021
Posts: 9
Rep Power: 2
Hao666 is on a distinguished road
Quote:
Originally Posted by kamath View Post
Hi Hao,

I see that your simulation is crashing. It is possibly crashing at the first time step and therefore you have 0 values for forces throughout.

Are you sure you are using the latest version? In the latest version, the simulation terminates when there is a crash from Hypre to avoid this output (which is just a waste of resources). So, please check that first.

With the information you provide, I don't really follow your simulation/ problem.
What are you trying to simulate?

Do you have a porous object in the domain?

Are you trying to calculate the force on this porous object?

What is your domain size and grid size?
Hi Arun,
Thank you very much for your help. I used both versions 21.09 and 21.11. As you said, in version 21.11, this crashing simulation will be terminated and the force will not be output, but in version 21.09, the calculation continue to be calculated with the error, and the force output will be null.The case I want to do is to simulate the forces of the plate behind the porous object, both of them are in the computation domain. In addition, I use the S10 command to import the solid model. I found that when I do not add porous object (without use B270), the simulation can operate normally. More interestingly, the example can also be run when I don't add the solid file (without use S10 or S1 ). Overall, I cannot use it at the same time, or there will be a crash error. I have attached my case file. Best regards.
Attached Files
File Type: txt control.txt (134 Bytes, 5 views)
File Type: txt ctrl.txt (506 Bytes, 6 views)
Hao666 is offline   Reply With Quote

Old   January 14, 2022, 12:36
Default
  #4
Super Moderator
 
Arun Kamath
Join Date: Nov 2014
Location: Trondheim, Norway
Posts: 175
Rep Power: 10
kamath is on a distinguished road
would it also be possible to share the stl file? So that I can reproduce the error?
Thanks
__________________
Arun
Team REEF3D
www.reef3d.com
kamath is offline   Reply With Quote

Old   January 14, 2022, 21:23
Default
  #5
New Member
 
Hao hao
Join Date: Aug 2021
Posts: 9
Rep Power: 2
Hao666 is on a distinguished road
Quote:
Originally Posted by kamath View Post
would it also be possible to share the stl file? So that I can reproduce the error?
Thanks
I used the S 10 command to generate the STL file.
Hao666 is offline   Reply With Quote

Old   January 17, 2022, 03:35
Default
  #6
Super Moderator
 
Arun Kamath
Join Date: Nov 2014
Location: Trondheim, Norway
Posts: 175
Rep Power: 10
kamath is on a distinguished road
I can reproduce the error. I will get back to you soon.
__________________
Arun
Team REEF3D
www.reef3d.com
kamath is offline   Reply With Quote

Old   January 19, 2022, 11:29
Default
  #7
New Member
 
Hao hao
Join Date: Aug 2021
Posts: 9
Rep Power: 2
Hao666 is on a distinguished road
Quote:
Originally Posted by kamath View Post
I can reproduce the error. I will get back to you soon.
Thank you very much again for your help and I am looking forward to your reply.
Hao666 is offline   Reply With Quote

Old   February 21, 2022, 02:13
Default
  #8
Super Moderator
 
Arun Kamath
Join Date: Nov 2014
Location: Trondheim, Norway
Posts: 175
Rep Power: 10
kamath is on a distinguished road
Hi Hao Hao,
This bug is now fixed in the latest release candidate.
__________________
Arun
Team REEF3D
www.reef3d.com
kamath is offline   Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
[mesh manipulation] RefineMesh Error and Foam warning jiahui_93 OpenFOAM Meshing & Mesh Conversion 4 March 3, 2018 11:32
is internalField(U) equivalent to zeroGradient? immortality OpenFOAM Running, Solving & CFD 7 March 29, 2013 01:27
channelFoam for a 3D pipe AlmostSurelyRob OpenFOAM 3 June 24, 2011 13:06
Version 15 on Mac OS X gschaider OpenFOAM Installation 113 December 2, 2009 10:23
DecomposePar links against liblamso0 with OpenMPI jens_klostermann OpenFOAM Bugs 11 June 28, 2007 17:51


All times are GMT -4. The time now is 03:27.