CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > Siemens > STAR-CCM+

[meshing] Invalid ID inserted into subset

Register Blogs Members List Search Today's Posts Mark Forums Read

Like Tree1Likes
  • 1 Post By ping

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   April 20, 2020, 03:46
Unhappy [meshing] Invalid ID inserted into subset
  #1
raz
Member
 
Join Date: Nov 2015
Posts: 30
Rep Power: 9
raz is on a distinguished road
Hi all,

I am attempting to produce a mesh of a multi-body system. The surface remesh works, following which, the Tet mesher gives the following error:

Inserting invalid id into subset: (invalid)
stack trace:
libMKSurfaceView.so: MKSurfaceView::SurfaceBase::newFace(MKCore::Id, int, MKCore::Id, bool
libMKSurfaceView.so: MKSurfaceView::AddFv<MKSurfaceView::TriangleBase>: :newFace(MKCore::Id, MKCore::ConstFaceVertices const&, int, MKCore::Id, bool
libMKSurfaceView.so(+0x8e6e9
libMKSurfaceView.so: MKSurfaceView::appendSurface(MKSurfaceView::Triang leBase const&, MKSurfaceView::TriangleFv&, MKCore::Subset const&, std::map<int, int, std::less<int>, std::allocator<std:air<int const, int> > > const*
libStarMeshing.so: SurfaceMeshBase::appendMesh(SurfaceMeshBase const&, MKCore::Subset const&, MeshTypeMap const&, MKCore::IdHashMap<MKCore::Id>*, bool, MKCore::IdHashMap<MKCore::Id>*, MKCore::IdHashMap<MKCore::Id>*
libStarMeshing.so: ShellSurfaceMesh::append(ShellSurfaceMesh const&, GeometryPart const&, MeshTypeMap&, Cad::CadSet<Cad::Body> const*, MKCore::IdHashMap<MKCore::Id>*, MKCore::IdHashMap<MKCore::Id>*, bool
libStarMeshing.so: ShellSurfaceMesh::append(ShellSurfaceMesh const&, GeometryPart const&, MeshTypeMap&, Cad::CadSet<Cad::Body> const*, MKCore::IdHashMap<MKCore::Id>*, bool
libStarMeshing.so: ShellSurfaceMesh::append(ShellSurfaceMesh const&, GeometryPart const&, bool
libStarSolidMesher.so: ThinAutoMesher::storeThinFacetypes(ShellSurfaceMes h const&
libStarSolidMesher.so(_ZN14ThinAutoMesher4initEPSt 6vectorIP8MeshPartSaIS2_EEPKSt3setIjSt4lessIjESaIj EERN9Dt3Mesher10Dt3Options
libStarDelaunayMesher.so(_ZN18DelaunayAutoMesher15 executeInternalERSt6vectorIP8MeshPartSaIS2_EERK16S hellSurfaceMeshRN6MKCore13
libStarDelaunayMesher.so(_ZN18DelaunayAutoMesher7e xecuteERSt6vectorIP8MeshPartSaIS2_EERK16ShellSurfa ceMeshRN6MKCore13Interface
libStarDualMesher.so(_ZN14DualAutoMesher7executeER St6vectorIP8MeshPartSaIS2_EERK16ShellSurfaceMeshRN 6MKCore13InterfaceMapsERKS
libStarDualMesher.so(_ZN14DualAutoMesher27meshPart ConformallySpecificERSt6vectorIP8MeshPartSaIS2_EER K16ShellSurfaceMeshRN6MKCo
libMeshingPipeline.so: VolumeAutoMesher::meshPartConformally(std::vector< MeshPart*, std::allocator<MeshPart*> >&, ShellSurfaceMesh&, ShellSurfaceMesh*&, PatchTypeMapper&
libMeshingPipeline.so: AutoMeshPipeline::meshPartsConformally(std::vector <MeshPart*, std::allocator<MeshPart*> >&, std::vector<MesherBase*, std::allocator<MesherBase*> > const&
libMeshingPipeline.so: AutoMeshOperation::executeSpecific(
libMeshingPipeline.so: MeshOperation::execute(
libMeshingPipeline.so(+0x2825db
libStarNeo.so: Controller::executeCommand(Command&, Properties const&, Properties&
libStarNeo.so: Controller:rocessCommands(
libStarMachine.so: CommandController::SerialMasterCommandLoop::start(
libStarMachine.so: CommandController:rocessCommands(
libStarMachine.so: Machine::startServerHost(int, char**, std::map<std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> >, unsigned int, std::less<std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > >, std::allocator<std:air<std::__cxx11::basic_strin g<char, std::char_traits<char>, std::allocator<char> > const, unsigned int> > >&
libStarMachine.so: Machine::main(int, char**
Invalid id inserted into Subset!
Command: ExecuteMeshOperation
error: Server Error
Loading/configuring connectivity (old|new partitions: 1|1)
Configuring finished


Nobody in my immediate group of colleagues has seen this error before. Anyone who could suggest why this may occur?

No pierced faces, suspicious proximity, free or manifold edges are present in my split geometry (either root or remeshed)

Here's my approach: Import CAD -> Combine all parts -> Imprint all necessary faces & other surface repair -> Split by topology -> Create regions (individual fluid regions & multi-component solid regions) -> Mesh
raz is offline   Reply With Quote

Old   April 21, 2020, 03:39
Default
  #2
Senior Member
 
Ping
Join Date: Mar 2009
Posts: 556
Rep Power: 18
ping is on a distinguished road
disable the mesh model in all but one part/region and see if it works then do the same for each part to try to find the problem
raz likes this.
ping is offline   Reply With Quote

Reply

Tags
errors, mesh, meshing, surface repair

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
[snappyHexMesh] Invalid Normals for source face to target face while making AMI? Sorabh OpenFOAM Meshing & Mesh Conversion 1 August 3, 2021 07:35
[meshing] Invalid ID insterted into subset raz STAR-CCM+ 0 April 20, 2020 03:45
parallel simulations - error message: "OPT_ITERATIONS: invalid option name" v8areu SU2 5 July 23, 2015 03:57
OpenFOAM install on Ubuntu Natty 11.04 bkubicek OpenFOAM 13 May 26, 2011 06:48
Phase locked average in run time panara OpenFOAM 2 February 20, 2008 15:37


All times are GMT -4. The time now is 20:21.