CFD Online Logo CFD Online URL
Home > Forums > ANSYS Meshing & Geometry

[ICEM] "run out of memory"

Register Blogs Members List Search Today's Posts Mark Forums Read

LinkBack Thread Tools Display Modes
Old   July 7, 2009, 08:41
Default "run out of memory"
New Member
Join Date: Jul 2009
Posts: 13
Rep Power: 10
moca is on a distinguished road
Hi every body,
I try to meshing "wind turbine" using ICEM CFD. But when I doing meshing process I get message " run out memory.........". My computer have 3 GB memory RAM. I try to make "max size" from "part mesh set up" more bigger but i get it message again. What happen friend??? Any suggestion about this?? I use volume meshing, tetrahedron. Thank you
moca is offline   Reply With Quote

Old   July 8, 2009, 06:23
Default 32 Bit?
Retired from CFD Online
PSYMN's Avatar
Simon Pereira
Join Date: Mar 2009
Location: Ann Arbor, MI
Posts: 2,665
Blog Entries: 1
Rep Power: 39
PSYMN has a spectacular aura aboutPSYMN has a spectacular aura about
If you are on a 32 bit machine, you are limited to 2Gig per process regardless of how many Gig memory you have. For ICEM CFD Octree Tetra, that tops you out at about 12 million tetras. (Due to memory improvements, this goes up to 16 or 18 million for the 12.1 release).

Check you mesh sizes, particularly your minimum sizes to see if you have meshed the model too finely...

Perhaps just ratchet up your Global Element Scale Factor (the first option under the Mesh Tab => Global Mesh Size) to a larger number than 1. This scales up all the sizes in your model. If you set this to 5 and get a model of 10 million cells, then you know you would have got a much much larger mesh with this set to 1...

If you need to mesh larger models (12 million to over a billion tetras) you will need a 64 bit machine.
PSYMN is offline   Reply With Quote

Old   July 8, 2009, 09:50
New Member
Join Date: Jul 2009
Posts: 13
Rep Power: 10
moca is on a distinguished road
Thank you Mr. Simon Pereira,
I need your information again. Why when I change scale factor and max element more bigger i always get information at operation progress that when operation progress 28% always there is 1.000.000 tetrahedron. I my mind when I change "scale factor" or "max element" more bigger , when operation progress 28% it should be less than 1.000.000 element. Yes I use 32 bit machine. For information, finally I use "scale factor = 25" in global mesh set up. In part mesh set up i use "max size = 10", "height = 1.2, "height ratio = 1,1, "tetra size ratio = 1.3. Until now when i meshing my model I always get information "run out of memory......". Any suggestion, so I can meshing my model with my computer (memory RAM = 1 GB) . Thank you every body
moca is offline   Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 12:52.