CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > ANSYS > CFX

Error reported by IO module

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   February 23, 2016, 08:53
Default Error reported by IO module
  #1
New Member
 
Hossein
Join Date: May 2015
Posts: 11
Rep Power: 9
hhm747 is on a distinguished road
Hello everybody,

I tried to launch an unsteady simulation with initial value on a cluster by cfx161.
but it didn't run and crushed with the following error massage:

Do you know why it says: "file is corrupt"

Thanks
hhm747

An error has occurred in cfx5solve:

Error reported by IO module: recreate_indextable: warning: truncated (or
bad) index data at end of file while rebuilding index, file is corrupt but
probably recoverable, continuing. [1172197824 + 45386 > 1172242432]

An error has occurred in cfx5solve:

Error reported by : write_index: fwrite failed writing format: Bad
file descriptor

An error has occurred in cfx5solve:

Error reported by IO module: iif_flush: write_index failed

An error has occurred in cfx5solve:

Error reported by IO module: cfxwriteString: (fputs failed) syserr:: Bad
file descriptor
hhm747 is offline   Reply With Quote

Old   July 14, 2016, 11:17
Default
  #2
Senior Member
 
Maxim
Join Date: Aug 2015
Location: Germany
Posts: 414
Rep Power: 11
-Maxim- is on a distinguished road
I just ran into the same problem and it's driving me crazy. I only have 3 out of your 4 errors:
Quote:
An error has occurred in cfx5solve:

Error reported by : write_index: fwrite failed writing format: Bad
file descriptor

An error has occurred in cfx5solve:

Error reported by IO module: iif_flush: write_index failed

An error has occurred in cfx5solve:

Error reported by IO module: cfxwriteString: (fputs failed) syserr:: Bad
file descriptor
I use 17.1 and want to solve local parallel on 8 cores.
-Maxim- is offline   Reply With Quote

Old   July 18, 2016, 06:55
Default
  #3
Senior Member
 
Maxim
Join Date: Aug 2015
Location: Germany
Posts: 414
Rep Power: 11
-Maxim- is on a distinguished road
I reinstalled CFX 17.1, started the job via command line with a different initial condition file and now the error is gone.
My guess is that it was caused by my *.res file that I wanted to use as initial condition.
Will report back if something changes.
-Maxim- is offline   Reply With Quote

Old   December 28, 2018, 10:10
Default
  #4
New Member
 
jiaji lu
Join Date: Mar 2018
Posts: 5
Rep Power: 6
jiaji lu is on a distinguished road
Quote:
Originally Posted by -Maxim- View Post
I reinstalled CFX 17.1, started the job via command line with a different initial condition file and now the error is gone.
My guess is that it was caused by my *.res file that I wanted to use as initial condition.
Will report back if something changes.
Have you solved the probelm? What's th reason?
jiaji lu is offline   Reply With Quote

Old   January 2, 2019, 02:36
Default
  #5
Senior Member
 
Maxim
Join Date: Aug 2015
Location: Germany
Posts: 414
Rep Power: 11
-Maxim- is on a distinguished road
Quote:
Originally Posted by jiaji lu View Post
Have you solved the probelm? What's th reason?
Hi,

I don't recall that problem since it occurred to me a few years ago. As I stated in my answer, it might have been caused by a corrupt *.res file.
-Maxim- is offline   Reply With Quote

Reply

Tags
cfx 16.2, hpc cluster, unsteady

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Conduction and Convection Thermal Analysis of a PV Module firestone9x ANSYS 0 February 19, 2016 08:26
[OpenFOAM] Annoying issue of automatic "Rescale to Data Range " with paraFoam/paraview 3.12 keepfit ParaView 60 September 18, 2013 03:23
PEM electrolyzer module A CFD free user FLUENT 0 February 27, 2013 12:51
Can someone PLEASE document the development version installation bernd OpenFOAM Installation 76 November 14, 2008 21:51
Lamboot trouble r2d2 OpenFOAM Installation 4 October 17, 2005 04:27


All times are GMT -4. The time now is 05:16.