CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Installation

Reinstalled OpenFOAM getting wmake error

Register Blogs Members List Search Today's Posts Mark Forums Read

Like Tree5Likes

Reply
 
LinkBack Thread Tools Display Modes
Old   March 3, 2014, 08:07
Default Reinstalled OpenFOAM getting wmake error
  #1
Senior Member
 
Join Date: Jan 2012
Posts: 159
Rep Power: 6
maybee is on a distinguished road
hi,

I just reinstalled OpenFOAM and getting now the error

Quote:
/usr/bin/ld: cannot find -lcompressibleMultiPhaseModel
collect2: ld returns 1
make: *** [/opt/openfoam230/platforms/linuxGccDPOpt/bin/multiphaseEulerFoam] Error 1
when running wmake in my project directory.

How can I fix this?

Edit: I also can t find any directory or file "compressibleMultiPhaseModel" in /opt/openfoam230
maybee is offline   Reply With Quote

Old   March 3, 2014, 08:16
Default
  #2
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 9,748
Blog Entries: 39
Rep Power: 103
wyldckat is a glorious beacon of lightwyldckat is a glorious beacon of lightwyldckat is a glorious beacon of lightwyldckat is a glorious beacon of lightwyldckat is a glorious beacon of light
Quick answer:
  1. http://openfoamwiki.net/index.php/Ho...ompile_icoFoam
  2. File "Make/files":
    Code:
    my_icoFoam.C
    
    EXE = $(FOAM_USER_APPBIN)/my_icoFoam
    ---> FOAM_USER_APPBIN <---
wyldckat is offline   Reply With Quote

Old   March 3, 2014, 08:58
Default
  #3
Senior Member
 
Join Date: Jan 2012
Posts: 159
Rep Power: 6
maybee is on a distinguished road
Ok,

now I made the problem even worse . I deleted the OpenFOAM and Paraview folder and tried to reinstall again like described here

http://www.openfoam.org/download/ubuntu.php

Problem is I can t reinstall since I get the output

Quote:
openfoam230 is the newest version.
0 updated, 0 new installed, 0 removed and 32 not updated.
It seems the shell gets the misinformation OpenFOAM is installed. What should I do?
maybee is offline   Reply With Quote

Old   March 3, 2014, 09:14
Default
  #4
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 9,748
Blog Entries: 39
Rep Power: 103
wyldckat is a glorious beacon of lightwyldckat is a glorious beacon of lightwyldckat is a glorious beacon of lightwyldckat is a glorious beacon of lightwyldckat is a glorious beacon of light
Instead of "install", use "remove".
Example:
Code:
sudo apt-get remove openfoam230
maybee likes this.
wyldckat is offline   Reply With Quote

Old   March 3, 2014, 09:15
Default
  #5
Senior Member
 
Alexey Matveichev
Join Date: Aug 2011
Location: Nancy, France
Posts: 1,437
Rep Power: 25
alexeym will become famous soon enoughalexeym will become famous soon enough
Hi,

it seems that you've installed OF using package manager (apt-get) but deleted the folders by hand (using rm -rf) while you had to use package manager.

AFAIR there is --reinstall option for 'apt-get install' command (though you'd better read man page for apt-get) which will instruct apt-get to ignore installed packages. So the commands should be like these:

Code:
sudo apt-get install --reinstall openfoam230 
sudo apt-get install --reinstall paraviewopenfoam410
wyldckat and maybee like this.
alexeym is offline   Reply With Quote

Old   March 4, 2014, 12:13
Default
  #6
Senior Member
 
Join Date: Jan 2012
Posts: 159
Rep Power: 6
maybee is on a distinguished road
Hi again,

I have now reinstalled OpenFOAM, to be precise I have installed the source package like descibed here

http://www.openfoam.org/download/source.php

in the hope using Eclipse will be possible afterwards.

Two questions:

1. When finishing the chapter "System Requirements" of the above link I get the last line in Terminal

Quote:
ldconfig deferred processing now taking place
When trying to close the terminal I get the message

Quote:
There is still process running. Kill it?
Can I close the terminal and kill the process?

2. When I try to run wmake in my project folder I get the compiler output

Quote:
/bin/sh: 1: /home/USER/OpenFOAM/OpenFOAM-2.3.0/wmake/platforms/linuxGcc/wmkdep: not found
g++ -m32 -Dlinux -DWM_DP -Wall -Wextra -Wno-unused-parameter -Wold-style-cast -O3 -DNoRepository -ftemplate-depth-100 -IphaseModel/lnInclude -ImultiphaseSystem/lnInclude -ImultiphaseFixedFluxPressure -IinterfacialModels/lnInclude -I/home/engineer/OpenFOAM/OpenFOAM-2.3.0/src/transportModels -I/home/engineer/OpenFOAM/OpenFOAM-2.3.0/src/transportModels/incompressible/lnInclude -I/home/engineer/OpenFOAM/OpenFOAM-2.3.0/src/transportModels/interfaceProperties/lnInclude -I/home/engineer/OpenFOAM/OpenFOAM-2.3.0/src/transportModels/incompressible/lnInclude -I/home/engineer/OpenFOAM/OpenFOAM-2.3.0/src/transportModels/incompressible/singlePhaseTransportModel -I/home/engineer/OpenFOAM/OpenFOAM-2.3.0/src/turbulenceModels -I/home/engineer/OpenFOAM/OpenFOAM-2.3.0/src/turbulenceModels/incompressible/LES/LESModel -I/home/engineer/OpenFOAM/OpenFOAM-2.3.0/src/turbulenceModels/LES/LESdeltas/lnInclude -I/home/engineer/OpenFOAM/OpenFOAM-2.3.0/src/finiteVolume/lnInclude -IlnInclude -I. -I/home/engineer/OpenFOAM/OpenFOAM-2.3.0/src/OpenFOAM/lnInclude -I/home/engineer/OpenFOAM/OpenFOAM-2.3.0/src/OSspecific/POSIX/lnInclude -fPIC -Xlinker --add-needed -Xlinker --no-as-needed Make/linuxGccDPOpt/multiphaseEulerFoam.o -L/home/engineer/OpenFOAM/OpenFOAM-2.3.0/platforms/linuxGccDPOpt/lib \
-lmultiphaseSystem -lcompressibleMultiPhaseModel -linterfaceProperties -lincompressibleTransportModels -lcompressibleMultiphaseEulerianInterfacialModels -lincompressibleLESModels -lincompressibleRASModels -lfiniteVolume -lOpenFOAM -ldl -lm -o /home/engineer/OpenFOAM/OpenFOAM-2.3.0/platforms/linuxGccDPOpt/bin/multiphaseEulerFoam
/usr/bin/ld: cannot find -lmultiphaseSystem
/usr/bin/ld: cannot find -lcompressibleMultiPhaseModel
/usr/bin/ld: cannot find -linterfaceProperties
/usr/bin/ld: cannot find -lincompressibleTransportModels
/usr/bin/ld: cannot find -lcompressibleMultiphaseEulerianInterfacialModels
/usr/bin/ld: cannot find -lincompressibleLESModels
/usr/bin/ld: cannot find -lincompressibleRASModels
/usr/bin/ld: cannot find -lfiniteVolume
/usr/bin/ld: cannot find -lOpenFOAM
collect2: ld returned 1 exit status
make: *** [/home/USER/OpenFOAM/OpenFOAM-2.3.0/platforms/linuxGccDPOpt/bin/multiphaseEulerFoam] Error 1
How can I solve this problem?

greetings
maybee
maybee is offline   Reply With Quote

Old   March 4, 2014, 12:21
Default
  #7
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 9,748
Blog Entries: 39
Rep Power: 103
wyldckat is a glorious beacon of lightwyldckat is a glorious beacon of lightwyldckat is a glorious beacon of lightwyldckat is a glorious beacon of lightwyldckat is a glorious beacon of light
OK... hopefully your next step won't be "going into a spacecraft and then going to the moon" ... because with every solution we give you, you keep going into another wall

I don't know which Ubuntu version you're using, but these instructions are more complete than the official ones: http://openfoamwiki.net/index.php/In...M-2.3.0/Ubuntu
wyldckat is offline   Reply With Quote

Old   March 4, 2014, 12:39
Default
  #8
Senior Member
 
Alexey Matveichev
Join Date: Aug 2011
Location: Nancy, France
Posts: 1,437
Rep Power: 25
alexeym will become famous soon enoughalexeym will become famous soon enough
Maybe you can post the following information:

1. Output of id command
2. Output of 'export | grep LD_LIBRARY_' command
3. Output of 'cat $HOME/.bash_profile' (or is it $HOME/.profile on Ubuntu?)

And finally are you sure that you've built OpenFOAM?

Last edited by alexeym; March 4, 2014 at 12:40. Reason: typo
alexeym is offline   Reply With Quote

Old   March 4, 2014, 12:52
Default
  #9
Senior Member
 
Join Date: Jan 2012
Posts: 159
Rep Power: 6
maybee is on a distinguished road
Ok great , now I am back to post number 3:

Quote:
Ok,

now I made the problem even worse . I deleted the OpenFOAM and Paraview folder and tried to reinstall again like described here

http://www.openfoam.org/download/ubuntu.php

Problem is I can t reinstall since I get the output

Quote:
openfoam230 is the newest version.
0 updated, 0 new installed, 0 removed and 32 not updated.
It seems the shell gets the misinformation OpenFOAM is installed. What should I do?
I deleted the previous installed folders manually and wanted to use the installation manual

http://openfoamwiki.net/index.php/In...M-2.3.0/Ubuntu

but now I get the output of post 3 again and your solutions posted in post 4 and 5 do not work -> I only get:

Quote:
sudo apt-get remove openfoam230
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package openfoam230
and

Quote:
sudo apt-get install --reinstall openfoam230
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package openfoam230
What should I do now?
maybee is offline   Reply With Quote

Old   March 4, 2014, 12:59
Default
  #10
Senior Member
 
Alexey Matveichev
Join Date: Aug 2011
Location: Nancy, France
Posts: 1,437
Rep Power: 25
alexeym will become famous soon enoughalexeym will become famous soon enough
If you'd like to install from sources, you can forget about maybe installed or maybe not installed binary version of OpenFOAM and go straight to:

Code:
sudo apt-get install build-essential cmake flex bison zlib1g-dev qt4-dev-tools libqt4-dev gnuplot libreadline-dev libncurses-dev libxt-dev libopenmpi-dev openmpi-bin libboost-system-dev libboost-thread-dev libgmp-dev libmpfr-dev
and so on, see the guide.
alexeym is offline   Reply With Quote

Old   March 4, 2014, 13:03
Default
  #11
Senior Member
 
Join Date: Jan 2012
Posts: 159
Rep Power: 6
maybee is on a distinguished road
Hi,

problem is my folders are gone (I deleted them) and when using

Quote:
sudo apt-get install build-essential cmake flex bison zlib1g-dev qt4-dev-tools libqt4-dev gnuplot libreadline-dev libncurses-dev libxt-dev libopenmpi-dev openmpi-bin libboost-system-dev libboost-thread-dev libgmp-dev libmpfr-dev
no new folders are installed. i only get

Quote:
sudo apt-get install build-essential cmake flex bison zlib1g-dev qt4-dev-tools libqt4-dev gnuplot libreadline-dev libncurses-dev libxt-dev libopenmpi-dev openmpi-bin libboost-system-dev libboost-thread-dev libgmp-dev libmpfr-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
Note, selecting 'libncurses5-dev' instead of 'libncurses-dev'
bison is already the newest version.
flex is already the newest version.
libgmp-dev is already the newest version.
libmpfr-dev is already the newest version.
libncurses5-dev is already the newest version.
libreadline-dev is already the newest version.
zlib1g-dev is already the newest version.
gnuplot is already the newest version.
and therefore I can t use any OpenFOAM commands. Furthermore installing OpenFOAM seems not possible... ?
maybee is offline   Reply With Quote

Old   March 4, 2014, 13:16
Default
  #12
Senior Member
 
Alexey Matveichev
Join Date: Aug 2011
Location: Nancy, France
Posts: 1,437
Rep Power: 25
alexeym will become famous soon enoughalexeym will become famous soon enough
The output just tells you that all necessary development packages are installed, so you can proceed to downloading OpenFOAM & ThirdParty source packs, unpacking them, etc, etc.

I can't understand what you are trying to get.

- You've uninstalled binary DEB packages, you'd like to install OF from sources? Follow the instructions wyldckat suggested you.

OR

- You'd like to install binary DEB packages, follow the instructions http://openfoam.org/download/ubuntu.php.

If we return to your initial post, in 2.3.0 there's really no -lcompressibleMultiPhaseModel, I guess now it is called -lcompressibleTwoPhaseSystem. If your solver is tightly based upon 2.2.x version of OF I'd suggest you to stick with 2.2.x cause in 2.3.0 there are backward incompatible changes (at least I needed to correct my viscosity model sources).
maybee likes this.
alexeym is offline   Reply With Quote

Old   March 4, 2014, 13:53
Default
  #13
Senior Member
 
Join Date: Jan 2012
Posts: 159
Rep Power: 6
maybee is on a distinguished road
Quote:
If we return to your initial post, in 2.3.0 there's really no -lcompressibleMultiPhaseModel, I guess now it is called -lcompressibleTwoPhaseSystem. If your solver is tightly based upon 2.2.x version of OF I'd suggest you to stick with 2.2.x cause in 2.3.0 there are backward incompatible changes (at least I needed to correct my viscosity model sources).
Ok,

the last version I used was 2.2.3, but within the old Version link

http://www.openfoam.org/download/archive.php

I only found 2.2.2, therefore tried to install it like described here

http://www.openfoam.org/archive/2.2....oad/source.php

I ve also copied the tutorials into "home/OpenFOAM Tutorials/run", but when trying to run with

Quote:
cd $FOAM_RUN/tutorials/incompressible/icoFoam/cavity
I get

Quote:
bash: cd: /tutorials/incompressible/icoFoam/cavity: No such file or directory
When I try to run wmake on my project I get:

Quote:
No command 'wmake' found, did you mean:
Command 'tmake' from package 'tmake' (universe)
Command 'wmaker' from package 'wmaker-common' (universe)
Command 'jmake' from package 'dist' (universe)
Command 'hmake' from package 'hmake' (universe)
Command 'imake' from package 'xutils-dev' (main)
Command 'mmake' from package 'mmake' (universe)
Command 'omake' from package 'omake' (universe)
Command 'make' from package 'make' (main)
Command 'dmake' from package 'dmake' (main)
Command 'vmake' from package 'hdf4-tools' (universe)
Command 'cmake' from package 'cmake' (main)
Command 'pmake' from package 'pmake' (main)
Command 'qmake' from package 'qt4-qmake' (main)
Command 'qmake' from package 'qt3-dev-tools' (main)
wmake: command not found
EDIT:

1.Ok I got it - I missed the part in chapter "Building the Sources" since I did not understand what directory "$WM_PROJECT_DIR" should be. It is just running now, afterwards I will try to build my project.

2.I guess the last version I used was 2.2.1 then if I can trust the release history .
maybee is offline   Reply With Quote

Old   March 4, 2014, 16:46
Default
  #14
Senior Member
 
Alexey Matveichev
Join Date: Aug 2011
Location: Nancy, France
Posts: 1,437
Rep Power: 25
alexeym will become famous soon enoughalexeym will become famous soon enough
Quote:
Originally Posted by maybee View Post
2.I guess the last version I used was 2.2.1 then if I can trust the release history .
I guess so, as the last release of 2.2.x series was 2.2.2.
alexeym is offline   Reply With Quote

Old   March 5, 2014, 03:26
Default
  #15
Senior Member
 
Join Date: Jan 2012
Posts: 159
Rep Power: 6
maybee is on a distinguished road
Hi,

when I type in "wmake" in my project folder I get now
Quote:
make: `/home/USER/OpenFOAM/OpenFOAM-2.2.2/platforms/linuxGccDPOpt/bin/multiphaseEulerFoam' is up to date.
What should I do?
maybee is offline   Reply With Quote

Old   March 5, 2014, 03:33
Default
  #16
Senior Member
 
Alexey Matveichev
Join Date: Aug 2011
Location: Nancy, France
Posts: 1,437
Rep Power: 25
alexeym will become famous soon enoughalexeym will become famous soon enough
It depends. What you trying to do?

The output of wmake command tells you that multiphaseEulerFoam is built and you can use it.

If your solver is a modified version of multiphaseEulerFoam maybe you should consider renaming it (into something like myNewCoolMultiphaseEulerFoam) and using $FOAM_USER_APPBIN instead of $FOAM_APPBIN in Make/files.
alexeym is offline   Reply With Quote

Old   March 5, 2014, 06:23
Default
  #17
Senior Member
 
Join Date: Jan 2012
Posts: 159
Rep Power: 6
maybee is on a distinguished road
Quote:
The output of wmake command tells you that multiphaseEulerFoam is built and you can use it.
Ok, but when running wmake on my solver I should get at least some warnings and as far as I remember also one error. When I had run wmake with the former installed version of OpenFOAM (DebPack) I got these outputs. So you are thinking now that I have to change the name of the solver.c file?

Quote:
If your solver is a modified version of multiphaseEulerFoam maybe you should consider renaming it (into something like myNewCoolMultiphaseEulerFoam) and using $FOAM_USER_APPBIN instead of $FOAM_APPBIN in Make/files.
Can you please tell me what you mean by this? I know just the basic of makefiles: Generally they consist of constructions how a program has to be run, right?

If I open myproject/make/.file there is


Quote:
EXE = $(FOAM_APPBIN)/multiphaseEulerFoam
So you advice me to change this into

Quote:
EXE = $FOAM_USER_APPBIN/NewSolverName
Surely I ll also change the Solver-Name to NewSolverName.C . Can you please also tell what the consequences of this will be ?

EDIT:

I did as you proposed,but now I get the following output:

Quote:
wmake
mkdir: cannot create directory `': No such file or directory
make: *** [/multiphaseEulerFoamNEW] Error 1
?
maybee is offline   Reply With Quote

Old   March 5, 2014, 06:40
Default
  #18
Senior Member
 
Alexey Matveichev
Join Date: Aug 2011
Location: Nancy, France
Posts: 1,437
Rep Power: 25
alexeym will become famous soon enoughalexeym will become famous soon enough
If I'm not mistaken (though maybe the exact mechanism is more complicated), wmake checks modification time of the files it needs to compile, check modification time of Make/files and Make/options and if these time is older than the modification time of executable it should build, it just says that solver is up to date. As you've just recompiled OpenFOAM, modification time of the multiphaseEulerFoam is more recent than modification times of your files.

Also if you have

Code:
EXE = $(FOAM_APPBIN)/multiphaseEulerFoam
in YOUR project Make/files, it means that every time you build your solver, you overwrite original solver (if you had system-wide read-only OF installation, you'd find out rather quickly that using $FOAM_APPBIN in your personal Make/files is not a good idea ).

So, yes, I suggest you change that line to (the name of the new solver is up to you, this is just an example)
Code:
EXE = $FOAM_USER_APPBIN/modMultiphaseEulerFoam
and your solver will be installed in your personal folder. Here's the difference:

Code:
myself at daphne in ~$ echo $FOAM_APPBIN 
/home/myself/OpenFOAM/OpenFOAM-2.2.2/platforms/linux64GccDPOpt/bin
myself at daphne in ~$ echo $FOAM_USER_APPBIN 
/home/myself/OpenFOAM/myself-2.2.2/platforms/linux64GccDPOpt/bin
You can keep the name of the .C file, you just need to change executable file name of the solver to distinguish it from the one from standard OF distribution.
alexeym is offline   Reply With Quote

Old   March 5, 2014, 06:52
Default
  #19
Senior Member
 
Join Date: Jan 2012
Posts: 159
Rep Power: 6
maybee is on a distinguished road
hi,

I have done this

Quote:
EXE = $FOAM_USER_APPBIN/modMultiphaseEulerFoam
in /make/.file , but when running wmake I still get

Quote:
wmake
mkdir: cannot create directory `': No such file or directory
make: *** [/multiphaseEulerFoam] Error 1
What to do now?
maybee is offline   Reply With Quote

Old   March 5, 2014, 06:55
Default
  #20
Senior Member
 
Alexey Matveichev
Join Date: Aug 2011
Location: Nancy, France
Posts: 1,437
Rep Power: 25
alexeym will become famous soon enoughalexeym will become famous soon enough
EXE = $(FOAM_USER_APPBIN)/multiphaseEulerFoamNEW

Sorry, forgot about braces.
alexeym is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ansys Fluent 13.0 UDF compilation problem in Window XP (32 bit) Yogini Fluent UDF and Scheme Programming 7 October 3, 2012 07:24
groovyBC sega OpenFOAM Running, Solving & CFD 12 February 17, 2010 10:30
Version 15 on Mac OS X gschaider OpenFOAM Installation 120 December 2, 2009 11:23
Problem with compile the setParabolicInlet ivanyao OpenFOAM Running, Solving & CFD 6 September 5, 2008 20:50
ParaFoam error message joey OpenFOAM Paraview & paraFoam 1 October 2, 2006 13:28


All times are GMT -4. The time now is 08:19.