CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > OpenFOAM > OpenFOAM Installation

[OpenFOAM.org] Installing OpenFOAM 2.3.1 on Mint 17 - ThirdParty stuff not seeming to compile

Register Blogs Members List Search Today's Posts Mark Forums Read

Like Tree1Likes
  • 1 Post By MikeHersee

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   December 31, 2014, 13:23
Default Installing OpenFOAM 2.3.1 on Mint 17 - ThirdParty stuff not seeming to compile
  #1
New Member
 
Mike Hersee
Join Date: Nov 2014
Posts: 23
Rep Power: 11
MikeHersee is on a distinguished road
Having got over the problems of Paraview not compiling, the other third party resources does not appear to have completed properly:

In file included from /home/mikehersee/OpenFOAM/ThirdParty-2.3.1/build/linux64Gcc/CGAL-4.3/src/CGAL_Qt4/all_files.cpp:1:0:
/home/mikehersee/OpenFOAM/ThirdParty-2.3.1/CGAL-4.3/src/CGAL_Qt4/DemosMainWindow.cpp:33:21: fatal error: QGLWidget: No such file or directory
#include <QGLWidget>

Any suggestions gratefully appreciated.

Mike Hersee
Attached Files
File Type: gz make.log.tar.gz (12.8 KB, 2 views)
MikeHersee is offline   Reply With Quote

Old   December 31, 2014, 14:04
Default
  #2
Retired Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 10,975
Blog Entries: 45
Rep Power: 128
wyldckat is a name known to allwyldckat is a name known to allwyldckat is a name known to allwyldckat is a name known to allwyldckat is a name known to allwyldckat is a name known to all
Hi Mike,

Fortunately I managed to reproduce the exact same problem

The missing package that needs to be installed is "libqt4-opengl-dev":
Code:
sudo apt-get install libqt4-opengl-dev
I've also updated the instructions here: http://openfoamwiki.net/index.php/In...M-2.3.1/Ubuntu

For other forum readers, this issue occurred after fixing the other aforementioned problem, as indicated here: http://www.cfd-online.com/Forums/ope...tml#post525561 post #49

Best regards,
Bruno
__________________
wyldckat is offline   Reply With Quote

Old   January 4, 2015, 05:32
Default
  #3
New Member
 
Mike Hersee
Join Date: Nov 2014
Posts: 23
Rep Power: 11
MikeHersee is on a distinguished road
That seems to have done it. Thank you Bruno, would never have known how to resolve this on my own. All the make files now seem to indicate successful installation. Am now having a completely different issue trying to get icoFoam to run while Paraview is displayed while doing the first tutorial, but that's a whole other issue...
wyldckat likes this.
MikeHersee is offline   Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Frequently Asked Questions about Installing OpenFOAM wyldckat OpenFOAM Installation 3 November 14, 2023 11:58
[OpenFOAM.org] Installing OpenFoam 3.0.1 on cluster hello177 OpenFOAM Installation 1 April 24, 2016 08:35
[OpenFOAM.org] A Mac OS X of23x Development Environment Using Docker rt08 OpenFOAM Installation 1 February 28, 2016 19:00
[foam-extend.org] problem when installing foam-extend-1.6 Thomas pan OpenFOAM Installation 7 September 9, 2015 21:53
OpenFOAM Foundation releases OpenFOAMŪ 2.3.1 CFDFoundation OpenFOAM Announcements from OpenFOAM Foundation 4 February 8, 2015 05:19


All times are GMT -4. The time now is 03:23.