CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Installation

Can't seem to compile ParaView 4.1.0 (OpenFOAM 2.4.x, CentOS 7)

Register Blogs Members List Search Today's Posts Mark Forums Read

Like Tree2Likes
  • 1 Post By wyldckat
  • 1 Post By me3840

Reply
 
LinkBack Thread Tools Display Modes
Old   October 7, 2015, 23:17
Default Can't seem to compile ParaView 4.1.0 (OpenFOAM 2.4.x, CentOS 7)
  #1
Senior Member
 
Join Date: Nov 2010
Posts: 682
Rep Power: 12
me3840 is on a distinguished road
Hello folks,

Have a CentOS 7 installation here. I've followed the wiki to get down to the final step of running Allwmake on the ParaView OpenFOAM reader, but it seem to generate this error:

ERROR: ParaView not found in /home/michael/OpenFOAM/ThirdParty-2.4.x/platforms/linux64Gcc/ParaView-4.1.0

That directory does indeed, not exist; the 'platforms' directory doesn't show up. Attached is the logfile from the ParaView compile.

Can somebody help me figure out what's going on?

This seems to be a similar problem, but the solution posted there did not work for me:
http://www.cfd-online.com/Forums/ope...correctly.html
Attached Files
File Type: gz log.makePV.gz (10.3 KB, 7 views)
me3840 is offline   Reply With Quote

Old   October 8, 2015, 18:18
Default
  #2
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 9,748
Blog Entries: 39
Rep Power: 103
wyldckat is a glorious beacon of lightwyldckat is a glorious beacon of lightwyldckat is a glorious beacon of lightwyldckat is a glorious beacon of lightwyldckat is a glorious beacon of light
I'll have to be quick:

1. For future reference, I believe you're referring to these instructions: http://openfoamwiki.net/index.php/In...HEL#CentOS_7.1

2. The error message that the log file provides is this one:
Code:
CMake Error at VTK/CMake/FindPythonLibs.cmake:112 (FILE):
  file STRINGS file "/usr/include/python2.7/patchlevel.h" cannot be read.
This error message occurs because the necessary Python 2.7 development package is not installed. In step #2 it gives a very big list of packages that have to be installed, among which is "python-devel". Make sure you have installed it.
me3840 likes this.
wyldckat is offline   Reply With Quote

Old   October 13, 2015, 00:05
Default
  #3
Senior Member
 
Join Date: Nov 2010
Posts: 682
Rep Power: 12
me3840 is on a distinguished road
I must have missed the extra lines earlier, everything is working now. Thanks for your help
wyldckat likes this.
me3840 is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenFOAM 2.4.x on CentOS 6.5 kpsl OpenFOAM Installation 2 July 27, 2015 06:50
Openfoam to paraview kd55 OpenFOAM Paraview & paraFoam 8 January 5, 2014 18:58
New OpenFOAM Forum Structure jola OpenFOAM 2 October 19, 2011 06:55
OpenFOAM 1.6 package - CentOS 5.3 x86_64 linnemann OpenFOAM Installation 36 September 2, 2009 12:46
64bitrhel5 OF installation instructions mirko OpenFOAM Installation 2 August 12, 2008 18:07


All times are GMT -4. The time now is 10:08.