CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > OpenFOAM > OpenFOAM Installation

[OpenFOAM.org] 4.1: Bashrc file problem

Register Blogs Members List Search Today's Posts Mark Forums Read

Like Tree2Likes
  • 1 Post By FlyBob91
  • 1 Post By wyldckat

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   October 14, 2016, 15:39
Talking 4.1: Bashrc file problem
  #1
Senior Member
 
FlyBob91's Avatar
 
Join Date: Mar 2016
Location: Bergamo
Posts: 153
Rep Power: 6
FlyBob91 is on a distinguished road
Hello to everyone,
i'm trying to install the new OpenFOAM version 4.1 on Ubuntu 16.04 LTS by following the guide but i think there is a passage not explained.
I'm not installing it in /opt/ but in $home/my_name/OpenFOAM/
In the folrder OpenFOAM there are OpenFOAM-4.1 and ThirdParty-4.1

Now i'm at the point i have to add the line to the home bashrc file and i added this line always following the guide

HTML Code:
source $HOME/OpenFOAM/OpenFOAM-4.1/etc/bashrc
and this is the result on terminal

Code:
bash: /home/roby/OpenFOAM/OpenFOAM-4.x/etc/config.sh/functions: File o directory non esistente
bash: /home/roby/OpenFOAM/OpenFOAM-4.x/bin/foamEtcFile: File o directory non esistente
_foamSource: comando non trovato
_foamEval: comando non trovato
bash: /home/roby/OpenFOAM/OpenFOAM-4.x/bin/foamCleanPath: File o directory non esistente
bash: /home/roby/OpenFOAM/OpenFOAM-4.x/bin/foamCleanPath: File o directory non esistente
bash: /home/roby/OpenFOAM/OpenFOAM-4.x/bin/foamCleanPath: File o directory non esistente
_foamSource: comando non trovato
_foamSource: comando non trovato
bash: /home/roby/OpenFOAM/OpenFOAM-4.x/bin/foamEtcFile: File o directory non esistente
_foamSource: comando non trovato
bash: /home/roby/OpenFOAM/OpenFOAM-4.x/bin/foamEtcFile: File o directory non esistente
_foamSource: comando non trovato
bash: /home/roby/OpenFOAM/OpenFOAM-4.x/bin/foamEtcFile: File o directory non esistente
_foamSource: comando non trovato
bash: /home/roby/OpenFOAM/OpenFOAM-4.x/bin/foamEtcFile: File o directory non esistente
_foamSource: comando non trovato
bash: /home/roby/OpenFOAM/OpenFOAM-4.x/bin/foamEtcFile: File o directory non esistente
_foamSource: comando non trovato
bash: /home/roby/OpenFOAM/OpenFOAM-4.x/bin/foamCleanPath: File o directory non esistente
bash: /home/roby/OpenFOAM/OpenFOAM-4.x/bin/foamCleanPath: File o directory non esistente
bash: /home/roby/OpenFOAM/OpenFOAM-4.x/bin/foamCleanPath: File o directory non esistente
bash: /home/roby/OpenFOAM/OpenFOAM-4.x/etc/config.sh/functions: File o directory non esistente
i think i should change something in the bashrc file in the $HOME/OpenFOAM/OpenFOAM-4.1/etc/ because maybe is set up for the /opt/ installation.
Could someone explain me what to change?

Thanks a lot
FlyBob91 is offline   Reply With Quote

Old   October 14, 2016, 21:07
Default
  #2
Senior Member
 
FlyBob91's Avatar
 
Join Date: Mar 2016
Location: Bergamo
Posts: 153
Rep Power: 6
FlyBob91 is on a distinguished road
OK i solved the problem

As i mentioned the error was in

HTML Code:
HOME/OpenFOAM/OpenFOAM-4.1/etc/bashrc
Opened the bashrc file it's simply necessary to change

HTML Code:
export WM_PROJECT_VERSION=4.x
in

HTML Code:
export WM_PROJECT_VERSION=4.1
for the 4.1 OpenFOAM version.

i hope this could help someone
wyldckat likes this.
FlyBob91 is offline   Reply With Quote

Old   October 16, 2016, 10:44
Default
  #3
Retired Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 10,958
Blog Entries: 45
Rep Power: 122
wyldckat is a name known to allwyldckat is a name known to allwyldckat is a name known to allwyldckat is a name known to allwyldckat is a name known to allwyldckat is a name known to all
Greetings Roberto,

Many thanks for spotting this! I've reported it here: http://bugs.openfoam.org/view.php?id=2293

It should be fixed as soon as possible.

For others with the same problem, if you want to use a single command that does this fix, run the following from within the folder "OpenFOAM-4.1":
Code:
sed -i -e 's=4\.x=4.1=' etc/bashrc etc/cshrc
Best regards,
Bruno
FlyBob91 likes this.
__________________
wyldckat is offline   Reply With Quote

Old   October 17, 2016, 08:32
Default
  #4
Senior Member
 
FlyBob91's Avatar
 
Join Date: Mar 2016
Location: Bergamo
Posts: 153
Rep Power: 6
FlyBob91 is on a distinguished road
Quote:
Originally Posted by wyldckat View Post
I've reported it here: http://bugs.openfoam.org/view.php?id=2293

It should be fixed as soon as possible.
Thanks to you and your work Bruno.

Best regards,
Roberto
FlyBob91 is offline   Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
[swak4Foam] swak4foam for OpenFOAM 4.0 mnikku OpenFOAM Community Contributions 77 May 7, 2020 05:22
[swak4Foam] Problem installing swak_2.x for OpenFoam-2.4.0 towanda OpenFOAM Community Contributions 6 September 5, 2015 22:03
Problem compiling a custom Lagrangian library brbbhatti OpenFOAM Programming & Development 2 July 7, 2014 12:32
friction forces icoFoam ofslcm OpenFOAM 3 April 7, 2012 11:57
DecomposePar links against liblamso0 with OpenMPI jens_klostermann OpenFOAM Bugs 11 June 28, 2007 18:51


All times are GMT -4. The time now is 18:31.