CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > OpenFOAM > OpenFOAM Installation

[OpenFOAM.org] Invalid encoding error during generation of libOpenFOAM.so when building with clang.

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   May 6, 2020, 02:06
Default Invalid encoding error during generation of libOpenFOAM.so when building with clang.
  #1
New Member
 
saurabh
Join Date: May 2020
Posts: 2
Rep Power: 0
kavi.saurabh is on a distinguished road
Hi all,

I am trying to build openfoam-7 with clang compiler version 10. I am getting an error which I am unable to resolve. The error is coming during generation of libOpenFOAM.so.
The error is:-
LLVM ERROR: Invalid encoding
clang-10: error: linker command failed with exit code 1 (use -v to see invocation)

This invalid encoding error is not coming while generation of other libraries.
When I tried generating static library version of libOpenFOAM, it is getting generated without any issue. I have one question, instead of using dynamic libraries can I use static one as I am unable to resolve clang error which I am getting.

Thanks.

Last edited by kavi.saurabh; May 6, 2020 at 07:26. Reason: points were not clear
kavi.saurabh is offline   Reply With Quote

Old   May 12, 2020, 13:53
Default
  #2
HPE
Senior Member
 
Herpes Free Engineer
Join Date: Sep 2019
Location: The Home Under The Ground with the Lost Boys
Posts: 658
Rep Power: 8
HPE is on a distinguished road
Hi,

- If you believe that it is a bug, please do report to .org issue tracker. You can find the link below.

Hope it helps.
HPE is offline   Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
[snappyHexMesh] Invalid Normals for source face to target face while making AMI? Sorabh OpenFOAM Meshing & Mesh Conversion 0 November 21, 2019 23:58
[foam-extend.org] Error compiling OpenFOAM-1.6-ext Canesin OpenFOAM Installation 137 January 20, 2016 14:56
parallel simulations - error message: "OPT_ITERATIONS: invalid option name" v8areu SU2 5 July 23, 2015 02:57
Compilation error OF1.5-dev on Suse10.3 darenyang OpenFOAM Installation 0 April 29, 2009 04:55
Phase locked average in run time panara OpenFOAM 2 February 20, 2008 14:37


All times are GMT -4. The time now is 20:30.