CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > OpenFOAM > OpenFOAM Meshing & Mesh Conversion

[Commercial meshers] "can not find faces using edges.."when using the ICEM mesh

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   March 17, 2020, 11:11
Post "can not find faces using edges.."when using the ICEM mesh
  #1
New Member
 
bany
Join Date: Nov 2019
Posts: 14
Rep Power: 3
bany is on a distinguished road
My mesh is built by ICEM with hanging nodes when using the refinement in ICEM. And when i convert it into OpenFOAM by fluent3dmeshtofoam with checkMesh being OK, the case can be calculated. But when i use the functionObjects which involves meshTool.C in controlDict, the error "can not find faces using edges.." comes.
More in detail, my domain is a cylinder. And i use the O-block to build the structured mesh in ICEM. To refine certain block, i use the refinement tool, which cause the hanging nodes and uncovered faces. But when i convert it into OpenFOAM using fluent3dmeshtofoam, the mesh is Ok as i check the mesh. So i think the fluent3dmeshtofoam can merge these hanging nodes, just like FLUENT which can deal with the 1=>2 ratio refinement. But when i run the case, i find the errors "can not find faces using edges..". Finally, i find the errors come from meshTool.C because i use the functionObjects which involves meshTool.C in controlDict.
You can find more detail in uncovered faces after refinement in 3D which is posted by me.
Attached Images
File Type: png the_final_mesh.png (64.5 KB, 2 views)
File Type: png the error.png (81.7 KB, 1 views)
Attached Files
File Type: zip prt0001.zip (27.0 KB, 0 views)
bany is offline   Reply With Quote

Old   March 31, 2020, 03:23
Default zipUpMesh
  #2
New Member
 
Maximilian Hansinger
Join Date: Mar 2020
Posts: 1
Rep Power: 0
mhansinger is on a distinguished road
I had the same error from the meshTools.C, also with a mesh generated with ICEM and hanging nodes. What you describe applies exactly to my setup, too.
I ran zipUpMesh and that fixed it for me.
mhansinger is offline   Reply With Quote

Old   March 31, 2020, 23:01
Default errors have gone
  #3
New Member
 
bany
Join Date: Nov 2019
Posts: 14
Rep Power: 3
bany is on a distinguished road
Quote:
Originally Posted by mhansinger View Post
I had the same error from the meshTools.C, also with a mesh generated with ICEM and hanging nodes. What you describe applies exactly to my setup, too.
I ran zipUpMesh and that fixed it for me.
I try to run zipUpMesh, it work well and the errors have gone.
And thank you very much!
Best wishes!
bany is offline   Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
[snappyHexMesh] sHM layer process keeps getting killed MBttR OpenFOAM Meshing & Mesh Conversion 4 August 15, 2016 03:21
[snappyHexMesh] SnappyHexMesh for internal Flow vishwa OpenFOAM Meshing & Mesh Conversion 24 June 27, 2016 08:54
[mesh manipulation] Importing Multiple Meshes thomasnwalshiii OpenFOAM Meshing & Mesh Conversion 18 December 19, 2015 18:57
[Commercial meshers] fluentMeshToFoam multidomain mesh conversion problem Attesz OpenFOAM Meshing & Mesh Conversion 12 May 2, 2013 10:52
[snappyHexMesh] external flow with snappyHexMesh chelvistero OpenFOAM Meshing & Mesh Conversion 11 January 15, 2010 19:43


All times are GMT -4. The time now is 01:04.