CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Visualization & Post-Processing Software > ParaView

[OpenFOAM] QXcbConnection: Could not connect to display :0

Register Blogs Members List Search Today's Posts Mark Forums Read

Like Tree5Likes
  • 3 Post By jijilam
  • 2 Post By jijilam

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   January 5, 2018, 14:52
Default QXcbConnection: Could not connect to display :0
  #1
New Member
 
Georg
Join Date: Dec 2017
Posts: 15
Rep Power: 4
Schurl is on a distinguished road
Hi,

until lunch i worked with openFoam and paraFoam and all of a sudden paraFoam won't start anymore.

i already reinstalled docker-ce and openFoam, but the error remains.
Here is the total message:

bash-4.2# paraFoam
Created temporary 'cavity.OpenFOAM'
QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-root'
No protocol specified
QXcbConnection: Could not connect to display :0


My System is Debian Stretch.
OpenFoam and docker-se packages/binaries are installed according the guides on their webpages.
I use them as root.

As i did not change anything on the system, i have no clue where to start searching to solve the issue. The search results here and with google did not help so far.

Could someone help me out please?

Thanks in advance
George
Schurl is offline   Reply With Quote

Old   May 11, 2018, 11:35
Default paraFoam not working!!!
  #2
Senior Member
 
Join Date: Jan 2012
Posts: 191
Rep Power: 10
itsme_kit is on a distinguished road
Hi everyone

I have installed the latest versions of OpenFoam and Paraview on my Mac system.

I ran the cavity case and tried to view results via the command "paraFoam", but I got following messages from terminal:

Created temporary 'cavity.OpenFOAM'
QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-ofuser'
QXcbConnection: Could not connect to display

Can anyone help me sort out what the problem is?

Thanks in advance
itsme_kit is offline   Reply With Quote

Old   May 11, 2018, 11:38
Default
  #3
Senior Member
 
Join Date: Jan 2012
Posts: 191
Rep Power: 10
itsme_kit is on a distinguished road
Hi Schurl

I had the same problem, have you already sorted it out?

Thanks in advance

Quote:
Originally Posted by Schurl View Post
Hi,

until lunch i worked with openFoam and paraFoam and all of a sudden paraFoam won't start anymore.

i already reinstalled docker-ce and openFoam, but the error remains.
Here is the total message:

bash-4.2# paraFoam
Created temporary 'cavity.OpenFOAM'
QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-root'
No protocol specified
QXcbConnection: Could not connect to display :0


My System is Debian Stretch.
OpenFoam and docker-se packages/binaries are installed according the guides on their webpages.
I use them as root.

As i did not change anything on the system, i have no clue where to start searching to solve the issue. The search results here and with google did not help so far.

Could someone help me out please?

Thanks in advance
George
itsme_kit is offline   Reply With Quote

Old   July 14, 2018, 18:21
Default
  #4
New Member
 
Kiran
Join Date: Jul 2018
Posts: 1
Rep Power: 0
kiranprasad is on a distinguished road
Same problem here.
kiranprasad is offline   Reply With Quote

Old   September 7, 2018, 07:29
Default
  #5
New Member
 
Aucune sélection
Join Date: Sep 2018
Posts: 2
Rep Power: 0
jijilam is on a distinguished road
Hi,

I am new user of openFoam. I installed it this week, I have mac os X machine, and I get same error when typing paraFoam to post-process cavity exercise given tutorials, So I use :

paraFoam -touch-all

to create data files formats cavity.OpenFOAM, cavity.foam and cavity.blockMesh

and then I copy cavity folder in my Documents directory as follows :

cp -r cavity /home/ofuser/workingDir/Documents


Then, I open Paraview and select cavity.OpenFOAM file in Documents directory to display it and it works all right
wyldckat, gravis and PanosK like this.
jijilam is offline   Reply With Quote

Old   December 8, 2018, 01:17
Default Error same as you
  #6
New Member
 
Join Date: Dec 2018
Posts: 4
Rep Power: 3
lgs19960514 is on a distinguished road

Error same as you
Code:
[ofuser@99e05d27cec3 cavity]$ Created temporary 'cavity.OpenFOAM'
QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-ofuser'
QXcbConnection: Could not connect to display
if you have solved this error, can you tell me how to make it?
All the best,
Frank

[Moderator note: this post was moved to here from another thread and was referring to what now is post #2 on this thread.]

Last edited by wyldckat; March 6, 2019 at 20:38. Reason: see "Moderator note:"
lgs19960514 is offline   Reply With Quote

Old   March 6, 2019, 15:30
Thumbs up
  #7
New Member
 
Panos Koniavitis
Join Date: Oct 2017
Posts: 6
Rep Power: 5
PanosK is on a distinguished road
Quote:
Originally Posted by jijilam View Post
Hi,

I am new user of openFoam. I installed it this week, I have mac os X machine, and I get same error when typing paraFoam to post-process cavity exercise given tutorials, So I use :

paraFoam -touch-all

to create data files formats cavity.OpenFOAM, cavity.foam and cavity.blockMesh

and then I copy cavity folder in my Documents directory as follows :

cp -r cavity /home/ofuser/workingDir/Documents


Then, I open Paraview and select cavity.OpenFOAM file in Documents directory to display it and it works all right
After few days of search and failures, you made my day! Thanks!
PanosK is offline   Reply With Quote

Old   March 11, 2019, 07:19
Default
  #8
New Member
 
Aucune sélection
Join Date: Sep 2018
Posts: 2
Rep Power: 0
jijilam is on a distinguished road
Quote:
Originally Posted by PanosK View Post
After few days of search and failures, you made my day! Thanks!
Happy to help !
arashgmn and PanosK like this.
jijilam is offline   Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
[OpenFOAM] OpenFoam V6 via Docker: "Could not connect to any X display" Boomessh ParaView 8 July 4, 2019 07:04
error: connect failed destroy FLUENT 7 March 18, 2018 15:59
Scheme Executable Terminating Prematurely ec44 Fluent UDF and Scheme Programming 1 April 6, 2015 04:34
[OpenFOAM] Xlib: extension "GLX" missing on display goldbeard ParaView 5 March 24, 2013 14:12
errors when installing openfoam2.1 on ubuntu12.o4 hewei OpenFOAM Installation 5 May 29, 2012 08:43


All times are GMT -4. The time now is 15:08.