CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > ANSYS > FLUENT

Export overset to Tecplot in batch mode

Register Blogs Members List Search Today's Posts Mark Forums Read

Like Tree1Likes
  • 1 Post By munjalpu

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   August 7, 2020, 04:45
Post Export overset to Tecplot in batch mode
  #1
New Member
 
Join Date: Aug 2020
Posts: 4
Rep Power: 2
sbuanzi is on a distinguished road
Hello everyone,

I'm dealing with a 3D transient simulation involving grid motion through dynamic mesh applied to overset blocks (one is fixed, the other one is rotating according to UDF).

I need to run it in batch mode through journal file and to post-process the solution with Tecplot. The problem is that I can't export it the right way to Tecplot: the overset hole cut "is not recognized" and I get the whole domain (dead cells included). Just as a try, I ran some iterations with gui: everything works as expected and the solution is exported properly only if I first initialize the mesh and visualize it with overset display option. Then the solution is exported properly. I've tried many solutions to export properly in batch mode, but none worked.

Does anyone know any solution/tricik?
I don't know if any other detail may be helpful.

Thank you in advance!
sbuanzi is offline   Reply With Quote

Old   September 1, 2020, 11:34
Default
  #2
New Member
 
munjalshah
Join Date: Dec 2016
Location: Buffalo,NY
Posts: 5
Rep Power: 5
munjalpu is on a distinguished road
There is a way to visualize it properly in the tecplot. you need follow below steps.

1. In fluent after you initialize the case, you need to select additional quantities to export during simulation. Export " overset cell type" variable. If you are using the journal file here is the command.

Code:
/solve/initialize/initialize-flow
/file/data-file-options
overse-cell-type
q
2. Once you have all the case and data files exported during the simulations, read them in tecplot using advance option. It should have "Load additional quantities" option.

(If you can't see the option, dont worry. Follow this steps: load the data files anways. Save the layout file. Open the layout file in notepad/notepad++. It should have line stating the name of data file you loaded, probably 2nd or 3rd line. Go to end of that line and add this option....
before: "AverageToNodes" "No" "SaveUncompressedFiles" "No"
after: "AverageToNodes" "No" "LoadAdditionalQuantities" "Yes" "SaveUncompressedFiles" "No"
)
3. Go to Plot->Blanking->Value Blanking and choose overset-cell-type in "Blank when" drop down. Also choose "less then equal to" in second drop down and Put '0' as value.
4. Check "active" and "include value blanking".

Fluent assigns values to each type of overset cell. See manual for more information. Here
sbuanzi likes this.

Last edited by munjalpu; September 1, 2020 at 11:36. Reason: formatting
munjalpu is offline   Reply With Quote

Old   September 3, 2020, 08:44
Default
  #3
New Member
 
Join Date: Aug 2020
Posts: 4
Rep Power: 2
sbuanzi is on a distinguished road
Thank you very much munjalpu!

Your steps did the job
sbuanzi is offline   Reply With Quote

Reply

Tags
batch, export, fluent, overset, tecplot

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fluent Batch Mode error: No error handler available hahs FLUENT 0 September 14, 2018 01:29
Cfd post compatible export on batch mode ryma29 FLUENT 0 January 17, 2018 15:15
A CFX-POST error (ver 14.5.7) wangyflp88 CFX 2 July 22, 2017 00:17
exporting data from Fluent in batch mode without exporting entire design point nnvoro FLUENT 5 May 6, 2013 01:51
export in batch mode, programing? Benjamin FLUENT 0 April 11, 2006 05:03


All times are GMT -4. The time now is 20:44.