CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > FLUENT

Parallel Error in ANSYS FLUENT 12

Register Blogs Members List Search Today's Posts Mark Forums Read

Like Tree5Likes

Reply
 
LinkBack Thread Tools Display Modes
Old   September 6, 2010, 21:59
Question Parallel Error in ANSYS FLUENT 12
  #1
New Member
 
zeusxx's Avatar
 
Alex Hon
Join Date: Sep 2010
Posts: 4
Rep Power: 8
zeusxx is on a distinguished road
I always get error message when I using ANSYS FLUENT 12 with a Windows 7 x64 system and ANSYS 12 x64.



unable to read the cmd header on the pmi context, Undefined dynamic error code.

999999 (..\src\mpsystem.c@1149): mpt_read: failed: errno = 10054

999999: mpt_read: error: read failed trying to read 4 bytes: Invalid argument
unable to read the cmd header on the pmi context, Undefined dynamic error code.
unable to read the cmd header on the pmi context, Undefined dynamic error code.
unable to read the cmd header on the pmi context, Undefined dynamic error code.

job aborted:
rank: node: exit code[: error message]
...
The Parallel FLUENT process could not be started.


-------------------------------------------


999999 (..\src\mpsystem.c@1149): mpt_read: failed: errno = 10054

999999: mpt_read: error: read failed trying to read 4 bytes: No such file or directory
unable to read the cmd header on the pmi context, Undefined dynamic error code.
SuspendThread failed with error 5 for process 2:627A4F0C-CA4B-4435-B90A-4D110B465C35:'D:\ANSYSI~1\v121\v121\fluent\fluent1 2.1.2\win64\3ddp_node\fl_mpi1212.exe -mport 10.10.10.193:10.10.10.193:49174:0 node -mpiw mpich2 -pic ethernet'
unable to suspend process.
unable to read the cmd header on the pmi context, Undefined dynamic error code.
unable to read the cmd header on the pmi context, Undefined dynamic error code.
unable to read the cmd header on the pmi context, Undefined dynamic error code.
received kill command for a pmi context that doesn't exist: unmatched id = 1
received kill command for a pmi context that doesn't exist: unmatched id = 0

job aborted:
rank: node: exit code[: error message]
...
The Parallel FLUENT process could not be started.





Can anyone help me or provide ideas to fix this problem?

Thank you very much~
zeusxx is offline   Reply With Quote

Old   December 20, 2010, 05:31
Default tem
  #2
New Member
 
Join Date: Dec 2010
Posts: 2
Rep Power: 0
Stone is on a distinguished road
hi ,
did u solve your problem in fluent .
I too got the same problem.If u got the solution please help me.



my email id :dy-369@163.com

thank you!
Stone is offline   Reply With Quote

Old   December 24, 2010, 06:02
Default
  #3
New Member
 
Join Date: Oct 2010
Posts: 25
Rep Power: 8
sunflower is on a distinguished road
Hi Zeusxx,

Have you solved your problem? Actually I have the same problem as yours. If you find the solution, would you please tell me? Thanks.
sunflower is offline   Reply With Quote

Old   January 18, 2011, 09:04
Default
  #4
New Member
 
NeNaD
Join Date: Mar 2010
Posts: 16
Rep Power: 8
skinnyfluid is on a distinguished road
Do some PrtScrn (print screen) with your setting up parallel and send me. I can help you only if i see your steps in setup window.
skinnyfluid is offline   Reply With Quote

Old   January 18, 2011, 09:47
Default
  #5
New Member
 
zeusxx's Avatar
 
Alex Hon
Join Date: Sep 2010
Posts: 4
Rep Power: 8
zeusxx is on a distinguished road
thank u very much. I solved this problem several months ago. Thank u all the same.
raj kumar saini likes this.
zeusxx is offline   Reply With Quote

Old   January 26, 2011, 18:34
Default Same error - How did you solve it?
  #6
ADI
New Member
 
A. N.
Join Date: Oct 2009
Posts: 10
Rep Power: 9
ADI is on a distinguished road
Send a message via MSN to ADI
Hello All,

I get the same error only when I run a Composition PDF transport model in the species / transport modelling. Every other model has no problem running in parallel. Can you please tell me how I can solve this problem?
ADI is offline   Reply With Quote

Old   January 26, 2011, 18:37
Default Screen-shot
  #7
ADI
New Member
 
A. N.
Join Date: Oct 2009
Posts: 10
Rep Power: 9
ADI is on a distinguished road
Send a message via MSN to ADI
Here is a screen shot attached.
Attached Images
File Type: jpg fluent parallel error.jpg (69.1 KB, 510 views)
ADI is offline   Reply With Quote

Old   March 5, 2011, 09:06
Default
  #8
New Member
 
Chang Zhixin
Join Date: Mar 2011
Posts: 2
Rep Power: 0
Kevin.C is on a distinguished road
Hello All,

I got the same problem when I read mesh file in fluent 6.3, and my PC's Cpu is Inter i7 930 which has 8 processes. if all of 8 processes turned on , this problem would appeard. And if less than 7 processes turned on, it will be no problem. But i don't know why.

i think this maybe useful for you.

Kevin. C
Kevin.C is offline   Reply With Quote

Old   March 7, 2011, 20:24
Default
  #9
ADI
New Member
 
A. N.
Join Date: Oct 2009
Posts: 10
Rep Power: 9
ADI is on a distinguished road
Send a message via MSN to ADI
Hello Kevin,

I have a Core i7 860 myself and it is the same setup basically. I tried your trick but I was unsuccessful. Let me know what else you had to modify.
__________________
Adi.
ADI is offline   Reply With Quote

Old   March 9, 2011, 08:49
Default
  #10
New Member
 
Chang Zhixin
Join Date: Mar 2011
Posts: 2
Rep Power: 0
Kevin.C is on a distinguished road
Hi,Adi,

Maybe you need to turn off more processers and try again. And i found another route lately, you can setup all options and save case file firstly in single process environment, then iterate it in parallel environment, it will be ok. if still unsccessful, try rebuild your mesh.

Kevin.C
Kent_Neo and Traction like this.
Kevin.C is offline   Reply With Quote

Old   June 27, 2011, 20:11
Default
  #11
Member
 
Join Date: Mar 2011
Posts: 38
Rep Power: 7
aleisia is on a distinguished road
hi zeuxxx, can you please share with us what you did to solve the problem?
Thanks!

Quote:
Originally Posted by zeusxx View Post
thank u very much. I solved this problem several months ago. Thank u all the same.
aleisia is offline   Reply With Quote

Old   August 27, 2011, 07:47
Default
  #12
New Member
 
Tiziano Vaglini
Join Date: Sep 2010
Location: Pisa
Posts: 1
Rep Power: 0
Vaglio is on a distinguished road
Hi,
I know this is the fluent forum, and i0m asking about Star-CCM but my problem is the same when i try to start a parallel simulation in Star-CCM 4.04...
For Fluent is a problem of the software itself or something related to external program like Mpich?

Many Thanks.
Tiziano
Vaglio is offline   Reply With Quote

Old   June 8, 2012, 10:41
Default possible solution
  #13
New Member
 
TCH
Join Date: Jul 2010
Location: Beijing City
Posts: 15
Rep Power: 8
Solarberiden is on a distinguished road
Regulate up your pagefile as follow:

My computer>properties>advanced>Performance>Configura tion>
advanced>modify
Regulate up your possible pagefile scale by 1.0~2.0 time size of physical memory
Solarberiden is offline   Reply With Quote

Old   February 15, 2013, 08:48
Default
  #14
New Member
 
Join Date: Oct 2012
Posts: 2
Rep Power: 0
akshaydongre is on a distinguished road
Having the same problem. Reduced number of processors to 4. Not helping! I am using GRI 2.11 mechanism to describe chemistry.
Is it because the CHEMKIN mechanism which fails when used in parallel FLUENT Version 13.0?

Akshay
akshaydongre is offline   Reply With Quote

Old   March 13, 2013, 09:48
Default
  #15
New Member
 
Amjad Farah
Join Date: Mar 2013
Posts: 11
Rep Power: 5
amjadfirst is on a distinguished road
Seems to be a problem all around the web but I can't figure out a solution to it. I've got it installed on a number of computers and what I've noticed is that I get this error on AMD processors and Intel ones seem to run fine. Anyone had a similar case?

Error code:

999999 (..\src\mpsystem.c@1149): mpt_read: failed: errno = 10054

999999: mpt_read: error: read failed trying to read 4 bytes: Invalid argument
MPI Application rank 0 exited before MPI_Finalize() with status -1073741819
The Parallel FLUENT process could not be started.

Amjad
amjadfirst is offline   Reply With Quote

Old   March 13, 2013, 11:10
Exclamation My solution
  #16
New Member
 
zeusxx's Avatar
 
Alex Hon
Join Date: Sep 2010
Posts: 4
Rep Power: 8
zeusxx is on a distinguished road
I am so sorry that I didn't come back this forum for a long time

Now I post my experience and I hope it can help someone

I am not sure whether my experience works well...



if you use Win7, try to go to the [Control Panel] --> [Program and function] --> [Open or Close Windows function]

under the menu, MAKE SURE you select ALL terms in "Microsoft .NET Framework 3.5.1"

then it is OK


Maybe the translation I wrote above is not completely correct, because I use a Win7 in Chinese version. but I think you can understand what I mean
zeusxx is offline   Reply With Quote

Old   March 13, 2013, 14:45
Default
  #17
New Member
 
Amjad Farah
Join Date: Mar 2013
Posts: 11
Rep Power: 5
amjadfirst is on a distinguished road
Thanks for your reply, I tried that and didn't work for me
I tried restarting the computer and still nothing. Maybe it was a slightly different problem that you had.

Amjad
amjadfirst is offline   Reply With Quote

Old   March 14, 2013, 00:54
Default u'd better check UDF
  #18
New Member
 
zeusxx's Avatar
 
Alex Hon
Join Date: Sep 2010
Posts: 4
Rep Power: 8
zeusxx is on a distinguished road
Quote:
Originally Posted by amjadfirst View Post
Thanks for your reply, I tried that and didn't work for me
I tried restarting the computer and still nothing. Maybe it was a slightly different problem that you had.

Amjad
maybe u'd better check ur UDF firstly

try to find whether u use codes about UDM or UDS in the UDF, and make sure you open UDM in the DEFINE menu
zeusxx is offline   Reply With Quote

Old   March 14, 2013, 11:17
Default
  #19
New Member
 
Amjad Farah
Join Date: Mar 2013
Posts: 11
Rep Power: 5
amjadfirst is on a distinguished road
I don't use UDF's, I haven't actually gotten around to open a case.. I just try to read a mesh or a simple case that I prepared on another computer and nothing opens, same error for everything I try to open.
amjadfirst is offline   Reply With Quote

Old   June 18, 2013, 06:29
Default
  #20
Senior Member
 
Join Date: May 2011
Posts: 231
Rep Power: 8
Kanarya is on a distinguished road
hi,
I have the same problem...what did you mean with 'open UDM in the DEFINE menu' because I am using in define_mass_transfer function C_UDMI but it doesnt work in parallel...

thanks in advance!!!
Quote:
Originally Posted by zeusxx View Post
maybe u'd better check ur UDF firstly

try to find whether u use codes about UDM or UDS in the UDF, and make sure you open UDM in the DEFINE menu
Kanarya is offline   Reply With Quote

Reply

Tags
ansys 12, fluent, parallel error

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
problem of running parallel Fluent on linux cluster ivanbuz FLUENT 12 November 16, 2016 14:38
drag coefficient in ansys fluent 12.0 krishna FLUENT 18 May 2, 2013 13:29
Fluent v6.3.26 better than Ansys v12.1 jemyungcha FLUENT 2 August 24, 2012 23:10
Fluent parallel license problem brothershuai Main CFD Forum 0 July 1, 2009 15:41
Parallel Fluent with Mandrake Daniel Dotta FLUENT 1 May 19, 2005 15:30


All times are GMT -4. The time now is 17:03.