CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > OpenFOAM > OpenFOAM Installation

[OpenFOAM.org] Install fireFoam correct

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   January 13, 2023, 05:30
Unhappy Install fireFoam correct
  #1
New Member
 
Franco
Join Date: Jan 2023
Posts: 1
Rep Power: 0
FrancoCav is on a distinguished road
Hi everyone


I'm very new to OpenFOAM but need it to try something with pyrolysis. So I saw there is a fireFoam solver and with examples.


I'm using Ubuntu Version 22.04 in VM and have installed Openfoam 10 and 9 which work. But they don't have the fireFoam solver.. So I looked to install another version of openfoam which has the firefoam integrated. I saw the openfoam 5.x in the github, but I have error to compile it and I think it's because of my ubuntu version? I also tried to install with the instruction in the firefoam v1912 github to install openfoam v1912 but here I have also an error while compiling..


So I think I have to use Openfoam 10, which works how it is and upgrad it with the fireFoam solver? Is this possible?


Or is there another way how I can use this solver and the examples?


I'm sorry for my poor understanding and appreciate every help.
FrancoCav is offline   Reply With Quote

Old   November 1, 2023, 12:43
Question
  #2
New Member
 
Bruno B W
Join Date: Aug 2023
Posts: 5
Rep Power: 2
brunobw is on a distinguished road
Quote:
Originally Posted by FrancoCav View Post
Hi everyone


I'm very new to OpenFOAM but need it to try something with pyrolysis. So I saw there is a fireFoam solver and with examples.


I'm using Ubuntu Version 22.04 in VM and have installed Openfoam 10 and 9 which work. But they don't have the fireFoam solver.. So I looked to install another version of openfoam which has the firefoam integrated. I saw the openfoam 5.x in the github, but I have error to compile it and I think it's because of my ubuntu version? I also tried to install with the instruction in the firefoam v1912 github to install openfoam v1912 but here I have also an error while compiling..


So I think I have to use Openfoam 10, which works how it is and upgrad it with the fireFoam solver? Is this possible?


Or is there another way how I can use this solver and the examples?


I'm sorry for my poor understanding and appreciate every help.
Hi! Also be glad to get some directions on installing various versions of OF.
brunobw is offline   Reply With Quote

Old   November 2, 2023, 03:21
Default
  #3
Senior Member
 
Yann
Join Date: Apr 2012
Location: France
Posts: 1,104
Rep Power: 26
Yann will become famous soon enough
Hello Bruno,

You can install as many versions as you want, following the installation procedure on the website.
You will just have to load the proper version environment in your terminal to switch from one version to another with this command:

Code:
source path_to_your_OpenFOAM_install/etc/bashrc
Cheers,
Yann
Yann is offline   Reply With Quote

Reply

Tags
firefoam, installation, pyrolysis, ubuntu

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
how to correct turbulent variables in a solver chen wang OpenFOAM Programming & Development 2 August 13, 2019 08:40
[OpenFOAM.com] Installing v1612+ on Fedora 25 JonW OpenFOAM Installation 4 January 27, 2017 15:38
How can I install Openfaom-2.0.0 version. huecu588755 OpenFOAM 4 September 5, 2016 13:56
[OpenFOAM.com] Docker OpenFOAM install error on Mac OS X dersh OpenFOAM Installation 10 May 6, 2016 12:49
I can't install license for ANSYS Student Product jubair073 ANSYS 0 December 7, 2015 03:16


All times are GMT -4. The time now is 04:22.