CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > SU2 > SU2 Installation

Compiling problem on ubuntu

Register Blogs Members List Search Today's Posts Mark Forums Read

Like Tree1Likes
  • 1 Post By Mrc96

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   March 26, 2022, 10:17
Default Compiling problem on ubuntu
  #1
New Member
 
Salvatori Marco
Join Date: Dec 2020
Posts: 3
Rep Power: 5
Mrc96 is on a distinguished road
Hi everyone, this is the first time I am writing here and I hope not to make too many mistakes.

I am trying to install SU2 on Ubuntu 21.10 and after launching the build with the command:


$ ./ninja -C build install

the terminal gives me some warnings.


and this






Finally, once the compilation is finished, if I try to launch SU2 from the terminal I return this error


Attached Images
File Type: jpg Schermata del 2022-03-26 15-51-43.jpg (198.2 KB, 55 views)
File Type: jpg Schermata del 2022-03-26 15-52-16.jpg (181.4 KB, 54 views)
File Type: jpg Schermata del 2022-03-26 15-54-23.jpg (51.7 KB, 55 views)
Mrc96 is offline   Reply With Quote

Old   March 26, 2022, 12:43
Default
  #2
pcg
Senior Member
 
Pedro Gomes
Join Date: Dec 2017
Posts: 466
Rep Power: 13
pcg is on a distinguished road
The first warnings are in external libraries that we don't control.
The last looks like you have some MPI configuration problem.
pcg is offline   Reply With Quote

Old   March 26, 2022, 13:19
Default
  #3
New Member
 
Salvatori Marco
Join Date: Dec 2020
Posts: 3
Rep Power: 5
Mrc96 is on a distinguished road
First of all thanks for the reply. Could the problem be related to the 21.10 version of ubuntu and cgns
?
Mrc96 is offline   Reply With Quote

Old   March 27, 2022, 18:42
Default
  #4
New Member
 
Salvatori Marco
Join Date: Dec 2020
Posts: 3
Rep Power: 5
Mrc96 is on a distinguished road
Quote:
Originally Posted by pcg View Post
The first warnings are in external libraries that we don't control.
The last looks like you have some MPI configuration problem.

I finally solved it. The problem was in installing the OpenMpi package through the APT repository. Until now it had always worked with SU2 and Ubuntu versions prior to 21.10, but now to make it work i had to install OpenMpi in a classic way.
ShengZhang likes this.
Mrc96 is offline   Reply With Quote

Old   April 8, 2024, 10:57
Default
  #5
New Member
 
zs
Join Date: Mar 2024
Posts: 2
Rep Power: 0
ShengZhang is on a distinguished road
Quote:
Originally Posted by Mrc96 View Post
I finally solved it. The problem was in installing the OpenMpi package through the APT repository. Until now it had always worked with SU2 and Ubuntu versions prior to 21.10, but now to make it work i had to install OpenMpi in a classic way.
Hello,Salvatori Marco. I am a beginner learning SU2,who is currently installing and compiling SU2. I encountered the same problem as you mentioned in your post, but I was lucky enough to find your post. Could you please tell me how to download Openmpi and if there are any related websites and tutorials available. Looking forward to your reply, thank you.
ShengZhang is offline   Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
[OpenFOAM.org] problem with instaling openfoam-2.0.0 on ubuntu 18.04 alireza.sh OpenFOAM Installation 11 November 22, 2018 11:09
Problem with Compiling UDFs in Ansys Fluent 13 (lnx64) Ali.beh Fluent UDF and Scheme Programming 3 August 27, 2018 04:22
[OpenFOAM.com] problem: compiling of1806 on ubuntu 14.04 gian93 OpenFOAM Installation 2 August 8, 2018 09:03
[foam-extend.org] Installation problem for foam-extend-3.2 on Ubuntu 14.04 ahmet OpenFOAM Installation 5 July 4, 2018 02:51
[foam-extend.org] Problem in installation of OpenFOAM-1.6-ext in OS Ubuntu 14.04 samar OpenFOAM Installation 9 July 2, 2017 19:17


All times are GMT -4. The time now is 19:39.