CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > OpenFOAM > OpenFOAM Meshing & Mesh Conversion

[blockMesh] blockMesh and checkMesh with Wedges Issue

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   August 27, 2015, 23:49
Default blockMesh and checkMesh with Wedges Issue
  #1
Member
 
Michu
Join Date: Jun 2015
Location: PA, USA
Posts: 31
Rep Power: 7
michu is on a distinguished road
Hello,

I am working on a project with a few wedges. I am making a simple 2D model. Attached is a picture of what I am creating. I create the blockMesh and it works, but with an interesting line:
Quote:
patch 5 (start: 2080 size: 1) name: frontAndBack
which I think is bad because you cant divide 1 by another integer. I think this is the reason why when I use checkMesh I get:
Quote:
***Zero or negative face area detected. Minimum area: 0
and
Quote:
*** Max skewness = 2.33928e+148, 1 highly skew faces detected which may impair the quality of the results
When I check in paraFoam (using the glyph method to show where the zero or negative face area is located) I realize it is at position 15 and 69, which is part of wedge number 4.

I tried changing the wedge from hex (15 15 21 20 69 69 21 20) to hex (20 15 21 20 47 69 75 74) and also changing the empty from (15 69 69 15) to (20 74 74 20) but that didn't work either and it still gave the same error in the checkMesh.

Any help or suggestions on what to do would be greatly appreciated!!!

Thank you,
~Michu
Attached Images
File Type: jpg Img.jpg (28.5 KB, 39 views)
michu is offline   Reply With Quote

Old   August 30, 2015, 03:14
Default
  #2
Member
 
Michu
Join Date: Jun 2015
Location: PA, USA
Posts: 31
Rep Power: 7
michu is on a distinguished road
Can anyone help? I would greatly appreciate it!

Thank you,
~Michu
michu is offline   Reply With Quote

Old   September 6, 2015, 06:03
Default
  #3
Member
 
Michu
Join Date: Jun 2015
Location: PA, USA
Posts: 31
Rep Power: 7
michu is on a distinguished road
I now know it is the 15 69 69 15 face causing the problem. As seen in the first picture this face is in the frontAndBack category, which is an Empty type. If I remove it from this category it goes into defaultFaces category, which is also an Empty type as can be seen in the second picture. This has a minimum area of 0, which makes sense because it's the edge of the wedge that you have to identify as empty when creating wedges.

I am not sure why this is causing a problem since all the other wedges have the same thing with their faces under the frontAndBack category and those do not cause a problem. Can anyone help?
Attached Images
File Type: png 1.PNG (32.6 KB, 16 views)
File Type: png 2.PNG (36.0 KB, 16 views)
michu is offline   Reply With Quote

Old   September 6, 2015, 14:05
Default
  #4
Retired Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 10,958
Blog Entries: 45
Rep Power: 122
wyldckat is a name known to allwyldckat is a name known to allwyldckat is a name known to allwyldckat is a name known to allwyldckat is a name known to allwyldckat is a name known to all
Quick answer: Don't expect people to be able to do magic and be clairvoyant
  1. Provide a small example case that demonstrates the location that has this problem, so that anyone can try to help you by looking and testing the same problem.
  2. Indicate which OpenFOAM version you're using.
This is pretty much explained here: http://www.cfd-online.com/Forums/ope...-get-help.html
wyldckat is offline   Reply With Quote

Reply

Tags
blockmesh, mesh, wedge, wedges, zero face area

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
[IHFOAM] The IHFOAM Thread Phicau OpenFOAM Community Contributions 356 December 9, 2020 10:19
[blockMesh] Managing the cellToRegion function in blockMesh JFM OpenFOAM Meshing & Mesh Conversion 1 October 22, 2018 08:36
[blockMesh] 3D mesher using blockMesh ce73stargazer OpenFOAM Meshing & Mesh Conversion 1 June 21, 2016 21:51
[mesh manipulation] strange result with blockMesh and checkMesh dener OpenFOAM Meshing & Mesh Conversion 0 August 22, 2013 09:40
BlockMesh CheckMesh error Help!!! deepaktbabu OpenFOAM 0 March 11, 2012 13:40


All times are GMT -4. The time now is 13:26.